Tabs exhibit buggy behavior when Bookmark Toolbar Items are placed next to it

RESOLVED DUPLICATE of bug 603817

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 603817
7 years ago
6 years ago

People

(Reporter: J.K, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

When using customize to place Bookmark Toolbar Items to the left or right of tabs, both the tabs and the bookmark items begin to display a very strange behavior. 

Say you placed the Bookmark Toolbar Items to the left of the tabs. When you try to scroll through the tabs the tab area using the left arrow, it begins to expand and obscure the the Bookmark items. The obscured items are not listed in it's dropdown menu. Clicking the right arrow causes the tab area to contract; any obscured bookmarks hidden after first placing them beside the tabs will not be revealed.

Furthermore, clicking and dragging a bookmark causes the bookmark items to update (ex. obscured items get listed in dropdown menu), but also duplicates it.

Reproducible: Always

Steps to Reproduce:
1.place Bookmark Toolbar Items next to tabs
2.scroll through tabs
Version: unspecified → Trunk

Comment 2

6 years ago
Mozilla/5.0 (Windows NT 6.1; rv:13.0a1) Gecko/20120213 Firefox/13.0a1
Mozilla/5.0 (Windows NT 6.1; rv:10.0.1) Gecko/20100101 Firefox/10.0.1

The scrolling issue doesn't reproduce on the latest Firefox builds, but the tabs bar and Bookmarks toolbar still exhibit buggy behavior when placed next to each other and the user opens or closes tabs.

STR:
1. Launch Firefox with a fresh profile.
2. Add some bookmarks to the Bookmarks toolbar (this issue reproduces with only the 2 bookmars that come with the fresh profile but it is more visible with more bookmarks).
3. Place the Bookmarks toolbar next to the tabs bar.
4. Open multiple tabs until the tabs bar stops extending.
5. Click on the ">>" icon displayed instead of the bookmarks.

Case1:
6. Right-click on a tab and select "Close other tabs".

Case2:
7. Close the tabs one by one leaving only one tab open.

Actual Results:
Case1:
When the user clicks the ">>" icon, only the last bookmark from the toolbar is listed in the opened contextual menu (If the user had enough bookmarks to have some in that menu before step 4, only those that were in the menu at step 4 are listed now too).

When the Bookmarks toolbar is placed on the left side of the tabs bar, after the user clicks "Close other tabs" and only one tab remains open, the bookmarks still don't appear in the Bookmarks toolbar nor in the ">>" menu (sometimes the 1st bookmark on the toolbar is displayed but the rest are still missing). At this point, the tabs bar gets hidden sometimes and only the "<", ">", and "+" buttons are still displayed on it (although one tab is open, it is not displaye on the bar).

When the Bookmarks toolbar is placed on the right side of the tabs bar, the same issue reproduces, except that the open tab is displayed in the tabs bar.

The tabs bar gets hidden the same way when resizing the Firefox window.

Case2:
When closing the tabs from the "x" buttons on them, everything works fine. When closing them by middle-clicking on the them, the bookmarks don't appear even when there is only one tab open. In this case the ">>" icon is not displayed on the Bookmarks toolbar either.

An issue that happens in all the cases is that, if the Bookmarks toolbar was not displayed in Firefox before moving it next to the tabs bar, the user can check the View->Toolbars->Bookmarks Toolbar option and an empty toolbar is displayed in the default location of the Bookmarks toolbar.

Please let me know if u prefer I log any of these issue separately.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think there are several issues here which all related to having the Bookmarks Toolbar in a custom location:

1) Show More Bookmarks (>>) only displays one bookmark
2) Automatic resizing of tab-bar does not revert to original sizing when tabs are closed
3) Resizing the window causes tab-bar rendering issues including overlapping buttons and disappearing tabs
4) Bookmarks toolbar does not resize, show >> when closing tabs with Middle-click
5) Disable bookmarks toolbar does not remove it from the custom location, re-enabling adds an empty one below the location bar
6) Moving bookmarks bar to a custom location leaves behind an empty toolbar

NOTE: I cannot reproduce #4

Even though all of these are manifested through the same root action, I think they are all different issues and should all be filed in separate bugs. 

Ioana, please take care of this and we will close this bug.

Comment 4

6 years ago
Some of these issues might be fixed by my patch for Bug 603817. Definitely 1). I'm not seeing 2). I'm also not seeing 4), though that might be unrelated to the patch.

Comment 5

6 years ago
Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/16.0 Firefox/16.0 (20120712030541)

Issues 1, 2 and 4 don't reproduce anymore.
Two new bugs were logged for the remaining issues (5 and 6 fit together): bug 773600 and bug 773605.

Marking the bug as fixed since Owen's patch fixed the part of it that's not going in the newly filed bugs.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 603817
You need to log in before you can comment on or make changes to this bug.