Closed Bug 64396 Opened 20 years ago Closed 14 years ago

biff arrow doesn't pop up in new nav window

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Future

People

(Reporter: schut, Assigned: neil)

References

(Blocks 1 open bug)

Details

(Keywords: fixed-seamonkey1.1b)

Attachments

(1 file)

Build 2001010420 Win32.

If you have new mail while in navigator (arrow pops up in task bar) and open a
new navigator window (ctrl-n), this new window does *not* show the green arrow
in the taskbar. Imho, while this green arrow should be for global biff, it
should appear in every window, also new ones.
QA Contact: esther → fenella
I see this bug as well.  Changing status to NEW. Adding myself to CC list.

OS: Win2k SP1
Moz Build: 2001011704 Win32 Talkback
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20010117
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assign to Sheelar
QA Contact: fenella → sheelar
worksforme,using commmercial trunk build 2001020608 on win98 and linux 
biff arrow seen in nav window when there is a new mail.  
Reporter can you download latest build and try again.thanks.   
Tried on build 2001021304 winNT 4.0. (clean install, new profile). Still seeing
this bug.
Reporter,
Are you still seeing this problem on winNT or win98.  Because as I said before
windows 98 on build 2001022606 I see the biff arrow in the taskbar in navigator
window.  Can you download the above build and see if this works and if does
please mark it w4me. But I have a migrated profile.
Comments from reporter:

Just tried on build 2001022705 win32, winNT 4.0 machine.
Bug is still alive.

Remind that the problem is *not* that the biff arrow does not appear in a nav
window. The problem is that, when you open a new nav window with ctrl-n after
the biff arrow appeared in your nav window, this new nav window opens and loads
correctly but does *not* show the biff arrow.
I do not have a migrated profile, btw.
sorry, misread the summary. This still exists on all platforms. (2001-03-08-09 
build) However, if you have more than one navigator window open and then the 
biff goes of and gets mail this results in biff arrow showing on all the window 
but all the new windows after the message arrival does not have the biff arrow.

Nominating this bug.  Because the user might rely on the arrival of new mail 
with the biff visual. And the visual should be reflected in all the navigator 
windows.
Keywords: nsbeta1
marking nsbeta1- and reassigning to racham.
Assignee: sspitzer → racham
Keywords: nsbeta1nsbeta1-
Target Milestone: --- → Future
adding this to biff tracking bug 36011
Blocks: biff
*** Bug 105025 has been marked as a duplicate of this bug. ***
QA Contact: sheelar → stephend
mass re-assign.
Assignee: racham → sspitzer
*** Bug 86868 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
It would be very nice to have this fixed, Notice that dup bug 105025 and bug
284923 in particular stress the usefulness of clicking the mail icon on taskbar
in any window (browser, composer etc) to "get new mail". 4xp
Keywords: 4xp
OS: Windows 98 → All
Hardware: PC → All
Assignee: sspitzer → mail
Attached patch Proposed patchSplinter Review
Scott, can you confirm that this is a SeaMonkey-only patch? While you seem to be packaging mailTasksOverlay.xul you don't appear to actually use it.
Assignee: mail → neil
Status: NEW → ASSIGNED
Attachment #242319 - Flags: superreview?(mscott)
Attachment #242319 - Flags: review?(mnyromyr)
Attachment #242319 - Flags: approval-seamonkey1.1b?
Comment on attachment 242319 [details] [diff] [review]
Proposed patch

a=me for 1.1b given it gets r/sr in time before we freeze for this beta.
Attachment #242319 - Flags: approval-seamonkey1.1b? → approval-seamonkey1.1b+
Comment on attachment 242319 [details] [diff] [review]
Proposed patch

yup this is seamonkey only.
Attachment #242319 - Flags: superreview?(mscott) → superreview+
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061011 SeaMonkey/1.1b

I have to wonder if there's some underlying problem in new window opens which clears the biffs.

1. fire up mailnews to get polling going
2. close all windows 
3. send a test e-mail
4. see test e-mail count badge in dock biff

If I open Chatzilla or browser windows, there will be no mail biff in the component bar, but the dock biff will still show the new arrival count.   If I then re-open mailnews, the dock count will go away and mailnews will open without green arrows in the component bar, or on the mail folder/inbox, as described in https://bugzilla.mozilla.org/show_bug.cgi?id=344066 .
Attachment #242319 - Flags: review?(mnyromyr) → review+
Fix checked in to the trunk and the branch.

Note that I don't think bug 105025 is really a dup of this.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.