need new sound for when new mail arrives.

VERIFIED INVALID

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED INVALID
17 years ago
13 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: marlon bishop)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

the current sound file (chrome://messenger/content/newmail.wav) needs to be
replaces.

The current one is really notify.wav, which is from Microsoft Corporation.

cc'ing marlon, jglick and hewitt.  perhaps one of you want to come up with
something?

Comment 1

17 years ago
If Microsoft hasn't released notify.wav under the MPL or a compatible license, 
surely this is a blocker bug?

We shouldn't provide our own sounds for the UI (except possibly on Linux/Unix), 
just as we don't provide our own fonts for the chrome. We should use the sound 
which is specified in the Sounds control panel on Windows, and in the Internet 
control panel on Mac OS.
"We should use the sound  which is specified in the Sounds control panel on
Windows, and in the Internet control panel on Mac OS."

take it to #64462

Status: NEW → ASSIGNED

Updated

17 years ago
QA Contact: esther → fenella
a new sound (of my own creation) is about to be checked in.

once I do that, I'll re-assign to marlon to come up with a better sound.
new sound checked in.

re-assigning to marlon.  marlon, have fun creating a new sound!
Assignee: sspitzer → marlon
Status: ASSIGNED → NEW
(Assignee)

Comment 5

17 years ago
no where do i see the word "audio", in this phrase: "graphic design"... 

but today is your lucky day, you see, it happens that my father's father was in 
Audio Design, for years...   i have a feeling i may have inherited some of his 
genes, so I am gonna give it my best shot! 

:P   

Comment 6

17 years ago
i vote for using
ftp://ftp.mozilla.org/pub/mozilla/libraries/bonus-tracks/rheet.wav

Comment 7

17 years ago
Isn't that file a little large?

Comment 8

17 years ago
Does Mozilla run on any platform which doesn't, in a typical OS installation, 
already provide a selection of sounds to choose from?

Comment 9

17 years ago
if at all possible, Mozilla should integrate the sound with the OS system. That
way users can change the sound to their liking. If not, there should be a pref
to browse to a wav file.

Comment 10

17 years ago
Peter: You can set the wav file Mozilla uses in your prefs.js, and I'm 
currently working on the neccessary UI to change the sound using a file picker. 
See the bug assigned to me: http://bugzilla.mozilla.org/show_bug.cgi?id=64462

Comment 11

17 years ago
Created attachment 22766 [details]
my prefs.js file - no setting for newmail sound!?

Comment 12

17 years ago
Ryan, i searched my prefs.js file for "wav" and "sound" but found nothing. I've
attached my (slightly modified) prefs.js file for your confirmation.

I also copied another sound file over the
\chrome\messenger\content\messenger\newmail.wav but i still get that dorky bipp
instead of the riing in the new wav file.

I use the latest nightly 20010116 installed to a "clean" dir.

Comment 13

17 years ago
The prefs that should be edited are below (add them to your prefs.js):

user_pref("mail.biff.play_sound",true);
user_pref("mail.biff.use_default_sound",false);
user_pref("mail.biff.sound_file","/some/directory/youvegotmail.wav");

Comment 14

17 years ago
Actually (after some experimenting), the format is:

user_pref("mail.biff.play_sound",true);
user_pref("mail.biff.use_default_sound",false);
user_pref("mail.biff.sound_file", "c:\\winnt\\media\\ringin.wav");

The third line directory path structure is different. I really hope this doesn't
screw up any sound features that may be implemented in the (hopefully near) future.

Is the current sound embedded in some jar or xul file? There must be a "cleaner"
way (without messing up the prefs.js) to replace the current wav file.

Comment 15

17 years ago
Yeah, the directory structure used in my example was for Linux -- it won't mess 
anything up the way you've got it set. Eventually, the file picker will just 
assign the path to the sound use of course use the appropriate structure.

Comment 16

17 years ago
nominating for nsbeta1.
Keywords: mailtrack, nsbeta1

Comment 17

17 years ago
Assign to Sheela
QA Contact: fenella → sheelar

Comment 18

17 years ago
Themes Triage Team marking nsbeta1-, if the mail team feels this is really 
important for nsbeta1 please let me know
Keywords: nsbeta1 → nsbeta1-
Priority: -- → P3

Comment 19

17 years ago
We really need this due to the fact that the placeholder is unacceptable. We can
use a system sound as a backup, but we can't go out with what we have today.
I can checking this file: http://bugzilla.mozilla.org/showattachment.cgi?
attach_id=24391

What do you think?  It's public domain and it sounds a whole lot better 
than "beep"!
http://bugzilla.mozilla.org/show_bug.cgi?id=67634 is the bug I filed a while 
ago.

Comment 22

17 years ago
I guess this means the end of my voiceover career :(
(Assignee)

Comment 23

17 years ago
i am handling this for nsbeta1



We have a short term solution for nsbeta1, which is a unique, professional sound 

we are borrowing from something else.  The long term solution, which is 

concurrently happening, is to contract a real "Sound Factory" type firm to do 

something that enhances the netscape emailing experience

Comment 24

17 years ago
Since Marlon's on it for the commercial build, keep this nsbeta1 plussed, 
please. For Moz, feel free to check in public domain sounds. Another commercial 
vs. moz divergence, but fine in this case.
renominating for nsbeta1+
Keywords: nsbeta1- → nsbeta1

Updated

17 years ago
Blocks: 36011

Comment 26

17 years ago
adding to biff tracking bug

Comment 27

17 years ago
Themes Triage Team marking nsbeta1+, Seth please let us know if this not needed 
by mail.
Keywords: nsbeta1 → nsbeta1+
Target Milestone: --- → mozilla0.9.1

Comment 28

17 years ago
This bug has no current comments.  Isn't it time to cut this from the beta?!
(Assignee)

Comment 29

17 years ago
yes unfortunately, we will not make this for beta
(Assignee)

Comment 30

17 years ago
can't wait to do this one. but can't get to it till 0.92
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 31

17 years ago
themes triage: moving to 0.9.3
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 32

17 years ago
Missed 0.9.3.
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Comment 33

17 years ago
this one is "homework".  since i do not have any sound/audio design software on
my  machine, i will have to take this home.  will attempt to fix for 0.9.4

Updated

17 years ago
Target Milestone: mozilla0.9.4 → ---

Comment 34

17 years ago
Mail sound notification don't work in today's builds

As mentionned before in this bug, one can use those lines 

user_pref("mail.biff.play_sound", true);
user_pref("mail.biff.use_default_sound", false);
user_pref("mail.biff.sound_file", "C:\\Windows\\newmail.wav");


in prefs.js to enable new mail sound notification. TYhis worked well before but
not in today's build. Worked in yesterday's build.

Win98SE, moz build 2001083003


I think this may have to do with the recent checkin in bug 71143 and if i'm
right   this would probably only affect windows builds as noted in bug 71143
(win32 only fix)

The checkin in bug 71143 may also fix bug 94522 though...

Can someone confirm and look into this ?





no longer works

Comment 35

17 years ago
Oops, error in last comment, "no longer works" was supposed to follow the first
line "Mail sound notification don't work in today's builds". You already figured
that didn't you.

Bit of additional info for the bug : I forgot to add that if the new mail sound
notitifation, testing in bug 94522 is blocked.

Comment 36

16 years ago
From a user comment in the NG, seems like the line
user_pref("mail.biff.play_sound",true);
is always deleted when running mozilla, even if you add it every time. I can
confirm this on all builds from august 30 to sept 10

Comment 37

16 years ago
that might explain why I no longer get my new mail notification beep in
2001090703 on win98.

Comment 38

16 years ago
Bug 99898 is about the new mail sound no longer playing. I mark it as a blocker.
Depends on: 99898
on mac and windows, we now use the system sound.  but for linux, we still don't
have anything.

this blocks #104174, as we'll need a sound to ship with the linux build, in
order to play something other than the default system beep.
Blocks: 104174

Comment 40

16 years ago
*** Bug 71123 has been marked as a duplicate of this bug. ***

Comment 41

16 years ago
added the following to my prefs.js but it still uses the default sound.

user_pref("mail.biff.play_sound",true);
user_pref("mail.biff.sound_file", "d:\\mmos2\\sounds\\notes.wav");
user_pref("mail.biff.use_default_sound", false);


OS/2 version build 2001110711

Comment 42

16 years ago
Bill: It is a decision by sspitzer@netscape.com (Seth Spitzer). He will not fix
the prefs. BTW, I don't understand that WONTFIX decision. There was a big
discussion on the subject. See bug 64462.

Updated

16 years ago
QA Contact: sheelar → stephend
no longer needed.  about to add back end code to make this pref controlled.  
still deciding on the UI.  see bug 64462.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Neither Mozilla nor Netscape has any plans to produce a sound, we are just going
to use the system's defaults or let the user choose from their own sounds.

See bug 64462 for the feature implementation, and bug 169414 for native file
paths, bug 169384 for the Mac file picker UI and bug 104174 for Linux's API.

Verified INVALID.
Status: RESOLVED → VERIFIED

Updated

15 years ago
No longer blocks: 104174
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.