Closed Bug 645872 Opened 9 years ago Closed 9 years ago

[D3D9] Entire browser window shows garbage when scrolling (black and white stripes) with GeForce 6150 LE

Categories

(Core :: Graphics, defect)

x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 644787

People

(Reporter: pavel.shkolnikov, Unassigned)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

Problem almost always reproducible on my machine (Vista, all latest service packs, Firefox 4.0). When viewing pages on Waterloo Record website, when scrolling, sometimes the whole browser screen is garbled, with black and white horizontal stripes. I have screenshots but this form does not allow to submit. Not always reproducible, but I see it consistently after a few minutes of going back and force, scrolling, etc.

Reproducible: Sometimes

Steps to Reproduce:
1. Go to Waterloo Record website (therecord.com)
2. Go to any article
3. Scroll up/down
4. Go to another article

Actual Results:  
Garbled screen, black and white horizontal stripes.

Expected Results:  
Page shown correctly

Garbled screen clears right after scrolling or refreshing.
I can email you some screenshot if you'd like.
The problem started right after switching from 3.6 (always latest version) to 4.0.
Please post the graphic section from about:support (enter as URL in Firefox) here.
After that disable the the hardware acceleration under tools/options/advanced/general and retry it.,
(In reply to comment #1)
> Please post the graphic section from about:support (enter as URL in Firefox)
> here.
> After that disable the the hardware acceleration under
> tools/options/advanced/general and retry it.,



  Application Basics

        Name
        Firefox

        Version
        4.0

        User Agent
        Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

        Adblock Plus
        1.3.3
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        Xmarks
        3.9.5
        true
        foxmarks@kei.com

        Microsoft .NET Framework Assistant
        1.2.1
        false
        {20a82645-c095-46ed-80e3-08825760534b}

        Adobe DLM (powered by getPlus(R))
        1.6.2.63
        false
        {E2883E8F-472F-4fb0-9522-AC9BF37916A7}

        Java Console
        6.0.07
        true
        {CAFEEFAC-0016-0000-0007-ABCDEFFEDCBA}

        Java Console
        6.0.11
        true
        {CAFEEFAC-0016-0000-0011-ABCDEFFEDCBA}

        Java Console
        6.0.13
        true
        {CAFEEFAC-0016-0000-0013-ABCDEFFEDCBA}

        Java Console
        6.0.15
        true
        {CAFEEFAC-0016-0000-0015-ABCDEFFEDCBA}

        Java Console
        6.0.16
        true
        {CAFEEFAC-0016-0000-0016-ABCDEFFEDCBA}

        Java Console
        6.0.17
        true
        {CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}

        Java Console
        6.0.20
        true
        {CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}

        Java Console
        6.0.22
        true
        {CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}

        Java Console
        6.0.23
        true
        {CAFEEFAC-0016-0000-0023-ABCDEFFEDCBA}

        Java Console
        6.0.24
        true
        {CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}

        AVG Safe Search
        10.0.0.1178
        false
        {3f963a5b-e555-4543-90e2-c3908898db71}

        AVG Security Toolbar
        6.010.006.004
        false
        avg@igeared

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.history_expire_days.mirror
        180

        browser.places.createdSmartBookmarks
        true

        browser.places.importBookmarksHTML
        false

        browser.places.importDefaults
        false

        browser.places.leftPaneFolderId
        -1

        browser.places.migratePostDataAnnotations
        false

        browser.places.smartBookmarksVersion
        2

        browser.places.updateRecentTagsUri
        false

        browser.startup.homepage
        http://www.yahoo.com/

        browser.startup.homepage_override.buildID
        20110318052756

        browser.startup.homepage_override.mstone
        rv:2.0

        extensions.lastAppVersion
        4.0

        general.useragent.extra.microsoftdotnet
        (.NET CLR 3.5.30729)

        keyword.URL
        http://ca.yhs.search.yahoo.com/avg/search?fr=yhs-avg&type=yahoo_avg_hs2-tb-web_ca&p=

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1301280715

        places.history.expiration.transient_current_max_pages
        62340

        places.last_vacuum
        1299984063

        print.print_printer
        Canon Inkjet i450

        print.printer_Canon_Inkjet_i450.print_bgcolor
        false

        print.printer_Canon_Inkjet_i450.print_bgimages
        false

        print.printer_Canon_Inkjet_i450.print_command

        print.printer_Canon_Inkjet_i450.print_downloadfonts
        true

        print.printer_Canon_Inkjet_i450.print_edge_bottom
        0

        print.printer_Canon_Inkjet_i450.print_edge_left
        0

        print.printer_Canon_Inkjet_i450.print_edge_right
        0

        print.printer_Canon_Inkjet_i450.print_edge_top
        0

        print.printer_Canon_Inkjet_i450.print_evenpages
        true

        print.printer_Canon_Inkjet_i450.print_footercenter

        print.printer_Canon_Inkjet_i450.print_footerleft
        &PT

        print.printer_Canon_Inkjet_i450.print_footerright
        &D

        print.printer_Canon_Inkjet_i450.print_headercenter

        print.printer_Canon_Inkjet_i450.print_headerleft
        &T

        print.printer_Canon_Inkjet_i450.print_headerright
        &U

        print.printer_Canon_Inkjet_i450.print_in_color
        true

        print.printer_Canon_Inkjet_i450.print_margin_bottom
        0.5

        print.printer_Canon_Inkjet_i450.print_margin_left
        0.5

        print.printer_Canon_Inkjet_i450.print_margin_right
        0.5

        print.printer_Canon_Inkjet_i450.print_margin_top
        0.5

        print.printer_Canon_Inkjet_i450.print_oddpages
        true

        print.printer_Canon_Inkjet_i450.print_orientation
        0

        print.printer_Canon_Inkjet_i450.print_pagedelay
        500

        print.printer_Canon_Inkjet_i450.print_paper_data
        1

        print.printer_Canon_Inkjet_i450.print_paper_height
        11.00

        print.printer_Canon_Inkjet_i450.print_paper_size
        7077985

        print.printer_Canon_Inkjet_i450.print_paper_size_type
        0

        print.printer_Canon_Inkjet_i450.print_paper_size_unit
        0

        print.printer_Canon_Inkjet_i450.print_paper_width
        8.50

        print.printer_Canon_Inkjet_i450.print_reversed
        false

        print.printer_Canon_Inkjet_i450.print_scaling
        1.00

        print.printer_Canon_Inkjet_i450.print_shrink_to_fit
        true

        print.printer_Canon_Inkjet_i450.print_to_file
        false

        print.printer_Canon_Inkjet_i450.print_unwriteable_margin_bottom
        0

        print.printer_Canon_Inkjet_i450.print_unwriteable_margin_left
        0

        print.printer_Canon_Inkjet_i450.print_unwriteable_margin_right
        0

        print.printer_Canon_Inkjet_i450.print_unwriteable_margin_top
        0

        privacy.clearOnShutdown.cache
        false

        privacy.clearOnShutdown.cookies
        false

        privacy.clearOnShutdown.downloads
        false

        privacy.clearOnShutdown.formdata
        false

        privacy.clearOnShutdown.sessions
        false

        privacy.cpd.cookies
        false

        privacy.cpd.downloads
        false

        privacy.cpd.formdata
        false

        privacy.cpd.history
        false

        privacy.cpd.sessions
        false

        privacy.item.cache
        false

        privacy.item.downloads
        false

        privacy.item.formdata
        false

        privacy.item.sessions
        false

        privacy.sanitize.migrateFx3Prefs
        true

        privacy.sanitize.timeSpan
        0

        security.warn_entering_weak
        false

        security.warn_entering_weak.show_once
        false

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        NVIDIA GeForce 6150 LE

        Vendor ID
        10de

        Device ID
        0241

        Adapter RAM
        64

        Adapter Drivers
        nvd3dum

        Driver Version
        8.17.12.5896

        Driver Date
        7-9-2010

        Direct2D Enabled
        false

        DirectWrite Enabled
        false (7.0.6002.18409, font cache n/a)

        WebGL Renderer
        Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)

        GPU Accelerated Windows
        1/1 Direct3D 9
(In reply to comment #1)
> After that disable the the hardware acceleration under
> tools/options/advanced/general and retry it.,

I can reproduce it with hardware acceleration either on or off.
I played around a bit more and I think the root of the problem are ads from Wagjag.com. I tried disabling them through Adblock and was not able to repro. In addition, I've see (only once, but still) the same garbled screen when browsing Wagjag.com.
Can't say for sure as I only played 20 min this morning, but it look like it.
Did you restart after unticking hardware acceleration, for the change to take effect?

Also, can you attach a screenshot of the problem please.
(In reply to comment #5)
> Did you restart after unticking hardware acceleration, for the change to take
> effect?

No I did not. If I untick some setting and it does not warn me that I need to restart the application, I don't restart the application, I assume it takes effect on the fly as most other settings. Do you guys want another bug for this? ;)

Anyway, I tried restarting today and it does look like this is only reproducible with hardware acceleration.

> Also, can you attach a screenshot of the problem please.

Yep.
Attached image Garbled screenshot
Thanks for the extra info :-)

Looks like the issue in bug 644787 and bug 612007, and will likely mean needing to blocklist hardware acceleration for GeForce 6150 LE.
Status: UNCONFIRMED → NEW
Component: General → Graphics
Depends on: 644787
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → thebes
Summary: entire browser window shows garbage when scrolling → [D3D9] Entire browser window shows garbage when scrolling (black and white stripes) with GeForce 6150 LE
Version: unspecified → Trunk
In reply to comment 6
> Do you guys want another bug for this? ;)
The bug exist for a while: bug 593027.
OK thanks guys! I'm glad this was helpful.

Firefox still the best browser, thanks to you all for great work!
Marking as dupe of bug 644787, since my patch there will blocklist the GeForce 6150 LE at the same time.

Thanks again for the bug report :-)
No longer blocks: 601079, d3d9-layers
Status: NEW → RESOLVED
Closed: 9 years ago
No longer depends on: 644787
Resolution: --- → DUPLICATE
Duplicate of bug: 644787
You need to log in before you can comment on or make changes to this bug.