If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox 4.0 crashes sometimes when I click Clear Recent History (usually after startup)

RESOLVED DUPLICATE of bug 645471

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 645471
7 years ago
5 years ago

People

(Reporter: elgogo, Unassigned)

Tracking

({crash})

4.0 Branch
x86
Windows Vista
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-05-01][bugday-2011-05-06])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

When I click on Clear Recent History, and then the clear button, it greys out and Firefox freezes, then shows (Not Responding) and then crashes.  It doesn't happen all the time, but the crash happens most of the time.

When I check about:crashes, Firefox does not show the crash.

Reproducible: Sometimes

Steps to Reproduce:
1. Open Firefox 4.0
2. Immediate click on History > Clear Recent History > Clear Now
3. Crash may or may not happen.
Actual Results:  
Firefox freezes, shows Not Responding, then asks if you want to close firefox.  There is no bug report.

Expected Results:  
Clear Recent History just like Firefox 3.6 without any crashes.
Does it also crash if you leave out Cookies next Time?
Version: unspecified → 4.0 Branch
Severity: major → critical
Keywords: crash

Comment 2

7 years ago
Please post the crash ID from about:crashes
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report

Comment 3

7 years ago
No crash here.
Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0
Whiteboard: [closeme 2011-05-01]

Comment 4

7 years ago
No requested information has been supplied by the reporter and I'll close the bug.

Please feel free to reopen if more information gets available.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2011-05-01] → [closeme 2011-05-01][bugday-2011-05-06]
(Reporter)

Comment 5

7 years ago
The bug still exists with the latest version of Firefox 4.  I haven't turned off the cookies yet.  Will do so and report later today.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 6

7 years ago
(In reply to comment #1)
> Does it also crash if you leave out Cookies next Time?

I turned off cookies and it stop crashing.  What does that mean?
Do you see Symptoms of Bug 633427 too?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 645471
(In reply to comment #6)
> (In reply to comment #1)
> > Does it also crash if you leave out Cookies next Time?
> 
> I turned off cookies and it stop crashing.  What does that mean?

most likely one of your plug-ins is outdated and causes the crash
(Reporter)

Comment 9

7 years ago
When I clicked on clear history, I got this:

" A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://browser/content/sanitize.js:136 "

I know you said it's a cookie issue, and I'll post it in that following bug, too, this message I got.
(Reporter)

Comment 10

7 years ago
Not an isolated issue:  https://bugzilla.mozilla.org/show_bug.cgi?id=646315
(Reporter)

Comment 11

7 years ago
(In reply to comment #8)
> (In reply to comment #6)
> > (In reply to comment #1)
> > > Does it also crash if you leave out Cookies next Time?
> > 
> > I turned off cookies and it stop crashing.  What does that mean?
> 
> most likely one of your plug-ins is outdated and causes the crash

Ok, I *think* the issue is now resolved.  It was either the outdated Java plugin or a Citrix plugin.  I updated my Java plugin, and deleted the Citrix plugin.  All is well now.

Solution to resolve my issue:
Went here:  http://www.mozilla.com/en-US/plugincheck/  clicked on the ones I needed to be updated.  For the Citrix ICA plugin, it said "research".  A lot of people use Citrix, so hopefully it will be a plugin supported by Firefox, but I don't need it, and hence, I removed it.  After updating the Java plugin, I cleared history, and all is well.  So, it was either the Java plugin or the Citrix plugin.  Hope this helps!  More info of similar solution here:  http://support.mozilla.com/en-US/questions/792258#answer-160636

Recommendations for Firefox bug slayers:  I recommend to have the Plugin Check webpage actually part of Firefox (either automatically when users update Firefox, and/or as part of the help menu.)  I did not realize there was a plugin check webpage officially supported by Firefox and from my research, it seems that a lot of other users are having the same issue.  It's funny how Clear Private Data is linked to plugins, even when these plugins are not activated.  PLEASE PLEASE PLEASE have the Plugin Check webpage as part of your Help Menu.  It will save you guys a lot of time, effort, and headaches for the Bugzilla team.  Thank-you Marco Bonardo.  Kudos.
You need to log in before you can comment on or make changes to this bug.