Closed Bug 647877 Opened 9 years ago Closed 9 years ago

[SeaMonkey] mochitest-browser-chrome: browser_library_infoBox.js fails since 2011.04.02

Categories

(SeaMonkey :: Bookmarks & History, defect, major)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey2.1final

People

(Reporter: sgautherie, Assigned: neil)

References

(Blocks 1 open bug, )

Details

(Keywords: regression, Whiteboard: [perma-orange])

Attachments

(1 file)

{
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Expander button is not hidden for recently bookmarked node.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Expander button is not hidden for bookmark item.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly hidden by default: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly hidden by default: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly hidden by default: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly unhidden after toggle: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly unhidden after toggle: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly unhidden after toggle: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly hidden after toggle: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly hidden after toggle: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly hidden after toggle: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Expander button is not hidden for second bookmark item.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly hidden by default: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly hidden by default: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly hidden by default: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly unhidden after toggle: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly unhidden after toggle: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly unhidden after toggle: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly hidden after toggle: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly hidden after toggle: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/places/tests/browser_library_infoBox.js | Additional info field correctly hidden after toggle: #editBMPanel_keywordRow
}

Regression timeframe:
http://build.mozillamessaging.com/tinderboxpushlog/?tree=SeaMonkey2.1&rev=3caccd684365
Oh, these are all expected, because the test was testing buggy behaviour :-P
The first change fixes the "bug" that the test was testing the behaviour that bug 646210 changed. (Firefox doesn't want that change, of course.)

The second change fixes the bug that the test was testing the behaviour of the same bookmark item over and over again, since the focus never moved to the bookmark item that it was actually trying to test. I assume you can handle filing the equivalent Firefox bug, and porting their fix if it's different.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #524156 - Flags: review?(sgautherie.bz)
No longer blocks: 646257, 646672
Comment on attachment 524156 [details] [diff] [review]
Proposed patch
[Checked in: Comment 5+7]

>-    ok(!infoBoxExpanderWrapper.hidden,
>-       "Expander button is not hidden for recently bookmarked node.");
>+    ok(infoBoxExpanderWrapper.hidden,
>+       "Expander button is hidden for recently bookmarked node.");

Bug 646210 expected behavior change, right.
Nit: please add a comment like "# SeaMonkey UI differs from Firefox.", as a reminder when comparing both tests.

>+    PO._content.focus();

This does fix the reported failures and I can understand it visually.
Ftr, this test doesn't report anything about which actual node is being tested, so I just trust you this issue is not caused by an underlying SM "bug".
Attachment #524156 - Flags: review?(sgautherie.bz) → review+
Blocks: 647983
(In reply to comment #2)
> I assume you can handle
> filing the equivalent Firefox bug, and porting their fix if it's different.

I filed bug 647983.
Pushed changeset 89589947a98a to comm-central.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
(In reply to comment #3)
> Nit: please add a comment like "# SeaMonkey UI differs from Firefox.", as a
> reminder when comparing both tests.
Sorry, I forgot to do this.
Comment on attachment 524156 [details] [diff] [review]
Proposed patch
[Checked in: Comment 5+7]

http://hg.mozilla.org/comm-central/rev/f8f7eaacaf0f
Attachment #524156 - Attachment description: Proposed patch → Proposed patch [Checked in: Comment 5+7]
V.Fixed, per
http://build.mozillamessaging.com/tinderboxpushlog/?tree=SeaMonkey2.1
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
Target Milestone: --- → seamonkey2.1final
You need to log in before you can comment on or make changes to this bug.