Last Comment Bug 647886 - Pulling down Back/Forward menu requires an unnecessary delay
: Pulling down Back/Forward menu requires an unnecessary delay
Status: VERIFIED FIXED
[parity-Chrome][parity-IE]
: ux-efficiency
Product: Firefox
Classification: Client Software
Component: Toolbars and Customization (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 6
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on:
Blocks: 582485
  Show dependency treegraph
 
Reported: 2011-04-05 13:37 PDT by David Regev
Modified: 2011-07-26 15:39 PDT (History)
9 users (show)
dao+bmo: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.97 KB, patch)
2011-05-20 04:57 PDT, Dão Gottwald [:dao]
no flags Details | Diff | Splinter Review
patch (5.03 KB, patch)
2011-05-23 14:45 PDT, Dão Gottwald [:dao]
sdwilsh: review+
Details | Diff | Splinter Review

Description David Regev 2011-04-05 13:37:16 PDT
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

(Continued from bug 582485 comment #38)

If you want to bring up the Back/Forward menu (without right-clicking), you must click and hold. The hold is required in order to differentiate between going Back/Forward immediately and bringing up the menu. Thus, if you want to go back to a specific page, you must click, hold until the menu pops up, drag down/up to the desired history item, and release. The problem is that the hold is unnecessary if you’re going to be pulling down/up this menu. If you click on the Back button and then drag it down, there is no ambiguity: you can only possibly want to see the history menu.

Thus, the proposed solution is to remove the need for holding when pulling up/down the Back/Forward menu and show it the menu immediately.

Fixing this bug will also remove the regression introduced by removing the Back/Forward dropdown (bug 582485): it’s no longer possible to bring up the Back/Forward menu quickly.

Reproducible: Always

Steps to Reproduce:
1. Click down on Back button.
2. Don’t wait!
2. Drag down.
Actual Results:  
Nothing.

Expected Results:  
Back/Forward menu appears.

The proposed solution is already implemented by Google Chrome.
Comment 1 futraders 2011-04-13 16:11:43 PDT
I believe this is not a complete solution to the problems introduced by 582485.  The removal of the button, and a buttons functionality are not replaced the unique methods of accessing the functions.

1.  582485 requires waiting, holding, and or using additional buttons.

2.  Original FF 3.6 and all previous FF has the button.  
  a.  You click button.  Menu appears.
  b.  You hover (select) the previous URL, and you click again.   You are done.  Its a Click, select, Click.   (can be done on trackpad with no buttons)

New options are.  
Click, Hold, wait, release, highlight,click again  (Requires trackpad and buttons, holding pressure on buttons)

or 

Right Click, select LEFT click.   (requires two buttons and trackpad)

----The simple solution is the return of the old button, the new functionality as current in 4.0, does not need to be removed.   

Advocates 582485 did not do proper due diligence to the impact of the removal.  Even with the proposals here, the quickness and the directness a button, is not replaced.
Comment 2 LeiraHoward 2011-04-14 04:47:53 PDT
(In reply to comment #1)

> ----The simple solution is the return of the old button, the new functionality
> as current in 4.0, does not need to be removed.   
> 
> Advocates 582485 did not do proper due diligence to the impact of the removal. 
> Even with the proposals here, the quickness and the directness a button, is not
> replaced.

I agree.
Comment 3 David Regev 2011-04-15 10:45:42 PDT
(In reply to comment #1)
> I believe this is not a complete solution to the problems introduced by 582485.

This solution is just as efficient as the previous method, if not more so. Previously, what many people were used to doing is: click on dropdown, find desired page, and click again. Now, they're forced to be quicker about it: click down on on of the buttons (any one will do), drag down to the desired page, and let go. It’s all one click, one quick gesture. Moreover, removing the dropdown removes the choice between going to one of the buttons and going to the dropdown. This reduces time (and mental overhead) due to Hick’s Law.
Comment 4 futraders 2011-04-18 14:45:45 PDT
> 
> This solution is just as efficient as the previous method, 

David, I read again you solution, and I think I understand it better.   You are saying when I click back, it tosses up the history dropdown, and then when I move my mouse off that button it fades out.....or I click on one of them.

This would be an improvement over the current method of in FF 4, and it would instantly solve the need to understand how it is to work...it shows right up.

Some may find it a bit messy or busy, but it would be functional.  It also supports my criteria for ACCESS consideration of some users.   That it can be done with one button, and or, with a trackpad and zero buttons.

Developers need to realize that point and click, is much less of a burden than click and hold, or right mouse click, for some users than others.

So I support the idea of this solution....but do not retract what I believe is a real need to give users the button back again.   

We agree and see the same problem, we are both trying to fix what functionality that was removed, by misstating it as a software defect, instead of the designed functionality it was.
Comment 5 David Regev 2011-04-18 15:03:04 PDT
(In reply to comment #4)
> David, I read again you solution, and I think I understand it better. You are
> saying when I click back, it tosses up the history dropdown, and then when I
> move my mouse off that button it fades out.....or I click on one of them.

Not exactly. When you click on Back (or Forward) and “drag” the button down, the menu appears. It’s the same as pulling down what is known as a pull-down menu, such as the File menu. If you want to see how this works in practice, try doing this in Chrome or Internet Explorer 9.
Comment 6 Dão Gottwald [:dao] 2011-05-20 04:57:32 PDT
Created attachment 533932 [details] [diff] [review]
patch
Comment 7 Shawn Wilsher :sdwilsh 2011-05-23 09:49:44 PDT
I take it we don't have a test for this, right?
Comment 8 Dão Gottwald [:dao] 2011-05-23 12:06:24 PDT
Not that I know of. There's http://hg.mozilla.org/qa/mozmill-tests/file/c211c062c5b5/tests/functional/testToolbar/testBackForwardButtons.js for clicks.
Comment 9 Shawn Wilsher :sdwilsh 2011-05-23 12:55:04 PDT
(In reply to comment #8)
> Not that I know of. There's
> http://hg.mozilla.org/qa/mozmill-tests/file/c211c062c5b5/tests/functional/testToolbar/testBackForwardButtons.js
> for clicks.
Would it be a lot of work to add one with this bug?
Comment 10 Dão Gottwald [:dao] 2011-05-23 14:45:54 PDT
Created attachment 534581 [details] [diff] [review]
patch

added a test
Comment 11 Shawn Wilsher :sdwilsh 2011-05-23 14:49:47 PDT
(In reply to comment #10)
> added a test
Thanks a ton :)  I should get to this review in a couple of hours.
Comment 12 Shawn Wilsher :sdwilsh 2011-05-23 16:24:05 PDT
Comment on attachment 534581 [details] [diff] [review]
patch

Review of attachment 534581 [details] [diff] [review]:
-----------------------------------------------------------------

Could you please add the pd license block (https://www.mozilla.org/MPL/boilerplate-1.1/pd-c) to the test file?

r=sdwilsh
Comment 13 Dão Gottwald [:dao] 2011-05-24 03:06:34 PDT
http://hg.mozilla.org/mozilla-central/rev/381e9216f883
Comment 14 Jesse Ruderman 2011-05-25 14:59:18 PDT
This fix is great for people who know about it, but is it discoverable enough?
Comment 15 Dão Gottwald [:dao] 2011-05-25 15:11:24 PDT
(In reply to comment #14)
> This fix is great for people who know about it, but is it discoverable
> enough?

Bug 619930 wants to add a hint to the tooltip. If you have alternative ideas, please file new bugs.
Comment 16 Simona B [:simonab] 2011-05-26 06:24:17 PDT
Mozilla/5.0 (Windows NT 5.1; rv:6.0a2) Gecko/20110525 Firefox/6.0a2

Verified issue using the STR from Comment 0 on Win XP, Win 7, Ubuntu, Mac OS X 10.6.
Comment 17 Alex Faaborg [:faaborg] (Firefox UX) 2011-07-26 15:31:17 PDT
I'm finding that very fast click and pull down gestures aren't registering.  Is there any timer or threshold here?
Comment 18 Dão Gottwald [:dao] 2011-07-26 15:39:19 PDT
There's no timer; it could have to do with the button being round on Windows and OS X.

Note You need to log in before you can comment on or make changes to this bug.