The default bug view has changed. See this FAQ.

Change the back/forward buttons tooltips to notify users that right-clicking/click-holding the button will display the history

RESOLVED FIXED in Firefox 8

Status

()

Firefox
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: u88484, Assigned: dao)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {ux-discovery, verified-aurora, verified-beta})

Trunk
Firefox 8
ux-discovery, verified-aurora, verified-beta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: [qa!][testday-20110930])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

6 years ago
Bug 606888 was filed to make it discoverable how to access the back and forward button's history menu but was wont fixed, probably due to not having clear specific suggestions.  I think the best option (or at least short term best option) is to change the tooltip to notify users that click-holding the buttons will display the history.

Before:
"Go back one page"
"Go forward on page"

After:
"Go back one page. Click and hold to display history"
"Go forward one page. Click and hold to display history"
(Reporter)

Updated

6 years ago
blocking2.0: --- → ?
Perhaps place the second sentence on a separate line to help establish that we are describing two different functions?
Whiteboard: [strings]
And I'd recommend "Click and hold to show history", since that's the terminology we're using in the menus.
(Reporter)

Comment 3

6 years ago
Do we currently have two lined tooltips?  I'm just looking for an example for the coding style.

Comment 4

6 years ago
Well, click-hold for Mac-land. Right-click for Windows and Linux.
Summary: Change the back/forward buttons tooltips to notify users that click-holding the button will display the history → Change the back/forward buttons tooltips to notify users that right-clicking/click-holding the button will display the history

Updated

6 years ago
Duplicate of this bug: 621311

Comment 6

6 years ago
(In reply to comment #3)
> Do we currently have two lined tooltips?

Sure, if you use <tooltip> instead of just "tooltiptext" you can put in whatever you want. Bookmarks all have two line tooltips already, so we do separate lines in places where it makes sense and because these would be two separate and unrelated pieces of information two lines would probably be best.
blocking2.0: ? → -
(Reporter)

Comment 7

6 years ago
Created attachment 502260 [details]
Screenshot of patch v1
Assignee: nobody → supernova00
Status: NEW → ASSIGNED
Attachment #502260 - Flags: ui-review?(limi)
(Reporter)

Comment 8

6 years ago
Created attachment 502261 [details] [diff] [review]
Patch v1
(Reporter)

Comment 9

6 years ago
(In reply to comment #4)
> Well, click-hold for Mac-land. Right-click for Windows and Linux.

Click and hold also works on Windows.  Right-clicking does feel friendlier to user though as there is no delay.

Comment 10

6 years ago
Click-hold was not supported here in 3.6 and is new to 4.0 for non-Mac. Click-hold on a button is unnatural on anything but Mac where it's used to having an over-simplified mouse without a right button. Left-click does an action and right-click gives options about an action. That's the way these OSes work and what users expect. You'll need to have different tooltips based on OS.

Comment 11

6 years ago
By the way, I'm aware that having to have different strings per OS is annoying, but we still do the stupid dance of using the word "preferences" vs. "options" on different OSes, even putting it in a different location in the main menus. In this case it's not just convention, it's a UI interaction difference in expectation between OSes. (especially because right-click lacks a delay)

Updated

6 years ago
Keywords: late-l10n
Comment on attachment 502260 [details]
Screenshot of patch v1

Yeah, as stated in earlier comments, we probably need it to be different on Mac and Windows:

Windows:
Right-click to show history

Mac:
Click and hold to show history

Review+ with those changes implemented.
Attachment #502260 - Flags: ui-review?(limi) → ui-review+
Duplicate of this bug: 626634

Comment 14

6 years ago
Has this been fixed in RC1?  I do like the new graphics that are used for the back and forward buttons, but there is no indication I can right click to get the history.  In firefox 3.x it had indicators I could right click, why were they removed in firefox 4?
(Reporter)

Comment 15

6 years ago
I completely missed the follow up emails after I posted the patch. There is no way this will make firefox 4.0 since it deals with changing strings.
Duplicate of this bug: 640447

Updated

6 years ago
Blocks: 606888

Comment 17

6 years ago
This could now go into FF7. What needs to be done here? Do you have a review+? It seems not, there is no patch after comment 12.
(Reporter)

Comment 18

6 years ago
(In reply to comment #17)
> This could now go into FF7. What needs to be done here? Do you have a
> review+? It seems not, there is no patch after comment 12.

Someone needs to create a new patch that addresses the review comments in comment #12.  I do not have the time to work on anything for at least the new few months.
Status: ASSIGNED → NEW
(Assignee)

Updated

6 years ago
Assignee: supernova00 → dao
(Assignee)

Comment 19

6 years ago
Created attachment 545551 [details] [diff] [review]
patch

Bug 647886 made it so that the mouse doesn't need to rest on the button, so I changed the tooltip to "Right-click or pull down to show history" and "Pull down to show history" for Mac.
Attachment #502260 - Attachment is obsolete: true
Attachment #502261 - Attachment is obsolete: true
Attachment #545551 - Flags: ui-review?(limi)
Attachment #545551 - Flags: review?(mano)
(Assignee)

Updated

6 years ago
Keywords: late-l10n
Whiteboard: [strings]
(Assignee)

Updated

6 years ago
Attachment #545551 - Flags: ui-review?(limi) → ui-review?(faaborg)
Comment on attachment 545551 [details] [diff] [review]
patch

I'm not sure that users will immediately understand what the direction of "pull down" is instructing them to do, but I do like that we are leading users towards a more efficient interaction once they try the pull down.  So overall seems like a good idea.
Attachment #545551 - Flags: ui-review?(faaborg) → ui-review+
(Assignee)

Updated

6 years ago
Attachment #545551 - Flags: review?(mano) → review?(gavin.sharp)
Attachment #545551 - Flags: review?(gavin.sharp) → review+
http://hg.mozilla.org/mozilla-central/rev/45750d4529d9
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 8

Comment 22

6 years ago
(In reply to Alex Faaborg [:faaborg] (Firefox UX) from comment #20)
> 
> I'm not sure that users will immediately understand what the direction of
> "pull down" is instructing them to do…

I totally agree. Like some others wrote, using “pull down” seems very unnatural in any non-drop-down menu, especially now that the drop-drown indicator was removed (!). It also makes less sense when localizing, or makes localizers use “Right-click or click and hold to show history” and “Click and hold to show history” anyway. Could you consider using this instead?

> …, but I do like that we are leading
> users towards a more efficient interaction once they try the pull down.  So
> overall seems like a good idea.

I don’t think this is more relevant nor valid for all users - most of them probably won’t have a clue or simply don’t take the effort to try finding out how the pulling down is done. IMO we should not be leading users anywhere this way to find out how to use basic actions, but be clear instead.

Comment 23

6 years ago
Just wondering: doesn't right-clicking work on OS X too, when using a normal mouse, or one of Apple's later mice where the user can choose the number of buttons?
Depends on: 683437

Updated

6 years ago
Whiteboard: [qa+]

Comment 24

6 years ago
verified [testday-20110930]

Comment 25

6 years ago
verified Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0

Comment 26

6 years ago
Verified fixed, too, on Linux x86_64 with 8.0b1 eo Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa+][testday-20110930]
Verified also on the latest Nightly, latest Aurora and Firefox 8.0b1 on Windows XP, Windows 7, Ubuntu 11.04 and Mac OS X 10.6. The tooltip is now changed to "Right-click or pull down to show history" and "Pull down to show history" for Mac.

Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111004 Firefox/10.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111004 Firefox/10.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a1) Gecko/20111004 Firefox/10.0a1
Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111004 Firefox/10.0a1

Mozilla/5.0 (Windows NT 5.1; rv:9.0a2) Gecko/20111004 Firefox/9.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:9.0a2) Gecko/20111003 Firefox/9.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a2) Gecko/20111004 Firefox/9.0a2
Mozilla/5.0 (Windows NT 6.1; rv:9.0a2) Gecko/20111004 Firefox/9.0a2


Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0) Gecko/20100101 Firefox/8.0
Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0
Keywords: verified-aurora, verified-beta
Whiteboard: [qa+][testday-20110930] → [qa!][testday-20110930]
(In reply to Rimas Kudelis from comment #23)
> Just wondering: doesn't right-clicking work on OS X too, when using a normal
> mouse, or one of Apple's later mice where the user can choose the number of
> buttons?

Yes, but it's not the default setup, so we can't rely on it. And in the interest of not having platform-specific strings, I'd say we use the click-and-hold pattern instead.

(In reply to Ton from comment #22)
> I totally agree. Like some others wrote, using “pull down” seems very
> unnatural in any non-drop-down menu, especially now that the drop-drown
> indicator was removed (!). It also makes less sense when localizing, or
> makes localizers use “Right-click or click and hold to show history” and
> “Click and hold to show history” anyway. Could you consider using this
> instead?

Agreed, "pull down" is confusing. Just discovered this in the UX build, sorry for not chiming in earlier. 

Let's go with "Click and hold to show history" instead?

(and let me know whether it makes more sense to open a follow-up bug — I assume it's just a string change)
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 29

6 years ago
Even string changes get their own bugs.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.