stockholmsborsen.se - Leaves the page totaly unreadable

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Other
P2
normal
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: kim gabrielsen, Unassigned)

Tracking

Details

(Whiteboard: [deny], URL)

(Reporter)

Description

17 years ago
Hi,

try to go to the page 

http://www.omgroup.com/transaction/

usualy in ns and ie it displays fine, but in mozilla its totally unreadable.

i cannot specify further and i dont know if the page uses layers, dcom or 
anything spicy. i can just see that its not correct.

i'm using mozilla 2001010901

best regards

kim gabrielsen

Comment 1

17 years ago
I'm getting the following at the above URL ...

Microsoft VBScript runtime  error '800a000d'
Type mismatch: 'cInt'
/transaction/lib/browserCheck.asp, line 102

... and not only with Mozilla, also with 4.x. Do you really think this is a
Mozilla problem? Or has the site just changed?
(Reporter)

Comment 2

17 years ago
Try again,

the server sometimes choke around peak hours which is from 17.00 - 18.00 - local 
time.

the server dislay stock quotes from the swedish stock exchange and often the 
last hour before closing, it's difficult to establish contact.

/
Kim
Page uses layers, hence we get the problem we are seeing. Visibilitys are never
set to false for things because there is no codepath for browsers with a
standard DOM.  Over to evangelism.
Assignee: clayton → evangelism
Status: UNCONFIRMED → NEW
Component: Layout → Evangelism
Ever confirmed: true
QA Contact: petersen → zach

Comment 4

17 years ago
The layout is a mess but I noticed layer tags are being used on the page.

<layer ID="menu15" TOP="160" LEFT="-2">
<layer ID="menuItem1" WIDTH="100" HEIGHT="20" TOP="0" LEFT="0"
OnMouseOver="hoverMenu(0, this);" OnMouseOut="unHoverMenu(this);">
<layer ID="normal" CLASS="menuItem" BgColor="#8C95D1" WIDTH="100" HEIGHT="20">
Förstasidan</layer>
<layer ID="hover" CLASS="menuItemHover" BgColor="#18216B" VISIBILITY="hidden"
WIDTH="100" HEIGHT="20">
Förstasidan</layer>
<layer ID="menuItemArrow1" WIDTH="20" HEIGHT="20" TOP="0" LEFT="100"
BgColor="#18216B">&nbsp;</layer>
</layer>

Comment 5

17 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary

Comment 6

17 years ago
site changed url

Comment 7

17 years ago
giving to hwaara
Assignee: bclary → hwaara

Updated

17 years ago
Priority: -- → P4

Comment 8

16 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 9

16 years ago
I'm swamped so I don't know when I'll be able to get to these bugs. :(

Reassigning to default component owner.
Assignee: hwaara → nitot
Component: US English → European
QA Contact: zach → momoi
they are serving different html per browser, we get evil ns4 stuff

Comment 11

16 years ago
Moving to new component "West Europe".  European component is being removed. 
See bug 95808 for details.
Component: European → West Europe
QA Contact: momoi → caillon
Summary: Leaves the page totaly unreadable → stockholmsborsen.se - Leaves the page totaly unreadable

Comment 12

16 years ago
*** Bug 106410 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
Having looked at this while investigating bug 106410, some additional notes:

Something server-side (presumably ASP) is serving different content depending
upon what browser you're using.  IE gets completely different source from Moz.

It looks like Moz is being fed code written for NN4.x

As Boris Zbarsky mentioned above, all the javascript basically goes :

"Document.all? OK, have [this...] Document.layers?  Have [this...] instead
Everybody else?  you mean there's someone else?"

Comment 14

16 years ago
*** Bug 94919 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
Confirming on N62 / Win2K. OS -> All.
Accepting bug.
Contact details found here : http://www.stockholmsborsen.se/contact/index.asp
Telefon: +46 8 405 60 00

Setting P3
Status: NEW → ASSIGNED
OS: Windows 98 → All
Priority: P4 → P2

Comment 16

16 years ago
Contact details : 
+46 8-405 68 00 
mail : contactcenter@stockholmsborsen.se
*** Bug 118448 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
Can someone please change platform to All since this one is reproductable on mac
os X (buildid 2002010308).

Updated

16 years ago
Hardware: PC → All

Comment 19

16 years ago
I have contacted them via contactcenter@stockholmsborsen.se and I am awaiting reply.

Comment 20

16 years ago
I got a reply from them. They do not know when Netscape 6 and Mozilla will be
supported, so basically they haven't thought about it. They did not want to give
me a contact person directly involved with the web development.
do they call this fixed with a deny?
Whiteboard: [deny]

Comment 22

16 years ago
I have been in touch with their customer support about this issue lately, and
they actually seemed quite responsive. The person I talked to said he would
forward my comments to their "web developers" and that he occasionally used
Nescape 6.2 himself, though he had not heard of Mozilla. I will report back when
(or if) I hear anything new from them.

Comment 23

15 years ago
Now they are aware of the problem, and show us the following message when trying
to access the page.

"We are continuously working to improve the Stockholmsbörsen’s and
Stockholmsbörsen Fixed Income’s websites. However, at the present time, we are
not able to offer the site for all browsers, for example Netscape version 6 users.

We apologize for any inconvenience that this might cause."

Comment 24

15 years ago
Re comment #23: That message is quite old, maybe some siz months or so. If they
were aware of anything, they would know that Netscape 7 is out.
move...
Component: Europe: West → Other

Comment 26

14 years ago
other default owner
Assignee: nitot → other
Status: ASSIGNED → NEW
QA Contact: z-caillon-obsolete2 → other

Comment 27

14 years ago
Wanted to use this page myself, but it effectively blocks mozilla by checking
navigator.appVersion which always is the string "5.0 (X11; en-US)" for me. I
can't seem to find a setting for it.

I can change navigator.userAgent with the preference general.useragent.override
but that doesn't seem to affect appVersion. Does anyone know of a way to set
navigator.appVersion in Mozilla?

Effectively the page's javascript checks for MSIE 5 or MSIE 6 in
navigator.appVersion.

I tried with opera identifying as MSIE 5 and the page displayed fine. So it
should hopefully display fine in mozilla as well.

Time for some serious evangelism here. This is the web page of the Swedish Stock
Exchange, so it's not like it's some small company.

Comment 28

14 years ago
Opera implements a number of JScript quirks, so successful rendering in Opera is
no guarantee for success in Mozilla. 

On the other hand, turning off JavaScript and spoofing the user agent string as
MSIE 6, I managed to achieve fully acceptable rendering of the front page in
Mozilla Firebird. The popup menus won't work, of course.

Comment 29

13 years ago
This page no longer exists:

http://www.omgroup.com/transaction/

and this page displays some kind of browser incompatibility page in a foreign
language:

http://www.stockholmsborsen.se/

The stockhomesborsen.se site loads fine in Opera 7.53 on Windows 2000.

Peace...

Comment 30

13 years ago
www.stockholmsborsen.se does no longer exist: it redirects to
<http://www.omxgroup.com/stockholmsborsen/>, which seems to work fine in Mozilla
and Netscape 7.2.

Comment 31

13 years ago
Confirmed, It does seem to work fine.

Marking Fixed
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.