Panning regression on google reader in 2011-04-12 nightly

VERIFIED FIXED in Firefox 5

Status

Fennec Graveyard
Panning/Zooming
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: glandium, Assigned: stechz)

Tracking

({regression})

Trunk
Firefox 5
regression
Dependency tree / graph

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
Here is my setup:
- Go on http://google.com/reader/i
- Subscribe to http://feeds.feedburner.com/DilbertDailyStrip
- Select any of the past comic
- Click zoom in

Up until 2011-04-11 nightly (double checked with ftp://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2011-04-11-05-mozilla-central-android-r7/), one could scroll the zoomed comic strip by dragging it.

Since 2011-04-12 nightly (double checked with ftp://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2011-04-12-04-mozilla-central-android-r7/), dragging the zoomed comic strip brings the right panel and doesn't scroll the comic strip.
(Reporter)

Comment 1

7 years ago
The tinderbox build corresponding to http://hg.mozilla.org/mozilla-central/rev/b48ebf9695bb already has this problem. Unfortunately, there's no older tinderbox build on ftp.mozilla.org
(Reporter)

Comment 2

7 years ago
This might be a regression from bug 639179
Duplicate of this bug: 649585
Probably iframes in general. See bug 649585 too:

Steps to reproduce: 
1. Go to html code tutorial:
http://www.htmlcodetutorial.com/frames/_IFRAME.html
2. Click into the iframe
3. Try to scroll within the iframe
(Assignee)

Updated

7 years ago
Assignee: nobody → ben
(Reporter)

Comment 5

7 years ago
So, I did a try build off that failing nightly, with bug 639179 backed out, and... still the same problem.
http://hg.mozilla.org/try/rev/d1c92a3c2989
https://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/mh@glandium.org-d1c92a3c2989/try-mob-andrd-r7-bld/
tracking-firefox5: --- → ?
Keywords: regression, regressionwindow-wanted
(Assignee)

Updated

7 years ago
Assignee: ben → wjohnston

Comment 6

7 years ago
We'd like to get a solution for this on Aurora within a week, either by backout or fix.
tracking-firefox5: ? → +
(Reporter)

Comment 7

7 years ago
A few data points, since I have them:
The nightly that I tested was working is 09b605eb3e0d
The nightly that I tested was not working is 48d6abe0a436
The oldest tinderbox build that I tested was not working is b48ebf9695bb
The latest aurora build also doesn't work. (wasn't sure of the merge/fork point)
tracking-firefox5: + → ?
(Reporter)

Comment 8

7 years ago
Grah, looks like firefox decided I wanted to reset tracking-firefox5 :(
tracking-firefox5: ? → +
(Assignee)

Comment 9

7 years ago
Created attachment 525795 [details] [diff] [review]
PAnning regression on google reader in 2011-04-12 nightly
(Assignee)

Comment 10

7 years ago
OK, somehow I missed a merge conflict and one of the files did not get patched.
Assignee: wjohnston → ben
(Assignee)

Comment 11

7 years ago
Comment on attachment 525795 [details] [diff] [review]
PAnning regression on google reader in 2011-04-12 nightly

(already reviewed)
Attachment #525795 - Flags: review+
(Assignee)

Comment 12

7 years ago
Created attachment 525797 [details] [diff] [review]
Panning regression on google reader in 2011-04-12 nightly
(Assignee)

Updated

7 years ago
Attachment #525795 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Attachment #525797 - Flags: review+
(Assignee)

Comment 13

7 years ago
Pushed http://hg.mozilla.org/mozilla-central/rev/193ec7c89ad5
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
This was a regression caused by an error on checkin of bug 642246.  This should go to Aurora.
Blocks: 642246
Keywords: regressionwindow-wanted
Whiteboard: [needs to land on aurora]
Target Milestone: --- → Firefox 6
Did this get review from someone besides the patch author?
(Assignee)

Comment 16

7 years ago
Yes, roc. See comments 10 and 11.
Attachment #525797 - Flags: approval-mozilla-aurora?

Updated

7 years ago
Duplicate of this bug: 649557

Comment 18

7 years ago
Mozilla /5.0 (Android;Linux armv7l;rv:5.0a2) Gecko/20110414 Firefox/5.0a2 Fennec/5.0a2 
Device: LG Optimus 2X (Android 2.2)

I still can't pan the iframe from http://www.htmlcodetutorial.com/frames/_IFRAME.html. Reopening the bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 19

7 years ago
My Dilbert test case works on the 20110414 6.0a1 nightly.
(Reporter)

Comment 20

7 years ago
Your test case is also fixed (no surprise, really). It probably hasn't landed on Aurora yet, though.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
status-firefox5: --- → affected
Not approving this yet, we'd like to get more confidence that this doesn't hurt desktop. Can we get layout people to vouch for that, or some other feedback here?
(Assignee)

Comment 22

7 years ago
Comment on attachment 525797 [details] [diff] [review]
Panning regression on google reader in 2011-04-12 nightly

We definitely want this patch for Fennec. Roc, could you weigh in?

As a reminder, Roc approved the original patch, which landed but did not have the needed changes to FrameLayerBuilder.cpp. These changes allow for empty layers to be sent across process instead of culled. For Firefox, there should be no other impact, because Firefox will never have any LAYER_ACTIVE_EMPTY display items.
Attachment #525797 - Flags: feedback?(roc)
Comment on attachment 525797 [details] [diff] [review]
Panning regression on google reader in 2011-04-12 nightly

Right, we can be very confident this does not affect desktop.
Attachment #525797 - Flags: feedback?(roc) → feedback+
verified FIXED On builds:
Mozilla/5.0 (Android; Linux armv7l; rv:6.0a1) Gecko/20110421 Firefox/6.0a1 Fennec/6.0a1 ID:20110421043148
Status: RESOLVED → VERIFIED
Attachment #525797 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Pushed to Aurora:
http://hg.mozilla.org/mozilla-aurora/rev/8369b648ab94
status2.0: --- → unaffected
status-firefox5: affected → fixed
OS: Android → All
Hardware: ARM → All
Whiteboard: [needs to land on aurora]
Target Milestone: Firefox 6 → Firefox 5
Depends on: 652948
Verified on Aurora Branch:
Mozilla/5.0 (Android; Linux armv71; rv5.0a2) Gecko/20110509 Firefox/5.0a2 Fennec/5.0a2
Device: Thunderbolt
OS: Android 2.2
You need to log in before you can comment on or make changes to this bug.