Last Comment Bug 649678 - Date Missing from About Nightly Window
: Date Missing from About Nightly Window
Status: VERIFIED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 All
: -- normal with 3 votes (vote)
: ---
Assigned To: Jonathan Kew (:jfkthame)
:
Mentors:
: 649444 649950 (view as bug list)
Depends on: 600569
Blocks: 648368
  Show dependency treegraph
 
Reported: 2011-04-13 10:05 PDT by WildcatRay
Modified: 2011-05-04 14:42 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
fixed


Attachments
About Nightly Window showing missing date (207.18 KB, image/png)
2011-04-13 10:05 PDT, WildcatRay
no flags Details
patch - include build date in About for nightly and aurora builds (1.01 KB, patch)
2011-04-13 10:39 PDT, Jonathan Kew (:jfkthame)
no flags Details | Diff | Review
patch, include build date for Nightly/Aurora in About - revised (1.07 KB, patch)
2011-04-13 12:21 PDT, Jonathan Kew (:jfkthame)
dao+bmo: review+
christian: approval‑mozilla‑aurora+
Details | Diff | Review

Description WildcatRay 2011-04-13 10:05:54 PDT
Created attachment 525709 [details]
About Nightly Window showing missing date

In the About Minefield window, the date of the (nightly) build appeared following the version (4.2a1pre most recently). Starting with the new Nightly, in the About Nightly (Help > About Nightly), the date no longer appears like it did in Minefield.

On a download and clean install of Nightly (C-set: 6bcaec19d09e), I tried with a brand new profile and the date is still missing.
Comment 1 Jonathan Kew (:jfkthame) 2011-04-13 10:23:44 PDT
Looks like the cause is here (http://mxr.mozilla.org/mozilla-central/source/browser/base/content/aboutDialog.js#68):

68   // Include the build ID if this is a "pre" (i.e. non-release) build
69   let version = Services.appinfo.version;
70   if (version.indexOf("pre") != -1) {
71     let buildID = Services.appinfo.appBuildID;
72     let buildDate = buildID.slice(0,4) + "-" + buildID.slice(4,6) + "-" + buildID.slice(6,8);
73     document.getElementById("version").value += " (" + buildDate + ")";
74   }

Note that this depends on the presence of a literal "pre" in Services.appinfo.version.
Comment 2 Jonathan Kew (:jfkthame) 2011-04-13 10:39:31 PDT
Created attachment 525720 [details] [diff] [review]
patch - include build date in About for nightly and aurora builds

This is designed to include the date in the About window for builds with version numbers that end in "a#" (for any number #), which should include both Nightly and Aurora builds, IIRC.
Comment 3 juan becerra [:juanb] 2011-04-13 11:05:41 PDT
This happens on Mac as well. I'll mark it affects all.
Comment 4 :Margaret Leibovic 2011-04-13 11:31:23 PDT
*** Bug 649444 has been marked as a duplicate of this bug. ***
Comment 5 Jonathan Kew (:jfkthame) 2011-04-13 11:53:13 PDT
Comment on attachment 525720 [details] [diff] [review]
patch - include build date in About for nightly and aurora builds

Seems to work as intended in my local build; are we happy to do this and bring back the date?
Comment 6 Dão Gottwald [:dao] 2011-04-13 11:57:35 PDT
Comment on attachment 525720 [details] [diff] [review]
patch - include build date in About for nightly and aurora builds

Please use regex.test(string) instead of string.match(regex) != null.
Comment 7 christian 2011-04-13 12:08:28 PDT
Yep, and I am not the correct person to review this. Dao, are you? If not I'll ping Gavin but he's in the air.
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-04-13 12:14:37 PDT
I'm on the ground in Toronto! Dao or I can review it.
Comment 9 Dão Gottwald [:dao] 2011-04-13 12:16:14 PDT
I can review this, but I'm not sure what the outcome really should be. Is it correct to have the date in aurora but not in beta?
Comment 10 Jonathan Kew (:jfkthame) 2011-04-13 12:21:05 PDT
Created attachment 525757 [details] [diff] [review]
patch, include build date for Nightly/Aurora in About - revised

Updated to use regex.test.

I'm assuming we don't want the build date in final release builds (at least, we didn't have it previously). Therefore, we can't have it in betas either, as in principle the (last) beta can _become_ the release, with the exact same bits. At least, that's how I understood things. So that's why I went for versions that end with "a#".
Comment 11 Jonathan Kew (:jfkthame) 2011-04-13 12:24:42 PDT
And as for Aurora - it seemed like a useful piece of info to show, just as it is for Nightly. I see no downside to including it there, as the version info is in any case not identical to final.
Comment 12 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-04-13 12:39:33 PDT
I concur - we want it in Aurora and Nightly but not Beta or Release.
Comment 13 christian 2011-04-13 12:39:47 PDT
Yep, correct in your reasoning.
Comment 14 Jonathan Kew (:jfkthame) 2011-04-13 13:40:39 PDT
Pushed to mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/222fc193d280

Setting tracking-firefox5? as I think we want this on Aurora too, right?
Comment 15 Marco Bonardo [::mak] 2011-04-14 05:15:54 PDT
*** Bug 649950 has been marked as a duplicate of this bug. ***
Comment 16 Chris B. 2011-04-14 06:21:09 PDT
I just downloaded the 4/14/11 Nightly and still don't see the date in the About Dialog.  Maybe I don't have the latest build.  The time stamp from the download is 6:12 AM (Pacific).  My Build ID = http://hg.mozilla.org/mozilla-central/rev/2a343ee6acd3, which doesn't match comment 14 above.  Will there be another Nightly update later?  Sometimes Nightly updates itself twice in a day (once in the morning and again later in the afternoon).
Comment 17 WildcatRay 2011-04-14 06:26:23 PDT
(In reply to comment #16)
> cc: cab26715@live.comI just downloaded the 4/14/11 Nightly and still don't see the date in the About
> Dialog.  Maybe I don't have the latest build.  The time stamp from the download
> is 6:12 AM (Pacific).  My Build ID =
> http://hg.mozilla.org/mozilla-central/rev/2a343ee6acd3, which doesn't match
> comment 14 above.  Will there be another Nightly update later?  Sometimes
> Nightly updates itself twice in a day (once in the morning and again later in
> the afternoon).

That build--an hourly build--is from before this patch landed. The full nightly Nightly build for today (2011-04-14) should be out soon.
Comment 18 Chris B. 2011-04-14 06:29:08 PDT
(In reply to comment #16)
> I just downloaded the 4/14/11 Nightly and still don't see the date in the About
> Dialog.  Maybe I don't have the latest build.  The time stamp from the download
> is 6:12 AM (Pacific).  My Build ID =
> http://hg.mozilla.org/mozilla-central/rev/2a343ee6acd3, which doesn't match
> comment 14 above.  Will there be another Nightly update later?  Sometimes
> Nightly updates itself twice in a day (once in the morning and again later in
> the afternoon).

Disregard my previous post.  Nightly just updated itself again less than 15 minutes after my original update.  I now have (http://hg.mozilla.org/mozilla-central/rev/aa200a803e07) and the date stamp is now in the About Dialog.
Comment 19 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-04-14 08:43:24 PDT
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110414 Firefox/6.0a1

Verified FIXED
Comment 20 WildcatRay 2011-04-14 09:27:46 PDT
Thanks!
Comment 21 Marc Rufert 2011-04-15 07:51:13 PDT
When will the patch be pushed to Aurora?
Comment 22 JP Rosevear [:jpr] 2011-04-19 15:37:08 PDT
This is not something to track for aurora, it would not prevent us from cutting over to beta for ff5.
Comment 23 christian 2011-04-20 11:58:01 PDT
Comment on attachment 525757 [details] [diff] [review]
patch, include build date for Nightly/Aurora in About - revised

Approved for mozilla-aurora
Comment 24 Jonathan Kew (:jfkthame) 2011-04-20 22:46:51 PDT
http://hg.mozilla.org/mozilla-aurora/rev/768ec7eec906
Comment 25 WildcatRay 2011-04-21 08:25:07 PDT
Confirmed that date now shows in the About Aurora window. Thanks and good work!

Note You need to log in before you can comment on or make changes to this bug.