500 Internal Server Error trying to load Fennec 4.0b5 /topcrasher lists /byversion

VERIFIED DUPLICATE of bug 650904

Status

P1
normal
VERIFIED DUPLICATE of bug 650904
8 years ago
7 years ago

People

(Reporter: stephend, Assigned: rhelmer)

Tracking

Bug Flags:
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
STR:

1. Load https://crash-stats.stage.mozilla.com/topcrasher/byversion/Fennec/4.0b5/28/browser with the Web Console open
2. Wait
3. Examine the console

Actual Results:

[20:01:03.558] POST https://crash-stats.stage.mozilla.com/correlation/bulk_ajax/cpu/Fennec/4.0b5/ [HTTP/1.1 500 Internal Server Error 31972ms]
[20:01:03.584] POST https://crash-stats.stage.mozilla.com/correlation/bulk_ajax/addon/Fennec/4.0b5/ [HTTP/1.1 500 Internal Server Error 31897ms]
[20:01:03.608] POST https://crash-stats.stage.mozilla.com/correlation/bulk_ajax/module/Fennec/4.0b5/ [HTTP/1.1 500 Internal Server Error 31856ms]
(Reporter)

Comment 1

8 years ago
(Unlike the other Kohana ones, I think this is pretty important.)
Flags: in-testsuite?
Flags: in-litmus?
(Assignee)

Comment 2

8 years ago
It looks like we don't currently generate correlation reports for Fennec, the list is hardcoded to Firefox Thunderbird SeaMonkey Camino:

http://code.google.com/p/socorro/source/browse/trunk/scripts/crons/cron_libraries.sh
So would the solution here be to add "Fennec" to the correlation generator script list? Or to have logic that evaluates whether or not the report is for Fennec, and removes the correlations tab in the UI for that specific product?

On spec this looks like a good candidate for general refactoring, especially if we're hoping to productize Socorro to some extent. Am I correct in my assumption that third party users would not be able to generate correlation reports without editing this file directly?

Comment 4

8 years ago
This will get refactored as part of bug 629029 soon anyway.

Stephen: do you want those 500 errors to go away before then?  If so let's do something hackish, like just not try to load correlation reports for products that don't have them.

Comment 5

8 years ago
Wrong bug number, doh.    Bug 629029 says we should spin off a bug to refactor correlation reports.  I'll file that next.

Bug 623164 will add correlation reports for Fennec, by the way.
(Reporter)

Comment 6

8 years ago
(In reply to comment #5)
> Wrong bug number, doh.    Bug 629029 says we should spin off a bug to refactor
> correlation reports.  I'll file that next.
> 
> Bug 623164 will add correlation reports for Fennec, by the way.

Cool; does this depend on bug 623164 in any way, then?

Comment 7

8 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > Wrong bug number, doh.    Bug 629029 says we should spin off a bug to refactor
> > correlation reports.  I'll file that next.
> > 
> > Bug 623164 will add correlation reports for Fennec, by the way.
> 
> Cool; does this depend on bug 623164 in any way, then?

Closing that will close this, so yes.  Mind if we punt this one until then?
Depends on: 623164
(Reporter)

Comment 8

8 years ago
(In reply to comment #7)

> > Cool; does this depend on bug 623164 in any way, then?
> 
> Closing that will close this, so yes.  Mind if we punt this one until then?

Fine by me!

Updated

8 years ago
Target Milestone: 1.7.7 → 1.9
(Reporter)

Comment 9

8 years ago
Does this also cover https://crash-stats.stage.mozilla.com/topcrasher/byversion/Firefox/4.0b13pre having:

[17:31:36.262] POST https://crash-stats.stage.mozilla.com/correlation/bulk_ajax/cpu/Firefox/4.0b13pre/ [HTTP/1.1 500 Internal Server Error 31221ms]
[17:31:36.277] POST https://crash-stats.stage.mozilla.com/correlation/bulk_ajax/addon/Firefox/4.0b13pre/ [HTTP/1.1 500 Internal Server Error 31195ms]
[17:31:36.292] POST https://crash-stats.stage.mozilla.com/correlation/bulk_ajax/module/Firefox/4.0b13pre/ [HTTP/1.1 500 Internal Server Error 31170ms]

Are those just missing correlation reports?
(Assignee)

Comment 10

8 years ago
(In reply to comment #9)
> Does this also cover
> https://crash-stats.stage.mozilla.com/topcrasher/byversion/Firefox/4.0b13pre
> having:
> 
> [17:31:36.262] POST
> https://crash-stats.stage.mozilla.com/correlation/bulk_ajax/cpu/Firefox/4.0b13pre/
> [HTTP/1.1 500 Internal Server Error 31221ms]
> [17:31:36.277] POST
> https://crash-stats.stage.mozilla.com/correlation/bulk_ajax/addon/Firefox/4.0b13pre/
> [HTTP/1.1 500 Internal Server Error 31195ms]
> [17:31:36.292] POST
> https://crash-stats.stage.mozilla.com/correlation/bulk_ajax/module/Firefox/4.0b13pre/
> [HTTP/1.1 500 Internal Server Error 31170ms]
> 
> Are those just missing correlation reports?

Yes looks like:

https://crash-analysis.mozilla.com/crash_analysis/20110418/

I think something we should fix though is to return HTTP 404, not 500 if the report is not found.

Comment 11

8 years ago
(In reply to comment #5)
> Wrong bug number, doh.    Bug 629029 says we should spin off a bug to refactor
> correlation reports.  I'll file that next.

Erm, I think that should be covered by bug 642325, right?

Updated

8 years ago
Assignee: nobody → rhelmer
Target Milestone: 1.9 → ---
(Assignee)

Updated

8 years ago
Priority: -- → P1
(Assignee)

Comment 12

7 years ago
Is this still happening? I just retested the query from comment 0 (using server name crash-stats.allizom.org instead of the old staging name), and I see no 500 errors in the web console.

Also spinners are replaced with "UNKNOWN: No Data" after  a short interval, due to bug 658034 being fixed.
(Reporter)

Comment 13

7 years ago
(In reply to Robert Helmer [:rhelmer] from comment #12)
> Is this still happening? I just retested the query from comment 0 (using
> server name crash-stats.allizom.org instead of the old staging name), and I
> see no 500 errors in the web console.
> 
> Also spinners are replaced with "UNKNOWN: No Data" after  a short interval,
> due to bug 658034 being fixed.

It still happens on https://crash-stats-dev.allizom.org/topcrasher/byversion/Firefox/9.0a2/28/browser.
[09:56:13.436] POST https://crash-stats-dev.allizom.org/correlation/bulk_ajax/cpu/Firefox/9.0a2/ [HTTP/1.1 500 Internal Server Error 33443ms]
[09:56:13.440] POST https://crash-stats-dev.allizom.org/correlation/bulk_ajax/addon/Firefox/9.0a2/ [HTTP/1.1 500 Internal Server Error 33257ms]
[09:56:13.445] POST https://crash-stats-dev.allizom.org/correlation/bulk_ajax/module/Firefox/9.0a2/ [HTTP/1.1 500 Internal Server Error 33073ms]
(Assignee)

Comment 15

7 years ago
(In reply to Stephen Donner [:stephend] from comment #13)
> (In reply to Robert Helmer [:rhelmer] from comment #12)
> > Is this still happening? I just retested the query from comment 0 (using
> > server name crash-stats.allizom.org instead of the old staging name), and I
> > see no 500 errors in the web console.
> > 
> > Also spinners are replaced with "UNKNOWN: No Data" after  a short interval,
> > due to bug 658034 being fixed.
> 
> It still happens on
> https://crash-stats-dev.allizom.org/topcrasher/byversion/Firefox/9.0a2/28/
> browser.

Aha, ok thanks for reproducing, will take a look.
Status: NEW → ASSIGNED
(Assignee)

Comment 16

7 years ago
OK the problem here is that the zeus is timing out our request and returning HTTP 500, so lowering severity.

We have a bunch of interconnected bugs around correlation reports, I'll go through these and try to emerge with one or two that are actionable and make sense.
Severity: critical → normal
(Assignee)

Comment 17

7 years ago
The way we do this now is just too slow, the zeus or PHP timeout is going to kill it.

We need to not be trying to download and parse these files on every page load.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 650904
(Reporter)

Comment 18

7 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.