Last Comment Bug 650322 - Remove 'ac_add_options --disable-installer'
: Remove 'ac_add_options --disable-installer'
Status: VERIFIED FIXED
[not-fennec-11]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla12
Assigned To: Abhishek Singh
:
Mentors:
http://mxr.mozilla.org/comm-central/s...
Depends on: 558180 661403 690369 697150
Blocks: 604266 736739
  Show dependency treegraph
 
Reported: 2011-04-15 10:32 PDT by Serge Gautherie (:sgautherie)
Modified: 2012-03-21 23:38 PDT (History)
5 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
'ac_add_options --disable-installer' removal, mozilla-central part (1.69 KB, patch)
2011-11-05 07:09 PDT, Abhishek Singh
ted: review+
Details | Diff | Review
'ac_add_options --disable-installer' removal, mozilla-central part [Checked in: Comment 15] (2.38 KB, patch)
2012-01-22 01:18 PST, Abhishek Singh
ted: review+
Details | Diff | Review

Description Serge Gautherie (:sgautherie) 2011-04-15 10:32:35 PDT
Do this for all mozilla-central based builds.

Do this before pushing bug 604266, to be sure the latter won't break these builds.

***

I would suggest to start with
/buildbot-configs/mozilla2/win64/tryserver/xulrunner/mozconfig
    * line 9 -- ac_add_options --disable-installer
which was added in the meantime (bug 567154).
Comment 1 Serge Gautherie (:sgautherie) 2011-04-16 09:08:00 PDT
This bug seems to be mostly affecting XulRunner.
Comment 2 Serge Gautherie (:sgautherie) 2011-06-01 15:29:12 PDT
If 'ac_add_options --disable-installer' can't be "removed" from 'mozconfig',
then it should be "replaced" with 'MOZ_INSTALLER=' in 'confvars.sh'.

In the latter case, this bug depends on bug 661403.
Comment 3 Serge Gautherie (:sgautherie) 2011-10-20 09:52:35 PDT
(In reply to Serge Gautherie (:sgautherie) from comment #2)

> If 'ac_add_options --disable-installer' can't be "removed" from 'mozconfig',
> then it should be "replaced" with 'MOZ_INSTALLER=' in 'confvars.sh'.

Ted, which way should this be done?

> In the latter case, this bug depends on bug 661403.

Blocking bugs have been fixed.
Comment 4 Ted Mielczarek [:ted.mielczarek] 2011-10-25 07:06:56 PDT
I'm not sure why that needs --disable-installer at all. Can we find out if that build works fine without it?
Comment 5 Abhishek Singh 2011-11-05 07:09:27 PDT
Created attachment 572200 [details] [diff] [review]
'ac_add_options --disable-installer' removal, mozilla-central part
Comment 6 Serge Gautherie (:sgautherie) 2011-11-05 10:13:47 PDT
Comment on attachment 572200 [details] [diff] [review]
'ac_add_options --disable-installer' removal, mozilla-central part

Review of attachment 572200 [details] [diff] [review]:
-----------------------------------------------------------------

Did you test or Try this patch?
Which repository are these paths in? (Is it 'build'?)

::: mobile/config/mozconfigs/macosx-desktop/nightly
@@ -5,5 @@
>  . $topsrcdir/build/macosx/mozconfig.leopard
>  ac_cv_visibility_pragma=no
>  
>  ac_add_options --disable-install-strip
> -ac_add_options --disable-installer

This one should probably be part of bug 697150.
Comment 7 Abhishek Singh 2011-11-05 23:37:34 PDT
>>>>Which repository are these paths in? (Is it 'build'?)
>>>>::: mobile/config/mozconfigs/macosx-desktop/nightly

mobile is inside src directory(the source code which i downloaded using command "hg clone http://hg.mozilla.org/mozilla-central/ src")
Comment 8 Nick Thomas [:nthomas] 2011-11-06 18:04:24 PST
Comment on attachment 572200 [details] [diff] [review]
'ac_add_options --disable-installer' removal, mozilla-central part

Like bug 697150 this should be reviewed by a peer of the Build Config module.

I don't personally know if windows xulrunner builds will be OK without --disable-installer. We don't normally call 'make installer' on the tinderbox machines, just 'make sdk' and 'make package', so it's possible something in 
  http://mxr.mozilla.org/mozilla-central/source/xulrunner/installer/windows/Makefile.in
is broken now.
Comment 9 Serge Gautherie (:sgautherie) 2011-11-07 19:34:18 PST
(In reply to Abhishek Singh from comment #7)
> command "hg clone http://hg.mozilla.org/mozilla-central/ src")

Ah, right: I didn't know about these 3 m-c files.
http://mxr.mozilla.org/mozilla-central/search?string=--disable-installer&case=1&find=%2Fconfig%2Fmozconfigs%2F
Comment 10 Ed Morley [:emorley] 2011-11-14 20:06:01 PST
Please could you tweak your hgrc to automatically add author info (guide here: http://blog.bonardo.net/2010/06/22/so-youre-about-to-use-checkin-needed) + add a commit message when attaching patches, since it makes pushing half a dozen checkin-neededs a lot easier. Thanks :-)
Comment 11 Dão Gottwald [:dao] 2011-11-18 05:01:06 PST
The patch doesn't apply anymore. mobile/config/... is now mobile/xul/config/...
Comment 12 Dão Gottwald [:dao] 2011-12-14 02:48:13 PST
See comment 11.
Comment 13 Abhishek Singh 2012-01-22 01:18:28 PST
Created attachment 590551 [details] [diff] [review]
'ac_add_options --disable-installer' removal, mozilla-central part
[Checked in: Comment 15]
Comment 15 Ed Morley [:emorley] 2012-01-25 18:08:19 PST
https://hg.mozilla.org/mozilla-central/rev/3732b1b4a0e0
Comment 16 Serge Gautherie (:sgautherie) 2012-01-26 01:24:45 PST
(In reply to Ed Morley [:edmorley] from comment #15)

This bug is not fixed yet: see URL.
Comment 17 Ed Morley [:emorley] 2012-01-26 01:36:14 PST
buildbot-configs are redundant with in-tree mozconfigs, surely?
Comment 18 Serge Gautherie (:sgautherie) 2012-01-26 02:19:08 PST
(In reply to Ed Morley [:edmorley] from comment #17)
> buildbot-configs are redundant with in-tree mozconfigs, surely?

Could very much be, but I didn't follow closely what happened wrt both places/uses.
If buildbot-configs/* files are redundant/obsolete, then they should just be removed.
Comment 19 Serge Gautherie (:sgautherie) 2012-01-26 02:31:08 PST
catlee, what about comment 18 after bug 558180?
Comment 20 Chris AtLee [:catlee] 2012-01-26 06:33:40 PST
(In reply to Serge Gautherie (:sgautherie) from comment #19)
> catlee, what about comment 18 after bug 558180?

Yes, after 558180 is closed those files can be removed. Right now some are used, some aren't.
Comment 21 Serge Gautherie (:sgautherie) 2012-01-26 07:14:12 PST
(In reply to Chris AtLee [:catlee] from comment #20)
> Yes, after 558180 is closed those files can be removed.

Then I would think the current bug is (still) valid as is:
in one place or the other, this option needs to be removed eventually.
Comment 22 Serge Gautherie (:sgautherie) 2012-03-21 23:36:24 PDT
V.Fixed, per MXR search.

Note You need to log in before you can comment on or make changes to this bug.