If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

--disable-installer packaging failures: missing or unnecessary file: bin/uninstall/helper.exe, bin/maintenanceservice_installer.exe

RESOLVED WONTFIX

Status

()

Firefox
Build Config
--
major
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: bc, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [workaround: stop using --disable-installer])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 606874 [details]
mozconfig

I normally build with official branding enabled. Since bug 713132 landed, packaging as failed with 

Error: package error or possible missing or unnecessary file: bin/uninstall/helper.exe (package-manifest, 31).
Error: package error or possible missing or unnecessary file: bin/maintenanceservice_installer.exe (package-manifest, 415).
Error: found error(s) while packaging, see above for details.
make[2]: *** [stage-package] Error 9

This bug prevents the crash automation from performing tests on Nightly builds on Windows.
(Reporter)

Updated

6 years ago
Summary: Official Branding packaging failures due to bug 713132 → Official Branding packaging failures: missing or unnecessary file: bin/uninstall/helper.exe, bin/maintenanceservice_installer.exe
(Reporter)

Comment 1

6 years ago
I've added a patch to my local build environments to back the patch out and and am no longer blocked by this, but it will affect any attempt to perform official builds as is.
Summary: Official Branding packaging failures: missing or unnecessary file: bin/uninstall/helper.exe, bin/maintenanceservice_installer.exe → --disable-installer packaging failures: missing or unnecessary file: bin/uninstall/helper.exe, bin/maintenanceservice_installer.exe
Given bug 650322, could you explain why --disable-installer would be needed in your case(s)?
Blocks: 650322
(Reporter)

Comment 3

6 years ago
It isn't absolutely needed but I don't use the installer and disabled it long ago to save time. If we are going to remove the option, I can go ahead and build it unless there is another way to disable it.
(In reply to Bob Clary [:bc:] from comment #3)

> It isn't absolutely needed but I don't use the installer and disabled it

I know the story: that's exactly why I filed bug 604266 initially :-|

> long ago to save time. If we are going to remove the option, I can go ahead
> and build it unless there is another way to disable it.

There isn't: the (stalled) plan is to remove MOZ_INSTALLER too in the end.
Blocks: 604266
No longer blocks: 650322
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Depends on: 650322
Resolution: --- → WONTFIX
Whiteboard: [workaround: stop using --disable-installer]
All things being equal, we prefer to have fewer configure options. All the prereqs for building the installer ship with MozillaBuild now, which is the only supported build environment on Windows, so it's not an onerous requirement.
Duplicate of this bug: 737303
You need to log in before you can comment on or make changes to this bug.