[Pinstripe] Make the filterdialog and the advanced search dialogs look better

RESOLVED FIXED in Thunderbird 8.0

Status

RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: stefanh, Assigned: stefanh)

Tracking

Trunk
Thunderbird 8.0
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Created attachment 526592 [details] [diff] [review]
Tweak search/filter dialogs

This is basically a port of the work I've done for seamonkey (clarkbw and I talked about this for a while ago). The most visible effect is the new buttons.

This also includes my proposal in bug 621546. It's all about these lines:
--------------------
+#searchTermList {
+  -moz-user-focus: ignore;
+}
+
+#searchTermList > listitem[selected="true"] {
+  background-color: inherit;
+}
--------------------

The last rule was in the original patch, that sort worsened the problem with no focus indication when you tabbed to the listbox. By adding the "ignore", the tab order is skipped for the listbox (see bug 621546 for more info). Another alternative is to remove the above rules.
Attachment #526592 - Flags: ui-review?(clarkbw)
(Assignee)

Comment 1

8 years ago
Comment on attachment 526592 [details] [diff] [review]
Tweak search/filter dialogs

I noticed that I missed one listbox. I'll re-visit this when I'm back from holiday.
Attachment #526592 - Flags: ui-review?(clarkbw)
(Assignee)

Comment 2

8 years ago
Created attachment 543687 [details] [diff] [review]
In line with current SeaMonkey

OK, so we decided to put bug 621546 on hold - we should probably fix the xul instead. So, this patch is basically what's we have in SeaMonkey atm (with the problem of keyboard navigation).
Attachment #526592 - Attachment is obsolete: true
Attachment #543687 - Flags: ui-review?(clarkbw)
(Assignee)

Comment 3

8 years ago
Created attachment 543688 [details]
Screenshots with patch applied
clarkbw: Do you want me to take this ui-review instead?
Comment on attachment 543687 [details] [diff] [review]
In line with current SeaMonkey

I'll pass this over to Andreas since I don't have a working build.
Attachment #543687 - Flags: ui-review?(clarkbw) → ui-review?(nisses.mail)
Comment on attachment 543687 [details] [diff] [review]
In line with current SeaMonkey

Look good! I like this style!
Attachment #543687 - Flags: ui-review?(nisses.mail) → ui-review+
(Assignee)

Comment 7

8 years ago
Comment on attachment 543687 [details] [diff] [review]
In line with current SeaMonkey

Thanks Andreas. Giving the r? to Mark.
Attachment #543687 - Flags: review?(mbanner)
Attachment #543687 - Flags: review?(mbanner) → review?(bwinton)
Comment on attachment 543687 [details] [diff] [review]
In line with current SeaMonkey

Review of attachment 543687 [details] [diff] [review]:
-----------------------------------------------------------------

Hey Stefan,

I'm sorry it took me so long to get to this.  On the plus side, I'm happy with the code, so r=me.  :)

Thanks,
Blake.
Attachment #543687 - Flags: review?(bwinton) → review+
(Assignee)

Comment 9

8 years ago
http://hg.mozilla.org/comm-central/rev/90e169ce9243
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 8.0
(Assignee)

Updated

7 years ago
Duplicate of this bug: 643596
You need to log in before you can comment on or make changes to this bug.