Last Comment Bug 651622 - Remove WinCE code from browser/*
: Remove WinCE code from browser/*
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: Firefox 6
Assigned To: Ed Morley [:emorley]
:
:
Mentors:
Depends on:
Blocks: 614720 653765
  Show dependency treegraph
 
Reported: 2011-04-20 14:07 PDT by Ed Morley [:emorley]
Modified: 2011-05-29 20:37 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from browser/* (47.32 KB, patch)
2011-04-20 14:29 PDT, Ed Morley [:emorley]
dolske: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-04-20 14:07:01 PDT
WinCE code is being slowly removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the browser/* parts of the removal.
Comment 1 Ed Morley [:emorley] 2011-04-20 14:29:06 PDT
Created attachment 527386 [details] [diff] [review]
Remove WinCE code from browser/*

Removes all WinCE ifdef and ifeq related code from browser/*

Benjamin, wasn't sure who to ask for review; your r= appeared on a few of the involved file's hg logs, however please let me know if someone else is actually more appropriate - thanks!
Comment 2 Justin Dolske [:Dolske] 2011-04-20 15:50:16 PDT
Comment on attachment 527386 [details] [diff] [review]
Remove WinCE code from browser/*

(*yoink*ing review)

Out, damn'd spot! out, I say!

I think this also makes the MOZ_FASTSTART stuff unused; WinCE and WinMobile were the only consumers afaik. Might double check with the mobile folks. In any case, let's do that as a separate bug.
Comment 3 Matheus Kerschbaum 2011-04-20 15:54:21 PDT
> I think this also makes the MOZ_FASTSTART stuff unused; WinCE and WinMobile
> were the only consumers afaik. Might double check with the mobile folks. In any
> case, let's do that as a separate bug.

There's also bug 503483 on enabling this for desktop but from the discussion in the bug I think its a WONTFIX.
Comment 4 Ed Morley [:emorley] 2011-04-20 16:17:54 PDT
Awesome, thanks for the fast review!

Yeah MOZ_FASTSTART (and also I believe the ActiveX stuff) will be unused once the toolkit cleanup is done; I've made a note to deal with it then :-)

Thanks for the link Matheus, hadn't seen that. I suspect as you say that the bug is WONTFIX - not just for the reasons inside, but also due to being made redundant by bug 627591 (windows) and bug 632404 (linux).
Comment 5 Ed Morley [:emorley] 2011-04-22 03:40:29 PDT
http://hg.mozilla.org/mozilla-central/rev/157b8fe56dd6

Thanks!
Comment 6 Ed Morley [:emorley] 2011-05-02 17:16:08 PDT
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=^/browser/
...returns 0 results.

-> Verified.

Note You need to log in before you can comment on or make changes to this bug.