Closed Bug 652338 Opened 9 years ago Closed 9 years ago

The "Component" multi-select field in the search page automatically scrolls to the top of the list every time you select a component

Categories

(Bugzilla :: Query/Bug List, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 4.0

People

(Reporter: mats, Assigned: LpSolit)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

This is a regression from the latest Bugzilla update.

STEPS TO REPRODUCE
1. load the URL
2. click Advanced Search
3. select a bunch of Products (just to fill up Components with many items)
4. select an item in Components
5. scroll down Components so that the selected item is not visible
6. CTRL+CLICK on a new item

ACTUAL RESULT
The first item is focused (has dotted outline) and is scrolled into view.

This makes it REALLY annoying to select many disparate items in these lists.

EXPECTED RESULT
The latest selected item should have focus and no scrolling should occur.
You can observe the correct behavior using this testcase:

data:text/html,<select multiple size=3><option>abc<option>abc<option>abc<option>abc<option>abc<option>abc<option>abc<option>abc<option>abc<option>abc<option>abc
This is an upstream bug, and a regression in 4.0. Bugzilla 3.6 is not affected. pyrzak, it's probably a regression due to the new UI for the Search page. Could you give it a look, please?
Assignee: nobody → query-and-buglist
Severity: major → normal
Component: Bugzilla: Other b.m.o Issues → Query/Bug List
Keywords: dogfood
Product: mozilla.org → Bugzilla
QA Contact: other-bmo-issues → default-qa
Target Milestone: --- → Bugzilla 4.0
Version: other → 4.0
Flags: blocking4.0.1+
Note that only the Component field is affected. This is probably due to doOnSelectProduct().
Summary: Auto-scrolling issues in multiple select lists → The "Component" multi-select field in the search page automatically scrolls to the top of the list every time you select a component
Depends on: 450301
Attached patch patch, v1Splinter Review
doOnSelectProduct() must not be triggered when selecting a component.
Assignee: query-and-buglist → LpSolit
Status: NEW → ASSIGNED
Attachment #528454 - Flags: review?(mkanat)
Comment on attachment 528454 [details] [diff] [review]
patch, v1

Review of attachment 528454 [details] [diff] [review]:

Certainly looks right to me. (By inspection.)
Attachment #528454 - Flags: review?(mkanat) → review+
Flags: approval4.0+
Flags: approval+
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/search/form.html.tmpl
Committed revision 7791.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified template/en/default/search/form.html.tmpl
Committed revision 7578.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
No longer blocks: 661132
You need to log in before you can comment on or make changes to this bug.