User activity report: Continue button does not always appear, even if username matches shown

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
--
minor
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: emorley, Assigned: glob)

Tracking

(Blocks: 1 bug)

Details

(URL)

(Reporter)

Description

7 years ago
The new user activity report feature (BMO specific customisation) does not always show the continue button, even if username results are shown.

1) On BMO, go to Reports -> User Changes
2) In the who box, try in succession (excl quotes):
"abc"
"abc def"
"abc de"
"abc def12345"

Expected:
If username matches shown, the continue button shown.

Actual:
"abc" -> Username matches found; continue button shown.
"abc def" -> Username matches found; continue button shown.
"abc de" -> Username matches found; continue button missing.
"abc def12345" -> Username matches found; continue button missing.


I believe the problem is that matchsuccess on this line:
http://bzr.mozilla.org/bmo/4.0/annotate/head:/template/en/default/global/confirm-user-match.html.tmpl#L177

Is being set to false if one part of the search string failed (eg did not match anything or was too short for substring match) - even if the other part generated results.

Not sure if this counts as a regression (seeing as this is a new feature), but provisionally blocking bug 652325 for now, for visibility.

Thanks! :-)
(Assignee)

Comment 1

7 years ago
the behvaour you're describing is correct -- the continue button won't be shown until all the specified users have been correctly identified.


in order for the report to be generated, it needs a successful match on all the users.

right now it is treating space as a delimiter (which is different from the other user fields in bugzilla, which only honour comma as a delimiter); this will probably change, but that's another story.

> "abc de" -> Username matches found; continue button missing.

here we perform two searches.  "abc" results in matches, however "de" is too short to use to search for users.

> "abc def12345" -> Username matches found; continue button missing.

here "def12345" fails to match any users.


in both cases you can't continue because you have to resolve the issue with your matching before the report can be run.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

7 years ago
I realise that, but search for :
"Ed Morley"

-> my entry shows, but not able to proceed

This seems daft.

It may be a case of expectation management (eg explicitly state on the search error page that space is a delimiter - and that all cases have to match before proceeding) or else just making a comma be the delimiter instead.
(Reporter)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 3

7 years ago
(In reply to comment #2)
> or else just making a comma be the delimiter instead.

yeah, i'll do that.
Assignee: nobody → glob
Status: REOPENED → ASSIGNED
(Assignee)

Comment 4

7 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.0/
modified extensions/BMO/Extension.pm
Committed revision 7670.

changes will be visible after the new production upgrade.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

7 years ago
Great, thanks! :-)
(Assignee)

Updated

7 years ago
Depends on: 654921
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.