Last Comment Bug 643460 - Update OTS version to r62 or later
: Update OTS version to r62 or later
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Masatoshi Kimura [:emk]
:
:
Mentors:
Depends on: 602558 628252 643137
Blocks: 653100
  Show dependency treegraph
 
Reported: 2011-03-21 10:12 PDT by Masatoshi Kimura [:emk]
Modified: 2011-04-27 06:18 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part 1: importing OTS r62 (173.06 KB, patch)
2011-04-07 04:00 PDT, Masatoshi Kimura [:emk]
jfkthame: review+
Details | Diff | Splinter Review
Part 2: apply local patches to fix build errors on Mozilla tree (5.35 KB, patch)
2011-04-07 04:01 PDT, Masatoshi Kimura [:emk]
no flags Details | Diff | Splinter Review
Part 3: remove gfx.downloadable_fonts.sanitize.preserve_otl_tables (6.17 KB, patch)
2011-04-07 04:02 PDT, Masatoshi Kimura [:emk]
no flags Details | Diff | Splinter Review
Part 2 v2: apply local patches to fix build errors on Mozilla tree (5.55 KB, patch)
2011-04-08 07:46 PDT, Masatoshi Kimura [:emk]
no flags Details | Diff | Splinter Review
Part 3: remove gfx.downloadable_fonts.sanitize.preserve_otl_tables (6.33 KB, patch)
2011-04-11 14:12 PDT, Masatoshi Kimura [:emk]
jfkthame: review+
Details | Diff | Splinter Review
Part 2 v3: apply local patches to fix some errors (7.73 KB, patch)
2011-04-20 14:48 PDT, Masatoshi Kimura [:emk]
jfkthame: review+
Details | Diff | Splinter Review

Description Masatoshi Kimura [:emk] 2011-03-21 10:12:39 PDT
Latest OTS has added a support for OTL tables (GDEF, GPOS and GSUB).
We can remove the most part of our modification by updating the library.
I'm afraid that OTS doesn't support vhea/vmtx tables yet. So we need to update a  bug 637481 patch to latest OTS (and submit it to upstream).
Comment 1 Masatoshi Kimura [:emk] 2011-03-27 10:42:55 PDT
Adding dependency to track patches which are not yet merged to upstream.
bug 527276 part 1a is also required.
http://hg.mozilla.org/mozilla-central/rev/88ff5f0a9681
Comment 2 Masatoshi Kimura [:emk] 2011-03-28 18:41:32 PDT
vhea/vmtx support was added in upstream.
Comment 3 Masatoshi Kimura [:emk] 2011-04-07 04:00:47 PDT
Created attachment 524378 [details] [diff] [review]
Part 1: importing OTS r62
Comment 4 Masatoshi Kimura [:emk] 2011-04-07 04:01:31 PDT
Created attachment 524379 [details] [diff] [review]
Part 2: apply local patches to fix build errors on Mozilla tree
Comment 5 Masatoshi Kimura [:emk] 2011-04-07 04:02:35 PDT
Created attachment 524380 [details] [diff] [review]
Part 3: remove gfx.downloadable_fonts.sanitize.preserve_otl_tables

This pref is no longer required because OTS validates OTL tables now.
Comment 6 Masatoshi Kimura [:emk] 2011-04-08 07:46:22 PDT
Created attachment 524624 [details] [diff] [review]
Part 2 v2: apply local patches to fix build errors on Mozilla tree

Forgotten to add a countermeasure against comma-at-end-of-enumerator errors.
Comment 7 Jonathan Kew (:jfkthame) 2011-04-11 06:36:47 PDT
I think one more local fix is needed in part 2, see bug 643137 (which gets reverted by the import in part 1 here).
Comment 8 Jonathan Kew (:jfkthame) 2011-04-11 06:40:32 PDT
Also, upstream OTS is now up to r64, with some Solaris fixes from Ginn Chen. So we should take that version. But let's wait until after the merge to Aurora, as there's no compelling need to fix this before the Fx5 train leaves.
Comment 9 Masatoshi Kimura [:emk] 2011-04-11 14:12:31 PDT
Created attachment 525166 [details] [diff] [review]
Part 3: remove gfx.downloadable_fonts.sanitize.preserve_otl_tables

updated to tip
Comment 10 Masatoshi Kimura [:emk] 2011-04-11 14:14:06 PDT
(In reply to comment #8)
> Also, upstream OTS is now up to r64, with some Solaris fixes from Ginn Chen. So
> we should take that version. But let's wait until after the merge to Aurora, as
> there's no compelling need to fix this before the Fx5 train leaves.
I chose r62 because Chromium did'nt roll into newer OTS yet.
http://src.chromium.org/viewvc/chrome/trunk/src/DEPS?view=markup
I'll update to a latest rolled revision at the time of aurora merge.
Comment 11 Masatoshi Kimura [:emk] 2011-04-20 14:48:54 PDT
Created attachment 527390 [details] [diff] [review]
Part 2 v3: apply local patches to fix some errors

The latest rolled revision is still r62, so I didn't update Part 1.
Comment 12 Jonathan Kew (:jfkthame) 2011-04-25 07:24:42 PDT
Comment on attachment 525166 [details] [diff] [review]
Part 3: remove gfx.downloadable_fonts.sanitize.preserve_otl_tables

Looks great, thanks. (I didn't attempt to actually review all the new OTS code, but the integration into Gecko looks correct.)

This should be tested on tryserver to make sure it doesn't cause any reftest surprises, etc; then let's get it landed in m-c.
Comment 13 Masatoshi Kimura [:emk] 2011-04-25 15:54:01 PDT
I do not have a commit access yet. Could you vouch me?
I've files bug 652685.
Comment 14 Jonathan Kew (:jfkthame) 2011-04-26 07:24:50 PDT
(In reply to comment #13)
> I do not have a commit access yet. Could you vouch me?
> I've files bug 652685.

I could, but I see Gavin did already. :)

Meanwhile, I've pushed these patches to try, and plan to land them in a while once the tests confirm all is good.

Note You need to log in before you can comment on or make changes to this bug.