Master-Password Dialogs as much as the checking interval settings

RESOLVED DUPLICATE of bug 584014

Status

defect
RESOLVED DUPLICATE of bug 584014
8 years ago
2 years ago

People

(Reporter: bugsarenotalloud, Unassigned)

Tracking

(Depends on 1 bug, Blocks 1 bug)

14 Branch
x86
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.17) Gecko/20110414 Thunderbird/3.1.10

Hello.

This is not a very big problem, but i hope i hope you can fix this.

I set my checking intervall to 1 minute:
http://img862.imageshack.us/img862/3062/thunderbirdmultiplemast.png

If i start my computer, thunderbird start with it.
And i forget to write my master-Password directly into the dialog, every minute 1 dialog comes to.

For example, for this scrren:
http://img51.imageshack.us/img51/3062/thunderbirdmultiplemast.png
i wait 2 minutes.

I only have to write one times the password into it, it is possbile to cancel the other dialogs.


I hope unterstand what i mean, i think relly that the problem is because of my high refresh checking settings (checking intervall).

Greetings by Daniel

Reproducible: Always

Steps to Reproduce:
1.Setting the checking intervall to 1 minute
2.Set up a master password
3.close TB
4.Open TB
5.Ignore the dialog wich ask you for the master password
6.Wait min. 1 minute or more if want more dialogs

Actual Results:  
There are moe than 1 dilaogs for the master password

Expected Results:  
show only 1 dialog and do not open 1 more, each minute

I used the software:
TB Tray
To start my thunderbird.
Reporter

Updated

8 years ago
Version: unspecified → 3.1
Reporter

Updated

8 years ago
Summary: Master-Password Dialogs as much as they checking intervall settings → Master-Password Dialogs as much as the checking intervall settings
Does it happens when you start Thunderbird in -safemode( see http://support.mozillamessaging.com/en-US/kb/Safe-Mode) ?
Reporter

Comment 2

8 years ago
Jes(In reply to comment #1)
> Does it happens when you start Thunderbird in -safemode( see
> http://support.mozillamessaging.com/en-US/kb/Safe-Mode) ?

Jes.

But i have to change my talking about more than 2 dilaogs.

It seems that i got not more than 2 dialogs.

Perhaps i have to wait longer, because i remember that i had more than 2 dialogs in the past.

Oh and alos a good information ist, that my girlfriend had the same issue.
But i am her systemadmin :D

Greetings by Daniel
Does deleting signons.sqlite	signons.txt	signons3.txt secmod.db cert8.db	key3.db	 in your profile helps (please make a backup before trying) ?
Reporter

Comment 4

8 years ago
I had only the folowing files in the dir
C:\Users\Daniel\AppData\Roaming\Thunderbird\Profiles\5hh6o93b.default:
cert8.db
key3db
secmod.db
signons.sqlite

NO:
signons.txt
signons3.txt

I cut the 4 existed files and start thunderbird in normal mode.
Then he ask me for my password for my mail, i write it into it.
Then i enabled the master-password and write my 0ld password into it.

Then i restart, wait a minute i got the secend dialog.


Greetings by Daniel
When you restarted Thunderbird was that in safe-mode ?
Reporter

Updated

8 years ago
Version: 3.1 → 8
Reporter

Comment 6

8 years ago
PLEASE, what should i do to help to fix this issue.

I see this bug on more than 4 pc's.

And i try to reproduce it at a another windows 7 system and it works.

Greetings by Daniel
Reporter

Comment 7

8 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #5)
> When you restarted Thunderbird was that in safe-mode ?

No, not at the moment when i delete:
cert8.db
key3db
secmod.db
signons.sqlite

But know i do this with the 8.0 and bug comes again.

Greetings by Daniel
Reporter

Comment 8

8 years ago
Ok i try again now on my pc (Windows 7 32bit).

I backup my appdata tb folder and reinstall tb 8.0 .

And then i add my google account:
http://img812.imageshack.us/img812/2098/tb01.png
http://img823.imageshack.us/img823/4381/tb02k.png
http://img716.imageshack.us/img716/3492/tb03a.png
http://img684.imageshack.us/img684/3395/tb04.png
http://img855.imageshack.us/img855/9972/tb05.png


I hope that helps you to reproduce.

Greetings by Daniel
Reporter

Updated

8 years ago
Version: 8 → 9
Nice video Thanks. I have one more question. The first run of Thunderbird is done in user mode - and then you run it as administrator.

Do you see the same issue if , you don't start thunderbird at the end of the installer , but launch it using the administrator rights too , and then set the master password.
Reporter

Comment 10

8 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #9)
> Nice video Thanks. I have one more question. The first run of Thunderbird is
> done in user mode - and then you run it as administrator.
> 
> Do you see the same issue if , you don't start thunderbird at the end of the
> installer , but launch it using the administrator rights too , and then set
> the master password.

Sorry I don't understand 100% what you write.

Can you tell me what I should exactly do?
Start as normal user and set master-pw?

(Ca delete the video from the host?)

Greetings by Daniel
Reporter

Updated

8 years ago
Version: 9 → 10
1) install thunderbird / but don't start it
2) launch thunderbird with admin rights
3) Set a master password

and sorry for the delay I have a lot of bugs to follow.
xref 589759 this might be the same issue, but I'm not sure. Does it goes away if you change your check intervals to say 5 minutes ?
Reporter

Comment 13

7 years ago
This is even faster to check than https://bugzilla.mozilla.org/show_bug.cgi?id=653678#c11

1.
I change my settings to 5 minutes.
See: http://img32.imageshack.us/img32/6349/tbbug5minutes.png
2.
I close my Thunderbird
3.
I open TB again as standart, not specially with admin rights
4.
I wait 5 minutes
5.
After 5 minutes it comes a secend dialog, wich ask me to put my master-pw into it
6.
I only have to put once a time my pass into one of these field to get acces to my mails
For example i can close the dialog, wich is open until the start ob tb and write my masterpw into the secend one wich comes after my inverall (in this case 5minutes) or i write in into the first dialog and close the other one.

f course i can put my pw directly into the first dialog, but i set TB to my autostart programs and often I start my pc and make me a coffe or something, after that I see more than 1 dialog.

Greetings by Daniel
Reporter

Updated

7 years ago
Version: 10 → 14
I can reproduce this behavior (Mac OS X 10.7).
duplicate of 275547 ?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All

Updated

3 years ago
Depends on: 643265
Summary: Master-Password Dialogs as much as the checking intervall settings → Master-Password Dialogs as much as the checking interval settings
Depends on: 177175

Updated

2 years ago
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584014
You need to log in before you can comment on or make changes to this bug.