Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: CodeMachine, Assigned: Nobody's working on this, feel free to take it)

Tracking

Details

(Whiteboard: 3.4)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Would be cool to have a feature to periodically send you out a reminder about a
bug.

This would be in a separate table like votes, and shouldn't change the bug's
last changed date.  It shouldn't ever notify anyone else (we might want to send
an initial message to the user), and should be totally private IMO.

We should restrict this to weekly multiples so this can be a cron job and we
have scope to aggregate multiple reminders to one user.

Something like:

[X] Send me a reminder mail about this bug every [_1_] week(s).

Optionally, we may also want to add reminder text, so the user remembers why
they're being reminded.

You should be able to query and show in bug lists whether a bug is reminded by
you - I don't think we need to make query or bug list handle the reminder text
or interval.

Comment 1

17 years ago
I've seen a lot of bug reports in the past couple days ;) but this one kinda 
jumped out at me... There should be something special about this reminder e-
mail so it could be easily filtered seperate of the normal bugmail.  Other than 
that, I don't have lot to add (esp. at this hour!).

Comment 2

17 years ago
See also the discussion in bug 35839.
(Reporter)

Updated

17 years ago
Whiteboard: 3.4

Comment 3

17 years ago
moving to real milestones...
Target Milestone: --- → Future

Comment 4

17 years ago
What about a 'Remind me on a particular date', or 'Remind me by this particular 
date' for one-shot reminders?

Comment 5

17 years ago
-> Bugzilla product, General component, reassigning.
Assignee: tara → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
(Reporter)

Comment 6

17 years ago
*** Bug 96985 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

17 years ago
Some ideas from bug #96985:

You could put a bug in a status called REMIND.  REMIND is considered "open" by
Bugzilla, to avoid all the problems we've had in the past with the REMIND
resolution.  But engineers can still remove REMIND bugs from their radars by
setting up appropriate queries.

You can also have one off reminders.  If you do this in the REMIND state, the
reminder should "reopen" the bug.
(Reporter)

Comment 8

17 years ago
Actions could look something like this for a resolved unconfirmed bug:

( ) Move to UNCONFIRMED (reopen)
( ) Move to REOPENED (reopen, confirm)
( ) Move to VERIFIED
(Reporter)

Comment 9

17 years ago
Ignore that last comment, wrong bug.

Comment 10

15 years ago
This feature would be of great issue with the Tech Evangelism effort. 
Currently, we try to do this through Target Milestones, but in my case, it does
not work very well.  For us, we do the following:
1. Diagnose site and find a fix.
2. Contact Webmaster to establish a date that problem will be fixed.
3. Set the month as the Target Milestone.

Hopefully, we will remember to periodically triage through the ASSIGNED bugs
with Target Milestones to make sure the bug has been fixed.  The problem,
however, is that we have a large number of bugs and if the Target Milestone is
set to Dec, we do not know if it is Dec 2000, 2001, 2002, etc.  If Quality
Assurance volunteers in that project could set a reminder date like commment #4,
then this issue could be circumvented.

Comment 11

15 years ago
I feel that this better fits in the Email Notifications component.
Reassigning all of my "future" targetted bugs to indicate that I'm not presently
working on them, and someone else could feel free to work on them.
Reassigning all of my "future" targetted bugs to indicate that I'm not presently
working on them, and someone else could feel free to work on them. (sorry for
the spam if you got this twice, it didn't take right the first time)
Assignee: justdave → nobody
While not as straightforward, for regular reminders it seems to me that this can
be done with the 2.19 whining possibilities, can't it?

Comment 15

13 years ago
Hello, All!

I've written an additional module to bugzilla and I am wondering if it may be of
 some interest to anyone.

Bugzilla_reminder consists of two PHP-scripts: 
one creating an additional reminder-creation window. After user provides
information, e-mail(s) and date info is written into separate MySQL table and
longdesc is updated.
The second script checks remindings periodically and sends them if necessary.

Comment 16

13 years ago
Created attachment 189268 [details]
Screenshot on my module...

This is main window, where you can input Date&Time, enter Message and e-mail.

Comment 17

13 years ago
Created attachment 189269 [details]
This is second screenshot on my module

You'll see this message after entering data

Comment 18

13 years ago
Created attachment 189271 [details]
Message sent to user

Comment 19

12 years ago
*** Bug 255562 has been marked as a duplicate of this bug. ***

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: Future → ---

Comment 20

11 years ago
Yes, this can be done with a combination of tagging and whining. As tagging gets even easier, this will improve.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.