If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Could not read extensions chrome manifest file (972ce4c6-7e08-4474-a285-3208198ce6fd = default theme)

VERIFIED FIXED in Thunderbird 5.0b1

Status

Thunderbird
Build Config
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: standard8, Assigned: Nomis101)

Tracking

Trunk
Thunderbird 5.0b1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
+++ This bug was initially created as a clone of Bug #586610 +++

Since the changes from Bug 579178, I see the following message in TBs error console:

Could not read chrome manifest file '/Volumes/Shredder/Shredder.app/Contents/MacOS/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/chrome.manifest'.

This extensions is the Thunderbird default theme.
(Reporter)

Comment 1

7 years ago
Created attachment 529950 [details] [diff] [review]
Workaround

This is Nomis' patch that I'm moving from bug 586610. It looks fine and has r=me.
Attachment #529950 - Flags: review+
(Reporter)

Updated

7 years ago
Keywords: checkin-needed
(Reporter)

Comment 2

7 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/a4a2d352aa47
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a4
Blocks: 654720
(Reporter)

Comment 3

7 years ago
I had to back this out because it busted the universal mac builds even after they were clobbered:

http://hg.mozilla.org/try-comm-central/rev/30c37ed6e0bb

I'm currently confused why that is the case though as I don't see anything wrong.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

7 years ago
I'm also confused. If you or anybody else don't have an idea, I will try to investigate this.

Seems unify doesn't work. Line 517 of /unify is about lines of a file and newlines. Maybe it will work if the empty chrome.manifest contains a newline?
(Assignee)

Comment 5

7 years ago
Created attachment 530434 [details] [diff] [review]
New patch that (hopefully) works

OK, I was able to reproduce this with an UB build. This new patch works for me. 
Can someone please test this on try, I don't want to break comm-central again...
Pushed http://tbpl.mozilla.org/?tree=Try&rev=7c4e4b223575
(In reply to comment #6)
> Pushed http://tbpl.mozilla.org/?tree=Try&rev=7c4e4b223575
I meant http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTry
Looks green to me.
(Assignee)

Comment 9

7 years ago
Thanks for pushing to try :-) Do I need now review again for the working patch? I never before had an patch that was backed out...
Comment on attachment 530434 [details] [diff] [review]
New patch that (hopefully) works

(In reply to comment #9)
> Thanks for pushing to try :-) Do I need now review again for the working
> patch? I never before had an patch that was backed out...

yes it's a new patch and thus needs review.
Attachment #530434 - Flags: review?(mbanner)
Status: REOPENED → ASSIGNED
(Reporter)

Comment 11

7 years ago
Comment on attachment 530434 [details] [diff] [review]
New patch that (hopefully) works

Thanks, that seems better. Checked in:

http://hg.mozilla.org/comm-central/rev/11953f14423a
Attachment #530434 - Flags: review?(mbanner) → review+
(Reporter)

Comment 12

7 years ago
It stuck this time :-)
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Comment 13

7 years ago
V. fixed, Windows 7 nightly (warning is present in 20110505 but not 20110506).
Status: RESOLVED → VERIFIED
Attachment #529950 - Attachment is obsolete: true
Duplicate of this bug: 620632
No longer blocks: 603198
You need to log in before you can comment on or make changes to this bug.