Last Comment Bug 654716 - Remove WinCE code from other-licenses/*
: Remove WinCE code from other-licenses/*
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on:
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-05-04 08:29 PDT by Ed Morley [:emorley]
Modified: 2011-05-09 10:21 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from other-licenses/bsdiff/Makefile.in (824 bytes, patch)
2011-05-04 10:01 PDT, Ed Morley [:emorley]
ted: review+
Details | Diff | Splinter Review
Remove WinCE code from other-licenses/bsdiff/Makefile.in (831 bytes, patch)
2011-05-09 07:01 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-05-04 08:29:02 PDT
WinCE & Windows Mobile code is being slowly removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the other-licenses/* parts of the removal:
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/other-licenses/
Comment 2 Ed Morley [:emorley] 2011-05-04 10:01:58 PDT
Created attachment 530053 [details] [diff] [review]
Remove WinCE code from other-licenses/bsdiff/Makefile.in

Going to ignore the MXR entries in comment 1 for now, since it appears 7zip support might no longer be needed at all after bug 652445 - so will deal with separately.

The only other WinCE remnant left in other-licenses/* now is in:
other-licenses/bsdiff/Makefile.in
Comment 3 Ed Morley [:emorley] 2011-05-04 17:30:47 PDT
Comment on attachment 530053 [details] [diff] [review]
Remove WinCE code from other-licenses/bsdiff/Makefile.in

http://dev.philringnalda.com/tbpl/?tree=Try&rev=ed18eff9dd9a

Thanks! :-)
Comment 4 Ted Mielczarek [:ted.mielczarek] 2011-05-09 06:44:25 PDT
Comment on attachment 530053 [details] [diff] [review]
Remove WinCE code from other-licenses/bsdiff/Makefile.in

Review of attachment 530053 [details] [diff] [review]:
-----------------------------------------------------------------

I didn't realize this was such a tiny patch or I would have just r+ed it right away!
Comment 5 Ed Morley [:emorley] 2011-05-09 07:01:15 PDT
Created attachment 531039 [details] [diff] [review]
Remove WinCE code from other-licenses/bsdiff/Makefile.in

Only change is updated commit message to include r=ted
Carrying forwards r+
Comment 6 Matt Brubeck (:mbrubeck) 2011-05-09 10:21:13 PDT
http://hg.mozilla.org/mozilla-central/rev/0abe8338b79b

Note You need to log in before you can comment on or make changes to this bug.