Last Comment Bug 655255 - Remove nsICharsetDetectionAdaptor from the tree
: Remove nsICharsetDetectionAdaptor from the tree
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla12
Assigned To: Henri Sivonen (:hsivonen)
:
: Makoto Kato [:m_kato]
Mentors:
Depends on:
Blocks: 655261 711790
  Show dependency treegraph
 
Reported: 2011-05-06 07:35 PDT by Henri Sivonen (:hsivonen)
Modified: 2012-01-09 15:09 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove nsICharsetDetectionAdaptor from the tree (15.23 KB, patch)
2011-05-06 07:40 PDT, Henri Sivonen (:hsivonen)
smontagu: review+
Details | Diff | Splinter Review

Description Henri Sivonen (:hsivonen) 2011-05-06 07:35:52 PDT
The new HTML parser uses chardet directly and makes nsICharsetDetectionAdaptor. Remove nsICharsetDetectionAdaptor as dead code once the old parser is gone.
Comment 1 Henri Sivonen (:hsivonen) 2011-05-06 07:40:25 PDT
Created attachment 530619 [details] [diff] [review]
Remove nsICharsetDetectionAdaptor from the tree
Comment 2 Henri Sivonen (:hsivonen) 2012-01-09 04:14:59 PST
nsHTMLContentSink is used for about:blank only these days, so this can land.
Comment 3 Henri Sivonen (:hsivonen) 2012-01-09 04:35:27 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/6e755023cdfa

Not adding an extension compat keyword, because extensions using this interface would have been broken since Firefox 4 anyway.
Comment 4 Ed Morley [:emorley] 2012-01-09 15:09:02 PST
https://hg.mozilla.org/mozilla-central/rev/6e755023cdfa

Note You need to log in before you can comment on or make changes to this bug.