slave-side slave-alloc support for w7/64

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: dustin, Assigned: armenzg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Similar to bug 629692, but for w7 systems.  These systems are not managed by any config management system, and do not have SSH.  Since we can't cause them to stop doing builds, we'll have to schedule a downtime and burn some builds.  

Alternately, they may all be configured on the same master, so we could just disable that master in slavealloc and graceful it.  I'll do some poking around to see how this can work.
Summary: slave-side slave-alloc support for w7/32 → slave-side slave-alloc support for w7/64
(Assignee)

Comment 1

8 years ago
FTR these systems have SSH installed.
(Assignee)

Comment 2

8 years ago
(In reply to comment #1)
> FTR these systems have SSH installed.
I just noticed you renamed the bug summary as talking about the 64-bit machines.
Please disregard.
Hardware: x86 → x86_64
Blocked until bug 656450 is solved, too.
Depends on: 656450
Armen, I'm handing this over to you.  At the moment, I only see three w764 testers running (all on bm05-tests1), and we don't have a refimage for me to upgrade.

I'm removing this from the tracking bug for the same reason.

As these get pushed further into production, please do something similar to bug 629692 - add c:\runslave.py and update startTalos.bat to invoke it.  Also, please store the startTalos.bat in the build/puppet-manifests repo.
Assignee: nobody → armenzg
(Assignee)

Updated

8 years ago
Priority: P3 → P5
(Assignee)

Updated

8 years ago
Assignee: armenzg → nobody
Blocks: 558448
(Assignee)

Comment 5

7 years ago
Let's get this finally done.
Assignee: nobody → armenzg
Status: NEW → ASSIGNED
Priority: P5 → P2
Armen was on buildduty last week. Hopefully he'll have time to tackle this work this week to unblock bug 674607.
(Assignee)

Comment 7

7 years ago
Created attachment 557649 [details] [diff] [review]
startTalos-w764.bat

Pretty much the same as http://hg.mozilla.org/build/puppet-manifests/raw-file/default/modules/buildslave/files/startTalos-w7.bat but changing the path of "C:\Program Files" to "C:\Program Files (x86)"

I have t-r3-w764-002 running with this and it has been able to connect through slavealloc. I will check later to see how it goes.
That should go into puppet, right?
(In reply to Armen Zambrano G. [:armenzg] - Release Engineer from comment #7)
> Created attachment 557649 [details] [diff] [review]
> startTalos-w764.bat

Does this need review? Can we get it flagged and/or landed?
I'm happy to see attachment 557649 [details] [diff] [review] landed in the appropriate place in puppet, with no need for further review.
(Assignee)

Comment 11

7 years ago
Created attachment 558535 [details] [diff] [review]
add startTalos-w764.bat to puppet repository

I was waiting to see it run the slaves with it.
Attachment #558535 - Flags: review?(dustin)
(Assignee)

Comment 12

7 years ago
Comment on attachment 558535 [details] [diff] [review]
add startTalos-w764.bat to puppet repository

I didn't see the previous comment.

Landed:
44b219c7790f
Attachment #558535 - Flags: review?(dustin) → checked-in+
(Assignee)

Comment 13

7 years ago
On t-r3-w764-ref:
1) install runslave.py
* open Cmd as Administrator
* cd C:\
* wget -Orunslave.py hg.mozilla.org/build/puppet-manifests/raw-file/44b219c7790f/modules/buildslave/files/runslave.py

2) deploy newer startTalos.bat
* cd Desktop
* wget -OstartTalos.bat http://hg.mozilla.org/build/puppet-manifests/raw-file/44b219c7790f/modules/buildslave/files/startTalos-w764.bat

Added instructions:
https://wiki.mozilla.org/index.php?title=ReferencePlatforms%2FTest%2FWin7_64-bit&action=historysubmit&diff=347126&oldid=345813
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.