Closed Bug 657054 Opened 10 years ago Closed 7 years ago

Re-enable asynchronous scrolling of input boxes

Categories

(Firefox for Android Graveyard :: Toolbar, defect)

defect
Not set
normal

Tracking

(fennec+)

RESOLVED DUPLICATE of bug 776030
Tracking Status
fennec + ---

People

(Reporter: stechz, Unassigned)

References

Details

To do this, we'll need to listen for scroll events for anything we set displayport on. I recommend we switch to a strategy where only one displayport is active at a time, so we'll need to be able to unset displayports.
Assignee: nobody → ben
Depends on: 655862
Depends on: 655852
No longer depends on: 655862
tracking-fennec: --- → ?
tracking-fennec: ? → 7+
tracking-fennec: 7+ → +
Assignee: ben → nobody
Keywords: qawanted
Is this still needed on
Component: Panning/Zooming → Graphics, Panning and Zooming
Product: Fennec → Firefox for Android
... native? Kats?
Keywords: qawanted
I'm not sure what the bug is asking for. Is it just the ability to drag-scroll text input fields? If so, then yeah I guess we need it on native because it doesn't seem to work right now.
Whiteboard: [mentor=kats][lang=c++]
We will get async panning of input fields for free when we switch over to APZC. There's not much point in reimplementing it in the Java APZC code.
Status: NEW → RESOLVED
Closed: 7 years ago
No longer depends on: apz-fennec
Resolution: --- → DUPLICATE
Whiteboard: [mentor=kats][lang=c++]
Duplicate of bug: apz-fennec
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.