View Page Source menu item is missing in "View" menu

RESOLVED WONTFIX

Status

()

Firefox
Menus
RESOLVED WONTFIX
7 years ago
4 years ago

People

(Reporter: Satish, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:6.0a1) Gecko/20110511 Firefox/6.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:6.0a1) Gecko/20110511 Firefox/6.0a1

View Page Source menu item is missing in "View" menu. I regularly use the shortcut Alt+V+O to view the source. This is missing in this nightly build. Not sure whether this is intentional or just missing. 

Reproducible: Always

Comment 1

7 years ago
This was changed by Bug 653221 .
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

7 years ago
OK... this is major UX change. From the beginning of Firefox 1.0 I have been accustomed to use the Alt+V+O to view the source. Now I need to go to Tools->Web Developer->View Source. This is very annoying. Is it possible to move it back to "View" menu? Please move it back...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
No, it will not be moved back. This specific item is mostly only important for a handful of people compared to our large user base. It makes totally sense to move that into a web developer sub-menu. Instead of hitting this strange key combo you can still use Ctrl+U to view the source of a page.

Closing as invalid.
Blocks: 653221
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INVALID
Version: unspecified → Trunk
(Reporter)

Comment 4

7 years ago
This is not a "strange" key combo. It is under View menu, so to activate the view menu we press "Alt+V". Then under that the View Source has accelerator "o" underlined, so we press "o". This is the Microsoft Windows UI standard way to navigate through menus.

Comment 5

6 years ago
But "Page source" was just removed from "View" menu. 

Unlike "Page Info" that was moved to "Tools" menu.
(Reporter)

Comment 6

6 years ago
"Page Source" should belong to "View" menu as it has been from the inception of the Firefox browser. I still don't understand the motive behind moving it to "Web Developer" menu. Not everyone who views the page source is a web developer. I am not sure what help it will do to move it from the age-old location to a completely new location.
(Reporter)

Comment 7

6 years ago
Please move the "Page source" to View menu if shown, otherwise (in case of tabs on top and menu bar hidden), keep it in Web Developer menu.

Please see the Bug 653221 for a discussion on this.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
specifically comment #30.

Fwiw, I'm not sure I agree with Page Source living under the Web Developer sub-menu in tools. It fairly buries that option and it's lived in the View menu since 1.0 as Satish says.

I'm confirming this bug for further evaluation.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Rob Campbell [:rc] (robcee) from comment #8)
> It fairly buries that option

Not more than any other dev tool. Why should this be special?

> and it's lived in the View menu since 1.0 as Satish says.

*shrug*
Looking at the reasons given there, I don't see a valid reason to move it back to the View menu.

* Used by support volunteers: 
Speaking as a former SUMO team member, and current admin for the support newsgroups, I don't think "Page Source" being used by support volunteers should affect this decision. The use case is that if someone is having trouble with a page rendering improperly, supporters knowledgeable in web development can look at the page source to get a better idea of why the page is not rendering properly. Support volunteers use almost any menu item, because it depends what the problem is that the user is having.

* Alt+V+O:
Satish, you are the one and only person I've ever seen use that shortcut for Page Source. The keyboard shortcut that has been documented and given to users has always been Ctrl-U. A quick search of support.mozilla.org reveals that no-one has asked about Alt+V+O.

* It's been in the View menu since the first version:
That should never prevent designers from improving Firefox. The only concern there is if it's too much change too quickly.
(Reporter)

Comment 11

6 years ago
Chirs, regarding Alt+V+O. It is nothing new. It is the standard Microsoft Windows way of selecting menus. Alt+V is for selecting "View" menu. While on View menu, the "accelerator" for the "Page Source" is "O" (you see it as an underlined character). So when I say Alt+V+O it is Alt+V and the pressing "O". This is a fairly standard way of selecting menu (and sub menu) items in Windows. I am not sure why you have not seen any one doing this, but I have seen (including myself).
Satish, as has been pointed out already, Ctrl+U is there for your convenience.
Status: NEW → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → WONTFIX

Comment 13

5 years ago
Why is everyone acting so rude about this issue? 


I too believe it is a much bigger inconvenience to us tech savvy people than is is for non techs who might accidentally click it and maybe even learn something..

The fact of the matter is I dont have time to learn all the hot-keys from every program by heart, but what I did learn was that I can easily access the page source from the view menu.

Im sorry if bringing this up upsets people, but honestly, I dont think you are giving the right message by hiding this option deep with in the bowls of the menu bar.

I mean, just so you can get an understanding of my position on this.

I first learned how to read code, by accidentally opening the page view menu over 8 years ago.

I think its time Mozilla objectively considers what they are trying to support here, and try it back.

Leave the dumbed down ease of use stuff to default browsers, like IE or Safari.


Yes, I know its 2013, but better late than never and you can keep my 2 cents.
(Reporter)

Comment 14

5 years ago
F2Mp9M1, it is 2013 and I am still here and will be happy to see the View Page Source in the View menu. But I don't think it will be done. But keeping hope is not a bad idea.

Updated

4 years ago
Duplicate of this bug: 867906

Comment 16

4 years ago
Just wanted to chime in and say that although thanks to this bug report I now once again know how to view source, I've always gotten there with the Alt-V-O method as well.  IMO it's easier to remember keyboard shortcuts that correspond to menu structure than random hotkeys.  That said, as long there's a keyboard shortcut for it of some kind, I'm not too concerned where it lives.

Comment 17

4 years ago
As far as I know, Ctrl+U was always the standard shortcut for view source, despite any obscure menu-dependant alternative shortcuts. I think it was like that ever since the Netscape days. However, for those strange few that really long for a more complicated keyboard shortcut, this extension should do the trick.

https://addons.mozilla.org/en-US/firefox/addon/restore-view-source/
You need to log in before you can comment on or make changes to this bug.