Closed Bug 657232 Opened 9 years ago Closed 9 years ago

Firefox 4 consumes far-too much memory and appears to increase memory usage over time.

Categories

(Firefox :: General, defect, major)

4.0 Branch
x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ian.seale, Unassigned)

References

Details

(Keywords: memory-leak)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17

Firefox 4 consumes far-too much memory, slowing down and freezing with only one or two tabs open, and appears to increase memory usage over time.

I have not changed hardware or software, have not changed the way I work, and I'm not running any complex or unusual applications - or putting any other demand on Firefox 4 that I didn't apply to Firefox 3.6.16. 

The "excessive Memory usage" problem did not occur on previous versions of Firefox and has only occurred since using (or trying to use) Firefox 4.

Reproducible: Always


Actual Results:  
I'm using Firefox 3.6.17 because Firefox 4 is unusable (as above)


I'm using Firefox 3.6.17 because Firefox 4 is unusable (as above)
Does the issue still occur if you start Firefox in Safe Mode?
https://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile?
https://support.mozilla.com/en-US/kb/Basic+Troubleshooting#w_8-make-a-new-profile
Version: unspecified → 4.0 Branch
A likely dupe of bug 598466
Guys,

I'm just a user.  Quite technically savvy, but I've only posted here because I'm getting nowhere with the forum and this seems to be quite a common problem with Firefox 4.

I'm running Firefox 3.6.17 OK.  Firefox 4 was so bad, I won't be going back to it until there is a fix.
(In reply to comment #3)
 
> I'm just a user.  Quite technically savvy, but I've only posted here because
> I'm getting nowhere with the forum and this seems to be quite a common
> problem with Firefox 4.
> 
> I'm running Firefox 3.6.17 OK.  Firefox 4 was so bad, I won't be going back
> to it until there is a fix.

Note
The thread in question on the SUMO Firefox support site is https://support.mozilla.com/en-US/questions/811150

I am not sure this adds anything to existing meta list  bug 640452
Is it okay to close as IMCOMPLETE then (Sorry Ian)?
Well, no, actually no it isn't.

If the problem "Firefox 4 consumes far-too much memory and appears to increase memory usage over time" is contained within another bug report (I've seen others that appear very similar) I'd appreciate someone directing me to what has been happening with that bug report or, more importantly, what solution has been found.

As I have said before, from a diagnostic standpoint, everything remains equal, only Firefox has changed - 3.6.16 (3.6.17) was good - 4.0 was bad.

You could watch the memory FF 4.0 was using constantly climbing with just one or two tabs open.  I saw some post elsewhere on a bug report that they were surprised that FF 4 had not been tested properly before launch.  This problem appears to be quite well known.

Please, by all means, close this bug report if someone posts an admission to the problem with FF 4 and, again, the important bit, the fix - is it fixed in the next software revision, or will it be fixed in 5?
A lot of people will desert Firefox if this is not sorted.
Bug 640452, and the two related meta bugs were created to do just what you are asking, they mention previous bugs and are listing and tracking open bugs relating to
-  memory usage and leaks
- (bug 640457) tracking other memory problems
- (bug 640791) improving memory reporting
Blocks: mlk-fx5+
Keywords: mlk
Whiteboard: [NEEDS ANALYSIS]
Ian, we appreciate the report, but it's likely this bug will be closed because there are a number of prior bugs like this one.  You'll be interested by http://blog.mozilla.com/nnethercote/2011/05/24/leak-reports-triage-may-24-2011-2/  This is an example of a bug I would classify as "[CLOSE?]" -- without specific steps to reproduce (eg. a specific website that triggers the problem) and some memory measurements, it's almost impossible for developers to do anything useful.

Having said that, Firefox 5 has fixed a number of leaks, which might be enough to get rid of the problem for you.  Eg. see bug 640923 comment 27.  It would be good to know if this helps you.  You can get Firefox 5 betas at http://beta.mozilla.org.
Thanks for the information and help Nick.

I've just upgraded from Firefox 3.6.17 to Beta 5 and it at first appeared to be a lot more stable and responsive than Firefox 4.

Intitial memory usage (with 3 Tabs open - BBC News, BT Yahoo Mail and this one) was 142,000k and stable.

However, checking the memory usage 5 minutes in the usage was steadily climbing (as I was experiencing in FF 4) by 100k increments at every refresh.
On this occasion (not like in FF 4 where it kept on climbing) memory usage levelled out at 170,000k and then fell back to under 150,000k but continued to climb but in much smaller increments (10k to 50k jumps).

Another 5 minutes in and memory usage was up to 160,000k - this is with absolutely nothing going on - and still continuing to climb - in the time it's taken to type this it has risen by 6,000k.

From memory, memory usage on Firefox 3.6.17 did vary between 90,000k and 120,000k but was stable.

9:32am - Checking back on Task Manager memory usage is now up to 170,000k.

Memory usage on Firefox 4 was higher, and climbed even higher, so by comparison, FF 5 looks better, but still has a problem - just less of one.

9:34am - Checking back on Task Manager memory usage is now up to 176,000k.

9:35am - Checking on Task Manager memory usage has dropped back to 124,000k.

9:37am - Checking on Task Manager memory usage is rising again to 130,000k.

OK - So this is a little weird - Firefox 5 seems to have the same memory climbing problem (but to less of an extent) - but 'tops out' at 170,000k-180,000k and 'resets' to around 120,000 - only to climb gradually again.

9:41am - Checking on Task Manager memory usage is rising again to 138,000k.

If Firefox 5 becomes unusable, I'll check memory to see if it's gone over 180,000k - but I suspect the cycle (above) will repeat itself - in which case the memory climbing will not be enough to affect functionality.

Once again, thanks for your help.
Ian, where are you getting your measurements from?

You might like to try loading the page called "about:memory", which tells you various things about Firefox's memory usage.  In Firefox 5 it's output isn't great, it'll be better in Firefox 6, but the breakdown might be informative.  I would expect that the js/gc-heap is probably going up and down a lot.  The up and downs you are seeing are to be expected, because garbage collection occurs periodically.  Memory usage rising when nothing is happening is not necessarily unexpected either, because lots of websites continually do stuff even if you don't touch them.

Are you happy if I close this bug, based on (a) your improved results, and (b) the list of existing similar bugs we have about memory usage?
Hi Nick,

My measurements are taken from Windows Task Manager.

10:44am - Checking on 'Task Manager' memory usage is 175,000k.
This is with 4 tabs open (BBC News, Facebook, BT Yahoo Mail, and this one).

Firefox 5 (Beta) is usable though, where Firefox 4 just plain wasn't - so I am pleased that Mozilla has identified and rectified the problem - and will win it's friends back.

10:49am - Checking on 'Task Manager' memory usage is 183,000k.
10:50am - Checking on 'Task Manager' memory usage is 142,000k.

So it appears Firefox 5 is 'dumping' garbage at around 185,000k memory.

Thank you for all your help.
Please close this 'Bug' but please note that the fix was to upgrade to Firefox 5 Beta should anyone else be searching for a solution.
Thanks, Ian!
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
One final 'additional' before this one gets closed.

I upgraded to Firefox 5 on one of my laptops (the data above) and left the other one running 3.6.17 (they are both similar age, processor, memory and the same operating system).

With the same 3 tabs open on the same 3 websites Firefox 3.6.17 is running at a stable 130,000k memory.
It fluctuates by about 5,000k, but that is it, no 'climbing' or 'climbing' and 're-setting' at all - just stays more-or-less the same.
You can see how stable FF 3.6.17 is from the stats below:

12:44pm - Checking on 'Task Manager' memory usage is 130,008k.
12:46pm - Checking on 'Task Manager' memory usage is 130,324k.
12:47pm - Checking on 'Task Manager' memory usage is 130,984k.
12:48pm - Checking on 'Task Manager' memory usage is 131,024k.
12:49pm - Checking on 'Task Manager' memory usage is 131,952k.
12:50pm - Checking on 'Task Manager' memory usage is 130,028k.
12:54pm - Checking on 'Task Manager' memory usage is 133,836k.
12:56pm - Checking on 'Task Manager' memory usage is 134,672k.

So, even though Firefox 5 is miles better than Firefox 4 in its memory management/demand there is still something different in the build (from Firefox 3.6.17) that causes it to increase memory usage over time - even if it then re-sets as it 'dumps' garbage.
So this might be the new 'normal', but it wasn't normal in FF 3.6.17.

FF 5 is good, but maybe there is something there that still needs a tweak to make it more stable (like FF 3.6.17).
Whiteboard: [NEEDS ANALYSIS]
Resolution: FIXED → WORKSFORME
Dão, why did you change from FIXED to WORKSFORME?  Sounds like the various fixes that have occurred since 4.0 was released mean that this problem has been fixed.
It's a sometimes fuzzy distinction, but FIXED tends to be used for cases where the cause of a problem is understood and known to be fixed by some specific bug(s) that already landed. WORKSFORME tens to be a better fit for cases where the exact cause of a problem isn't understood or a specific change can't be pinpointed.
Guys, I have to support Ian with this. I'm also a user (and software tester by profession) and as much as I love working with Firefox sometimes it is just impossible. As Ian described starting Firefox consumes over 130MB of memory (taken from Windows Task Manager) which is more than twice than any other application (for me - Skype and Outlook which consumes about 50MB). Soon it grows to large numbers. At this moment of reporting this issue my Firefox consumes about 420,000 KB!!! And all I have open is this tab, 2 Wikipedia tabs and Gmail as App Tab.
I had this problem with early 3.6 versions and it was solved.
I would really appreciate if this problem will be solved.
I won't reopen this bug, but it's worth noting that bug 656120 which has been fixed in Nightly builds (you can download from nightly.mozilla.org) has fixed a lot of problems with gradually rising memory usage.  You might like to try it.
You need to log in before you can comment on or make changes to this bug.