Last Comment Bug 657748 - Update ANGLE to r653
: Update ANGLE to r653
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla6
Assigned To: Benoit Jacob [:bjacob] (mostly away)
:
Mentors:
: 646229 (view as bug list)
Depends on: 648804 674731
Blocks: 657619 673559
  Show dependency treegraph
 
Reported: 2011-05-17 13:12 PDT by Benoit Jacob [:bjacob] (mostly away)
Modified: 2012-01-08 08:55 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
part 1. [PLACEHOLDER] Unapply r68002 (update ANGLE to r611) (111 bytes, patch)
2011-05-17 13:36 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review
part 2. [PLACEHOLDER] Unapply r68001 (update ANGLE to r551) (111 bytes, patch)
2011-05-17 13:37 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review
part 3. [PLACEHOLDER] Unapply r68000 (ANGLE Makefiles) (111 bytes, patch)
2011-05-17 13:39 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review
part 4. [PLACEHOLDER] Unapply r67999 (renaming debug->compilerdebug) (111 bytes, patch)
2011-05-17 13:40 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review
part 5. [PLACEHOLDER] Unapply local ANGLE patches (111 bytes, patch)
2011-05-17 13:42 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review
part 6. [PLACEHOLDER] Upgrade ANGLE to r653 (111 bytes, patch)
2011-05-17 13:44 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review
part 7. [PLACEHOLDER] Reapply local ANGLE patches (angle-nspr-misc and angle-shared) (111 bytes, patch)
2011-05-17 13:47 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review
Part 8. Reapply the debug->compilerdebug change (6.43 KB, patch)
2011-05-17 13:49 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review
part 9. Update and reapply the Makefiles (13.57 KB, patch)
2011-05-17 13:52 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review
part 10. Update the local patches and the README (66.96 KB, patch)
2011-05-17 13:57 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review
part 11: work around intrin.h compilation error on MSVS2005 (1.51 KB, patch)
2011-05-18 11:41 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review
part 12: disable fshaderWith256CharacterIdentifier test, crashes linux test slaves (1.44 KB, patch)
2011-05-24 05:46 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review
part 13: reject the Februrary 2010 SDK at configure time (2.60 KB, patch)
2011-05-24 06:37 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review

Description Benoit Jacob [:bjacob] (mostly away) 2011-05-17 13:12:19 PDT
Contrary to what we believed, newer ANGLE does not require the June 2010 DirectX SDK.
Comment 1 Benoit Jacob [:bjacob] (mostly away) 2011-05-17 13:16:11 PDT
Try push:
http://tbpl.mozilla.org/?tree=Try&rev=8012d1e9211d
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2011-05-17 13:36:34 PDT
Created attachment 533050 [details] [diff] [review]
part 1. [PLACEHOLDER] Unapply r68002 (update ANGLE to r611)

This is just a placeholder for reversing r68002 (update of ANGLE to r611)
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2011-05-17 13:37:38 PDT
Created attachment 533051 [details] [diff] [review]
part 2. [PLACEHOLDER] Unapply r68001 (update ANGLE to r551)

Just a placeholder for reversing r68001 (update ANGLE to r551)
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2011-05-17 13:39:09 PDT
Created attachment 533052 [details] [diff] [review]
part 3. [PLACEHOLDER] Unapply r68000 (ANGLE Makefiles)

placeholder for reversing r68000 (ANGLE Makefiles)
Comment 5 Benoit Jacob [:bjacob] (mostly away) 2011-05-17 13:40:22 PDT
Created attachment 533053 [details] [diff] [review]
part 4. [PLACEHOLDER] Unapply r67999 (renaming debug->compilerdebug)

placeholder for reversing r67999 (renaming debug->compilerdebug)
Comment 6 Benoit Jacob [:bjacob] (mostly away) 2011-05-17 13:42:52 PDT
Created attachment 533055 [details] [diff] [review]
part 5. [PLACEHOLDER] Unapply local ANGLE patches

placeholder for unapplying our local ANGLE patches:
  angle-fixes.patch
  angle-nspr-misc.patch
  angle-pbuffers.patch
  angle-shared.patch
Comment 7 Benoit Jacob [:bjacob] (mostly away) 2011-05-17 13:44:26 PDT
Created attachment 533057 [details] [diff] [review]
part 6. [PLACEHOLDER] Upgrade ANGLE to r653

placeholder for applying the ANGLE diff from r550 to r653.
Comment 8 Benoit Jacob [:bjacob] (mostly away) 2011-05-17 13:47:38 PDT
Created attachment 533058 [details] [diff] [review]
part 7. [PLACEHOLDER] Reapply local ANGLE patches (angle-nspr-misc and angle-shared)

placeholder for reapplying angle-nspr-misc.patch and angle-shared.patch.

The other two patches we had have been merged upstream.
Comment 9 Benoit Jacob [:bjacob] (mostly away) 2011-05-17 13:49:53 PDT
Created attachment 533060 [details] [diff] [review]
Part 8. Reapply the debug->compilerdebug change
Comment 10 Benoit Jacob [:bjacob] (mostly away) 2011-05-17 13:52:10 PDT
Created attachment 533065 [details] [diff] [review]
part 9. Update and reapply the Makefiles

In addition to a few new .cpp files, we have to link to D3DCompiler.lib.
Comment 11 Benoit Jacob [:bjacob] (mostly away) 2011-05-17 13:57:44 PDT
Created attachment 533066 [details] [diff] [review]
part 10. Update the local patches and the README

This will make future updates easier.
Comment 12 Benoit Jacob [:bjacob] (mostly away) 2011-05-18 11:41:39 PDT
Created attachment 533346 [details] [diff] [review]
part 11: work around intrin.h compilation error on MSVS2005

This is a fix for ANGLE issue, http://code.google.com/p/angleproject/issues/detail?id=158

It works around a MSVS 2005 build problem.
Comment 13 Benoit Jacob [:bjacob] (mostly away) 2011-05-18 11:42:54 PDT
At this point, what's blocking us from proceeding with this ANGLE upgrade is that newer ANGLE requires the June 2010 SDK, that's not installed on our builders.
See http://code.google.com/p/angleproject/issues/detail?id=158
and bug 648804.
Comment 14 Benoit Jacob [:bjacob] (mostly away) 2011-05-18 12:08:02 PDT
*** Bug 646229 has been marked as a duplicate of this bug. ***
Comment 15 Benoit Jacob [:bjacob] (mostly away) 2011-05-24 05:46:15 PDT
Created attachment 534741 [details] [diff] [review]
part 12: disable fshaderWith256CharacterIdentifier test, crashes linux test slaves

This fixes an orange I had on linux test slaves: this sub-test was crashing the NVIDIA 190.42 linux driver. Not worth fighting against. The reason why that wasn't crashing before is that ANGLE used to block that and now it forwards it to the GL.
Comment 16 Benoit Jacob [:bjacob] (mostly away) 2011-05-24 05:46:49 PDT
green on try:
http://tbpl.mozilla.org/?tree=Try&rev=81fdbb3e5bfb
Comment 17 Benoit Jacob [:bjacob] (mostly away) 2011-05-24 06:37:05 PDT
Created attachment 534748 [details] [diff] [review]
part 13: reject the Februrary 2010 SDK at configure time

Tested on your WinXP laptop.

Note You need to log in before you can comment on or make changes to this bug.