Missing prompt before deleting messages via [Del] in trash and via [Shift]+[Del] in any mail folder

RESOLVED DUPLICATE of bug 308690

Status

RESOLVED DUPLICATE of bug 308690
8 years ago
7 years ago

People

(Reporter: dfghjkjhg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: 

- If I select a message in the   TRASH FOLDER   and then (maybe accidentally) hit the   [Del]   key, the message disappears immediately without any warning/prompt whether I really want to delete this message (unlike e. g. MS Outlook does).

- Please make also sure that users are prompted for a confirmation when deleting mails via   [Shift]+[Del]   in   ANY FOLDER   (not only in trash).

Reproducible: Always

Steps to Reproduce:
1a) Select an e-mail in the TRASH FOLDER and press the [Del] key
or
1b) Select an e-mail in ANY FOLDER (not only in trash) and press the [Shift]+[Del] keys

2. The message immediately disappears without any warning

Comment 1

8 years ago
On IMAP, this isn't an issue, since you can just undo. It doesn't look like that works for local folders, though.
One issue per bug, please.

shift+del issue is a dupe of bug #308690 

first issue (del on a message in trash folder) is here also in local folder
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 308690
(Reporter)

Comment 4

7 years ago
I opened a new/clean for ony "DEL in Trash":
Bug 661513
You need to log in before you can comment on or make changes to this bug.