Closed Bug 660019 Opened 8 years ago Closed 8 years ago

Special characters (UTF-8) are displayed incorrect

Categories

(Thunderbird :: Message Reader UI, defect, major)

defect
Not set
major

Tracking

(thunderbird6 fixed, thunderbird7 fixed)

VERIFIED FIXED
Thunderbird 8.0
Tracking Status
thunderbird6 --- fixed
thunderbird7 --- fixed

People

(Reporter: toscha, Assigned: Bienvenu)

References

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:7.0a1) Gecko/20110526 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:7.0a1) Gecko/20110526 Thunderbird/3.4a1pre ID:20110526030123

If you read a message containing special / foreign characters, encoded as UTF-8, they're displayed fine. If you change the newsgroup, reading other messages in UTF-8, suddenly special characters (every encoding, not only UTF-8 but also e.g. iso-8859-1/-15) are displayed incorrect.

Reproducible: Always

Steps to Reproduce:
1. Have message in UTF-8, containing special characters (e.g.  <4DDD3D2B.2090104@news.toscha.de>, characters are displayed fine
2. Change Group, switch among messages
3. Suddenly special characters are displayed incorrect

Actual Results:  
Incorrect display of foreign / special characters, although correct declared.

Expected Results:  
Correct display of foreign / special characters
What's also strange, sometime maybe after an hour, when I go to the same message again it's correctly displayed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
I can confirm this bug. In MID: <4E2B63A6.5070709@hfigge.myfqdn.de> H.Figge find a window for last good and first bad:
2011-05-21 14:40:00 PDT
2011-05-23 04:31:00 PDT

And someone should change 'Platform' from 'x86 Windows 7' to 'all'.

With the new rapid release cycles in TB, this bug appears in the branch in some weeks. :-)
OS: Windows 7 → All
Hardware: x86 → All
This Bug is caused by changes in nsMsgProtocol.cpp from Patch attachment 534314 [details] [diff] [review] (Bug 658877).
I have removed these changes and the Bug was gone.
(In reply to comment #5)
> This Bug is caused by changes in nsMsgProtocol.cpp from Patch attachment
> 534314 [details] [review] (Bug 658877).
> I have removed these changes and the Bug was gone.

Ah, thx for figuring that out. I assume you're talking about the content charset changes. I'll back those out.
I don't think we want to ship TB 6 with this, since it should not have landed in the first place.
Assignee: nobody → dbienvenu
Attachment #548263 - Flags: approval-comm-beta?
http://hg.mozilla.org/comm-central/rev/cf242a5c4d70

backed out on trunk.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 8.0
Attachment #548263 - Flags: approval-comm-aurora?
Note to self:
Check tomorrow's nightly to see if this resolves bug 667736 as well.
Duplicate of this bug: 667736
Attachment #548263 - Flags: approval-comm-beta?
Attachment #548263 - Flags: approval-comm-beta+
Attachment #548263 - Flags: approval-comm-aurora?
Attachment #548263 - Flags: approval-comm-aurora+
Verified fixed with steps in duplicate bug 667736
Mozilla/5.0 (Windows NT 5.0; rv:8.0a1) Gecko/20110726 Thunderbird/8.0a1 ID:20110726030034
Status: RESOLVED → VERIFIED
Comment on attachment 548263 [details] [diff] [review]
backout part of patch that shouldn't have landed

Adding back approval flag that was mistakenly removed. dkl
Attachment #548263 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.