Closed Bug 660400 Opened 12 years ago Closed 12 years ago

Panorama thumbnails from the previous session are not visible in tabs to be loaded

Categories

(Firefox Graveyard :: Panorama, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 658913

People

(Reporter: 326374, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:6.0a2) Gecko/20110527 Firefox/6.0a2
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:6.0a2) Gecko/20110527 Firefox/6.0a2

This is almost an ("intended") regression, caused by "Panorama Groups on Demand". In previous versions (e.g. Fx 5) all tabs loaded at startup, and thus the thumbnails were available. Now, however, they are not, so Firefox should cache them.

Reproducible: Always

Steps to Reproduce:
1. Set the browser to remember tabs and windows from the last session.
2. Create multiple panorama groups with some tabs in each.
3. Quit Firefox, and restart.
4. Switch to panorama view.

Actual Results:  
White boxes are shown for all but the active panorama group.

Expected Results:  
The thumbnail of each tab appears.

In addition to displaying the previous thumbnails, it would be really good if it shows the current status as well (that is, that those tabs haven't yet been loaded).

I suggest a darker overlay on top of the thumbnail, and on top of that some text along the lines of "Not loaded".
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 658913
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.