Last Comment Bug 660861 - pyxpidl tracking
: pyxpidl tracking
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
Mentors:
Depends on: 677395 458936 578478 578790 660879 677922
Blocks: 665409 666199
  Show dependency treegraph
 
Reported: 2011-05-31 09:05 PDT by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2011-09-19 05:35 PDT (History)
18 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-05-31 09:05:26 PDT
For replacing xpidl with a python version.
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-05-31 15:40:54 PDT
Per conversation today with jst, this is not an immediate priority.
Comment 2 Boris Zbarsky [:bz] 2011-06-01 07:50:37 PDT
Why not?

This is blocking dom bindings work and is blocking HTML5 implementation work.  There are parts of HTML5 that we simply can't implement right now because the IDL they use can't be expressed in a way xpidl understands (e.g. interfaces shadowing properties on ancestor interfaces).
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-07-20 17:32:00 PDT
This is a Q3 goal and I'm actively working on it again.
Comment 4 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-09-19 05:35:06 PDT
Declaring victory here.

Note You need to log in before you can comment on or make changes to this bug.