(make check failures) Windows x86-64 failing a few random things in jit_test.py most builds

RESOLVED FIXED in mozilla9

Status

()

Core
JavaScript Engine
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: philor, Assigned: m_kato)

Tracking

(Blocks: 2 bugs, {intermittent-failure})

Trunk
mozilla9
x86_64
Windows 7
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [js-triage-needed][inbound])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Tough to say exactly when it started, or whether it started from code-related reasons or not, since the builds are hidden so nobody ever looks at them, and there's only one build slave so it runs on random pushes when it gets around to it.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307575035.1307588579.1656.gz
WINNT 6.1 x86-64 mozilla-central build on 2011/06/08 16:17:15
s: mw64-ix-slave01

TEST-UNEXPECTED-FAIL | jit_test.py -a -m -j -p    | e:\builds\moz2_slave\cen-w64\build\js\src\jit-test\tests\jaeger\bug577580.js
(Reporter)

Comment 1

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307603173.1307615792.6604.gz
TEST-UNEXPECTED-FAIL | jit_test.py -a -m -j | e:\builds\moz2_slave\cen-w64\build\js\src\jit-test\tests\jaeger\bug554580-1.js
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 4

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307692499.1307697196.3590.gz
TEST-UNEXPECTED-FAIL | jit_test.py -m -j -p | e:\builds\moz2_slave\cen-w64\build\js\src\jit-test\tests\basic\bug584499-1.js: 1
TEST-UNEXPECTED-FAIL | jit_test.py -m | e:\builds\moz2_slave\cen-w64\build\js\src\jit-test\tests\jaeger\bug577580.js
(Reporter)

Comment 5

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307697303.1307709146.1544.gz
TEST-UNEXPECTED-FAIL | jit_test.py -j | e:\builds\moz2_slave\cen-w64\build\js\src\jit-test\tests\closures\bug540131-2.js
(Reporter)

Comment 6

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307930414.1307942420.13482.gz
TEST-UNEXPECTED-FAIL | jit_test.py -m -j | e:\builds\moz2_slave\cen-w64\build\js\src\jit-test\tests\basic\bug605015.js: undefined
(Reporter)

Comment 7

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307947790.1307952331.11589.gz
TEST-UNEXPECTED-FAIL | jit_test.py -a -m -j | e:\builds\moz2_slave\cen-w64\build\js\src\jit-test\tests\basic\bug601395.js
(Reporter)

Comment 8

6 years ago
Still happening, like two of the last six, but I'm no longer forced to watch tbpl.m.o/?noignore=1, so I no longer see them or have to star them.
(Assignee)

Updated

6 years ago
Depends on: 669564
Duplicate of this bug: 670697

Comment 10

6 years ago
# Failures from June 27th to July 9th
FAILURES:
    e:\builds\moz2_slave\m-cen-w64\build\js\src\jit-test\tests\closures\bug540131-2.js
    e:\builds\moz2_slave\m-cen-w64\build\js\src\jit-test\tests\jaeger\bug554580-2.js
FAILURES:
    e:\builds\moz2_slave\m-cen-w64\build\js\src\jit-test\tests\jaeger\bug624100.js
FAILURES:
    -a -m -j -p e:\builds\moz2_slave\m-cen-w64\build\js\src\jit-test\tests\basic\bug601395.js
    -a -m -d e:\builds\moz2_slave\m-cen-w64\build\js\src\jit-test\tests\jaeger\bug577580.js
    -a -m -j e:\builds\moz2_slave\m-cen-w64\build\js\src\jit-test\tests\jaeger\bug583684.js
FAILURES:
    -m e:\builds\moz2_slave\m-cen-w64\build\js\src\jit-test\tests\basic\bug582161.js
    -a -m -j e:\builds\moz2_slave\m-cen-w64\build\js\src\jit-test\tests\jaeger\bug549393-1.js
    -a -m -j -p e:\builds\moz2_slave\m-cen-w64\build\js\src\jit-test\tests\jaeger\bug580883.js
    -m -j e:\builds\moz2_slave\m-cen-w64\build\js\src\jit-test\tests\jaeger\bug627486.js
FAILURES:
    e:\builds\moz2_slave\cen-w64\build\js\src\jit-test\tests\jaeger\bug583684.js
    -a -m -d e:\builds\moz2_slave\cen-w64\build\js\src\jit-test\tests\jaeger\bug600139.js
FAILURES:
    -a -m e:\builds\moz2_slave\cen-w64\build\js\src\jit-test\tests\closures\nameinc-loop-missing.js
FAILURES:
    -a -m e:\builds\moz2_slave\cen-w64\build\js\src\jit-test\tests\jaeger\bug582900.js
FAILURES:
    -m -j -p e:\builds\moz2_slave\cen-w64\build\js\src\jit-test\tests\basic\bug602088.js

TIMEOUTS:
make[1]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox/js/src'
make[1]: *** [check-jit-test] Error 2
make[1]: Target `check' not remade because of errors.
make: *** [check] Error 2
Blocks: 471090, 558448
Whiteboard: [orange] → [orange][js-triage-needed]

Updated

6 years ago
No longer blocks: 558448

Updated

6 years ago
Blocks: 558448
Summary: Windows x86-64 failing a few random things in jit_test.py most builds → (make check failures) Windows x86-64 failing a few random things in jit_test.py most builds
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1313833169.1313845468.29475.gz

s: w64-ix-slave36
TEST-UNEXPECTED-FAIL | jit_test.py -j             | e:\builds\moz2_slave\fx-team-w64\build\js\src\jit-test\tests\jaeger\bug554580-3.js
make[1]: *** [check-jit-test] Error 2
make: *** [check] Error 2
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1313916320.1313920443.31597.gz

s: w64-ix-slave12
TEST-UNEXPECTED-FAIL | jit_test.py -a -m -j -p    | e:\builds\moz2_slave\fx-team-w64\build\js\src\jit-test\tests\jaeger\bug627486.js
make[1]: *** [check-jit-test] Error 2
make: *** [check] Error 2
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1313923340.1313927496.27629.gz

s: w64-ix-slave12
TEST-UNEXPECTED-FAIL | jit_test.py -a -m          | e:\builds\moz2_slave\fx-team-w64\build\js\src\jit-test\tests\jaeger\bug582882.js
TEST-UNEXPECTED-FAIL | jit_test.py -a -m -d       | e:\builds\moz2_slave\fx-team-w64\build\js\src\jit-test\tests\jaeger\instanceOfWithKnownTypes.js
make[1]: *** [check-jit-test] Error 2
make: *** [check] Error 2
Comment hidden (Treeherder Robot)
tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1313999609.1314003904.707.gz

s: w64-ix-slave36
TEST-UNEXPECTED-FAIL | jit_test.py -m             | e:\builds\moz2_slave\fx-team-w64\build\js\src\jit-test\tests\jaeger\bug624100.js
make[1]: *** [check-jit-test] Error 2
make: *** [check] Error 2
Comment hidden (Treeherder Robot)

Comment 17

6 years ago
(In reply to TinderboxPushlog Robot from comment #16)
> jfkthame%gmail.com
> http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Beta/1314050969.
> 1314062162.14021.gz
> WINNT 6.1 x86-64 mozilla-beta build on 2011/08/22 15:09:29
> 
I enabled win64 on mozilla-beta by mistake. I will be fixing it.
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1314104742.1314116902.9282.gz

s: w64-ix-slave10
TEST-UNEXPECTED-FAIL | jit_test.py -a -m -j       | e:\builds\moz2_slave\fx-team-w64\build\js\src\jit-test\tests\jaeger\bug549393-1.js
TEST-UNEXPECTED-FAIL | jit_test.py -a -m -d       | e:\builds\moz2_slave\fx-team-w64\build\js\src\jit-test\tests\jaeger\strictModeSetUndefinedVar.js
make[1]: *** [check-jit-test] Error 2
make: *** [check] Error 2

Comment 19

6 years ago
See also a similar bug 658920.
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1314186149.1314198661.11900.gz

s: w64-ix-slave36
TEST-UNEXPECTED-FAIL | jit_test.py -m -j          | e:\builds\moz2_slave\fx-team-w64\build\js\src\jit-test\tests\jaeger\strictModeSetUndefinedVar.js
make[1]: *** [check-jit-test] Error 2
make: *** [check] Error 2
Comment hidden (Treeherder Robot)

Comment 22

6 years ago
dmandelin do you know who could help us fix this bug?
(Assignee)

Comment 23

6 years ago
All failured tests have "|jit-test|" entry to compare the exception.  When this occurs, python (jit-tests.py) doesn't get the any output by pipe() and communicate().

Armen, what python version do we use on builder?
(Assignee)

Comment 24

6 years ago
Created attachment 557124 [details] [diff] [review]
potential fix

Comment 25

6 years ago
(In reply to Makoto Kato from comment #23)
> Armen, what python version do we use on builder?

Python 2.6.5
(Assignee)

Updated

6 years ago
Attachment #557124 - Flags: review?(luke)
(Assignee)

Comment 26

6 years ago
Without python, I could reproduce this rarely using js.exe + cmd.exe only.  This seems to be output issue...  After fixing potential fix, there is no failure on my environment.

Updated

6 years ago
Attachment #557124 - Flags: review?(luke) → review+
(Assignee)

Comment 27

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/6d0812c1f610
Assignee: general → m_kato
Whiteboard: [orange][js-triage-needed] → [orange][js-triage-needed][inbound]
http://hg.mozilla.org/mozilla-central/rev/6d0812c1f610
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla9
Keywords: intermittent-failure
Whiteboard: [orange][js-triage-needed][inbound] → [js-triage-needed][inbound]
You need to log in before you can comment on or make changes to this bug.