The default bug view has changed. See this FAQ.

Search machine icon missing in address field

RESOLVED FIXED in seamonkey2.5

Status

SeaMonkey
Search
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: Glutton.Vidal, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
seamonkey2.5

SeaMonkey Tracking Flags

(seamonkey2.3 fixed, seamonkey2.4 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20110608 Firefox/4.0.1 SeaMonkey/2.1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20110608 Firefox/4.0.1 SeaMonkey/2.1

In older versions (e.g. 2.0.14) You can see the icon of the search machine ...
honestly I was used to click on the right search button ... as this was removed I needed a long time till I realized it after using 2.0.14 since a long time again, that I have to click below the address field.
This would be clear obvious with the icon(as seen in the modified screen shot)
http://img829.imageshack.us/img829/9250/searchmachine.jpg



Reproducible: Always

Steps to Reproduce:
1. Give in a search word
2.Click below the address field
3.
(Reporter)

Updated

6 years ago
Version: unspecified → SeaMonkey 2.1 Branch

Comment 1

6 years ago
Image Shack says I need to register to see that pic, but I think I know what you mean.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

6 years ago
Strange! I'm not registered there, and use it often for forums without access problems for others.

Comment 3

6 years ago
I live in a country that Image Shack doesn't like.

Comment 4

6 years ago
<RattyAway>
NeilAway: Bug 663919 is this intentional or an oversight on our part?
<NeilAway>
RattyAway: it's completely broken :-(
...

So can we fix it Bob?

Comment 5

6 years ago
Created attachment 539420 [details]
Picture for Ratty (not on imageshack.us)
(Assignee)

Comment 6

6 years ago
Created attachment 544976 [details] [diff] [review]
Proposed patch

addEngine used to take an icon string. The iconURI is an nsIURI, not a string, and it may be null, so I null-check it and use its spec if it exists.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #544976 - Flags: review?(iann_bugzilla)

Comment 7

6 years ago
Comment on attachment 544976 [details] [diff] [review]
Proposed patch

r=me and a=me for any repos that need it.
Attachment #544976 - Flags: review?(iann_bugzilla)
Attachment #544976 - Flags: review+
Attachment #544976 - Flags: approval-comm-beta+
Attachment #544976 - Flags: approval-comm-aurora+
(Assignee)

Comment 8

6 years ago
Pushed changeset 24b8803d73c0 to comm-central.

Transplant required for comm-aurora and comm-beta, so setting checkin-needed.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Version: SeaMonkey 2.1 Branch → Trunk

Comment 9

6 years ago
Pushed:
http://hg.mozilla.org/releases/comm-aurora/rev/4f6302029117
http://hg.mozilla.org/releases/comm-beta/rev/402abcbf2da0
Keywords: checkin-needed

Updated

6 years ago
Target Milestone: --- → seamonkey2.3

Updated

6 years ago
status-seamonkey2.3: --- → fixed
status-seamonkey2.4: --- → fixed
Target Milestone: seamonkey2.3 → seamonkey2.5

Updated

5 years ago
Duplicate of this bug: 87998

Updated

5 years ago
Duplicate of this bug: 236150
You need to log in before you can comment on or make changes to this bug.