Filter criteria line: regular expression.

RESOLVED DUPLICATE of bug 19442

Status

enhancement
RESOLVED DUPLICATE of bug 19442
19 years ago
9 months ago

People

(Reporter: netdragon, Unassigned)

Tracking

(Depends on 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Regular expressions can be placed in the normal criteria line, but there should 
also be another criteria condition format where you can enter just a regular 
expression.

Parents:
bug 19442
bug 59368
Depends on: 19442, 59368
QA Contact: esther → laurel
Status: UNCONFIRMED → NEW
Ever confirmed: true
reassigning to naving
Assignee: gayatrib → naving
mass re-assign.
Assignee: naving → sspitzer
*** Bug 244752 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Brian Bober, if you're still keeping up with Mozilla: I don't understand this bug.
Summary: [RFE] Filter criteria line: regular expression. → Filter criteria line: regular expression.
I guess, that the original poster referred to the fields available from the dropdown-fields, which are, in case of regular expressions, not strictly needed, if they are matched to the contents of a complete message.
BTW. If you did not understand the bug, how could you mark the other one as a duplicate. See there for an elaborate explanation. ;-)
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: laurel → filters
Product: Core → MailNews Core
aceman, I'm thinking to dupe this to bug  19442. Do you see a reason to keep this bug open?
I'd be OK. I am not sure what the difference to bug 19442 here is. Only warning against duping is that the original reported knew about bug 19442 but still filed this.

Can we ask him?
Flags: needinfo?(netdragon)
no bug comments from brian since 2008-01-31, so will be interesting if he responds
this is should be enough for GUI supporting regex
It has obviously been over 10 years since I filed this ticket, so if I recall correctly, I think Valerio's picture has captured the essence. I would recommend indicating in parenthesis what type of regex is used (Perl reg, etc)

In reply to monsterslayer from comment #5, partial words are not powerful enough. Regex are much more powerful. For instance, you can filter by a specific word followed by any number. 

If you get a high volume of emails, such as being a triager for Bugzilla :-) then this kind of powerful feature would be really useful for power users.
Flags: needinfo?(netdragon)
As for why this exists when bug #19442, it's too long ago to remember. I can only guess that #19442 was being treated as a meta bug at the time of the general feature, whereas this was a more specific details. I think the practice of meta bugs stopped back in 2004 or so.
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 19442
You need to log in before you can comment on or make changes to this bug.