Multiple formats for criteria lines in the filters' conditions box (not actions) [META]

RESOLVED INVALID

Status

MailNews Core
Filters
P3
enhancement
RESOLVED INVALID
18 years ago
7 years ago

People

(Reporter: Brian 'netdragon' Bober, Unassigned)

Tracking

(Blocks: 4 bugs, {meta})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Currently, filters can only check one set of criteria. A user should be able to 
select criterias from a list such as:

When Name appears in To box
When Someone appears in From box or from address book entry or list
Subject Contains
Message Contains
Subject and message contains
Written at specific time

Then enter the correct info as is done in the past.
(Reporter)

Updated

18 years ago
Blocks: 59339

Comment 1

18 years ago
Talked to Netdemon on IRC - the deal is there are specific types of criteria
which cannot be phrased in the form of
<Subject> <Verb> <object>

so he will file seperate, specific bugs about each of these types of criteria,
such as "To contains ONLY <email address>" and
"To is one of <these> entries from the addressbook"

I'm marking this one invalid as well, so that specific bugs get filed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

18 years ago
Alecf came up with the idea to have a drop down arrow next to the beginning of 
the criterial lines in order to choose from different format of criteria.

This will be a tracking bug for examples that don't fit into that subject verb 
category. Before the first example is added, it will be necessary to create the 
UI ability of the drop down arrow for choosing different formats.
(Reporter)

Comment 3

18 years ago
When someone clicks the drop down arrow on the left side of line, a drop down 
box would appear (or a window) where one can choose from the formats. When one 
chooses a format, one can enter the info. The default format would be the one 
currently used.
Summary: Filters should have a conditions (criteria) section → Multiple formats for criteria lines in the filters' conditions box (not actions)

Updated

18 years ago
QA Contact: esther → laurel

Comment 4

18 years ago
Marking verified (invalid).
Status: RESOLVED → VERIFIED
(Reporter)

Updated

18 years ago
Blocks: 66423
(Reporter)

Comment 6

18 years ago
Ok, lets get this going...

Please comment on these:

http://bugzilla.mozilla.org/show_bug.cgi?id=19442 - Regular expressions should 
be a possible condition format that isn't in the [noun][verb][text] format. It 
should just be in the [regular expression] format (although regular expressions 
could also be placed in the other text fields too for the old format. I am 
going to make a new one that depends on both this bug and the other one.



http://bugzilla.mozilla.org/show_bug.cgi?id=16750 -  I think this can be done 
in the normal format.

http://bugzilla.mozilla.org/show_bug.cgi?id=19402 - Same

http://bugzilla.mozilla.org/show_bug.cgi?id=37654 - Although this goes under 
actions to. I think it depends on this bug since it would require a new format.

http://bugzilla.mozilla.org/show_bug.cgi?id=60876 - This would be in 
format "Duplicate messages of [button: select messages]". Since I think it 
would be dangerous to just search for duplicates.

http://bugzilla.mozilla.org/show_bug.cgi?id=62598 - I believe this couldn't be 
in the old format because it would require a button to select the languages 
(for ease of use). The languages don't actually have to be installed. Tell me 
if I'm wrong.

http://bugzilla.mozilla.org/show_bug.cgi?id=62687 - I think that the third 
option (not in the address book) would require a new format.

http://bugzilla.mozilla.org/show_bug.cgi?id=33296 - Ratings can be entered in 
the text box, so no.

http://bugzilla.mozilla.org/show_bug.cgi?id=34340 - I believe 62687 is similiar 
and possibly a dup.







In fact all the ones that require a button as a third option can be placed in 
the same format.



Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 7

18 years ago
Alecf should probably look at this.
(Reporter)

Updated

18 years ago
Blocks: 66425

Comment 8

18 years ago
I have changed positions and I no longer work in mail or on filters, sorry.

Comment 9

18 years ago
reassiging to new owners
Assignee: alecf → gayatrib
QA Contact: laurel → esther

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: esther → laurel

Comment 10

17 years ago
reassigning to naving
Assignee: gayatrib → naving

Comment 11

16 years ago
Today, spam filtering is on its way, so I shall give another reason why regexp
are useful :
more & more mail servers allow using added strings, for instance if I have a
mail address xandrex@polytechnique.org , I can be also written to
xandrex_foo@polytechnique.org or xandrex+bar@polytechnique.org . This is in RFCs.
So I would like to be able to filter on xandrex.*@polytechnique\.org .

=> it requires a checkbox "use regexp" ou "use plain text", like the difference
between grep and egrep .
of course, the default would be search for plain text (egrep).

Comment 12

16 years ago
In comment 11, last line should read:

> of course, the default would be search for plain text (grep).

instead of

> of course, the default would be search for plain text (egrep).

I think you just fat-fingered it :)
mass re-assign.
Assignee: naving → sspitzer
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Comment 15

11 years ago
Filters have come a long way. Are these the only items from comment 0 that are not yet available?

> Written at specific time
> When Name appears in To box


QA Contact: laurel → filters

Comment 16

11 years ago
I doubt the world will miss one more outdated, apparently abandoned meta bug
-> INVALID
Status: NEW → RESOLVED
Last Resolved: 18 years ago11 years ago
Keywords: meta
Resolution: --- → INVALID
Summary: Multiple formats for criteria lines in the filters' conditions box (not actions) → Multiple formats for criteria lines in the filters' conditions box (not actions) [META]
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
Depends on: 720673
No longer depends on: 720673
You need to log in before you can comment on or make changes to this bug.