Last Comment Bug 664492 - Intermittent TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | Tab View is visible again
: Intermittent TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/brows...
Status: VERIFIED FIXED
: intermittent-failure
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All Linux
: -- normal
: Firefox 7
Assigned To: Matt Brubeck (:mbrubeck)
:
:
Mentors:
Depends on:
Blocks: 438871 633190 663614
  Show dependency treegraph
 
Reported: 2011-06-15 10:34 PDT by Matt Brubeck (:mbrubeck)
Modified: 2016-04-12 14:00 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Matt Brubeck (:mbrubeck) 2011-06-15 10:34:10 PDT
This first appeared on the backout of bug 661091 (which also caused other new test failures), so we thought it was caused by that change.  But it is still appearing after bug 661091 re-landed.  Perhaps this was caused by bug 633190 or bug 663614, which landed a little earlier.

http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308157207.1308158493.2016.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/06/15 10:00:07 

http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308146026.1308147155.17052.gz
Rev3 Fedora 12x64 mozilla-inbound opt test mochitest-other on 2011/06/15 06:53:46 

INFO TEST-END | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_orphaned_tabs.js | finished in 905ms
TEST-INFO | checking window state
TEST-INFO | before wait for focus -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XrayWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object XrayWrapper [object Window]]) about:blank docshell visible: true
TEST-INFO | already focused
TEST-INFO | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XrayWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object XrayWrapper [object Window]]) about:blank docshell visible: true
TEST-START | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | Tab View is visible
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | we start with one tab
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | we start with 1 group
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | the tab is in the group
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | we start with private browsing off
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | we now have two groups
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | we now have 2 tabs
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 0: private browsing is off
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 0: we have 2 tabs
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 0: we have 2 groups
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 0: same number of tabs as groups
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 0: correct URL
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 0: correct group title
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 0: tab 0 is in group 0
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 0: correct URL
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 0: correct group title
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 0: tab 1 is in group 1
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | Tab View is no longer visible
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | private browsing is on
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | we have 1 tab in private browsing
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | we have 1 group in private browsing
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | the tab is in the group
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | correct URL for private browsing
TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | Console message:
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | Tab View is visible again
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 1: private browsing is off
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 1: we have 2 tabs
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 1: we have 2 groups
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 1: same number of tabs as groups
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 1: correct URL
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 1: correct group title
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 1: tab 0 is in group 0
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 1: correct URL
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 1: correct group title
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 1: tab 1 is in group 1
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | Tab View is not visible
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | Tab View is still not visible
Comment 1 Treeherder Robot 2011-06-15 11:00:22 PDT
mbrubeck%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308158897.1308160408.9554.gz
Rev3 Fedora 12x64 mozilla-inbound opt test mochitest-other on 2011/06/15 10:28:17

s: talos-r3-fed64-044
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | Tab View is visible again
Comment 2 Treeherder Robot 2011-06-15 11:01:12 PDT
mbrubeck%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308158938.1308160257.8876.gz
Rev3 Fedora 12x64 mozilla-inbound opt test mochitest-other on 2011/06/15 10:28:58

s: talos-r3-fed64-046
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | Tab View is visible again
Comment 3 Matt Brubeck (:mbrubeck) 2011-06-15 11:03:05 PDT
Comment 2 is from a re-run on this push, which was originally green:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=623b1da3c382

So it looks likely that the culprit is indeed bug 633190 or bug 663614.
Comment 4 Raymond Lee [:raymondlee] 2011-06-15 11:38:00 PDT
It is very likely caused by bug 633190.
Comment 5 Matt Brubeck (:mbrubeck) 2011-06-15 12:23:30 PDT
Backed out bug 633190:
http://hg.mozilla.org/integration/mozilla-inbound/rev/4f59f296bc30
Comment 6 Mounir Lamouri (:mounir) 2011-06-16 05:29:37 PDT
Backout merged to m-c:
http://hg.mozilla.org/mozilla-central/rev/4f59f296bc30
Comment 7 Treeherder Robot 2011-06-30 20:36:30 PDT
jdm
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1309483314.1309484842.26193.gz
Rev3 WINNT 5.1 mozilla-aurora opt test mochitest-other on 2011/06/30 18:21:54

s: talos-r3-xp-059
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 2: we have 2 groups - Got 1, expected 2
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 2: same number of tabs as groups
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | verify normal 2: tab 0 is in group 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_privatebrowsing.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_248970_a.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_248970_a.js | Found a tab after previous test timed out: http://example.org/
Comment 8 Virgil Dicu [:virgil] [QA] 2011-08-31 02:36:04 PDT
Verified fixed based on passed results in:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1314760632.1314761843.20879.gz&fulltext=1

Note You need to log in before you can comment on or make changes to this bug.