New Thunderbird instance/window created when opening Add-ons Manager from preferences manager. Only one displayed in the taskbar.

RESOLVED INVALID

Status

RESOLVED INVALID
8 years ago
6 years ago

People

(Reporter: KenSaunders, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:7.0a1) Gecko/20110620 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:5.0) Gecko/20110528 Thunderbird/5.0b1

This was my initial perception as a user but not the correct issue.
Options window is hidden (doesn't close) after opening Add-ons Manger from Options. Options cannot be opened afterwards.

Apparently what is happening is another instance of Thunderbird or new window is created but only a single instance shows in the taskbar when doing the following.
Tools > Options > General > Add-ons > Change options for your add-ons > Manage Add-ons... (button)
After the Add-ons Manager opens, Go to Tools > Options (Options window will not appear until the close button on the title bar is clicked)

Well the preferences manager appears after I click the close button in the title bar because the new window, or instance was simply in front of the original one, but again, only one shows in the taskbar.

This issue also occurs in 5.0b2pre.

Reproducible: Always

Steps to Reproduce:
1. Go to Tools > Options > General > Add-ons > Change options for your add-ons > Manage Add-ons... (button)
After the Add-ons Manager opens, Go to Tools > Options


Actual Results:  
New instance/window is created but only one shows in the Windows taskbar

Expected Results:  
The preferences manager should close and the Add-ons Manager should open in a new tab or take focus if it is already loaded in a tab .

Clean install/profile
(Reporter)

Comment 1

8 years ago
Created attachment 540610 [details]
5.0b1-error-console
suspect this is a simple matter that Options is a modal dialog, which also makes it likely this is a duplicate, or dependent on some other modal dialog bug.  

behavior is not good. however this is not major: a) it's easily avoided/corrected, and b) it doesn't break basic functionality of the features involved. see https://bugzilla.mozilla.org/page.cgi?id=fields.html#bug_severity
Severity: major → minor
Probably the ideal solution is to make the options dialog non-modal, since I can't think of a good reason for it to be that way. It's certainly not modal on Linux, so I'm sure Thunderbird already handles everything correctly. If we did that, we could just switch to the most recent 3pane when people click that button.
Alternately, just get rid of that button because really, how many ways do we need to be able to get at the add-ons tab?
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> Alternately, just get rid of that button because really, how many ways do we
> need to be able to get at the add-ons tab?

+1

(In reply to comment #2)
see
> https://bugzilla.mozilla.org/page.cgi?id=fields.html#bug_severity

Thank you. Now I know. Always willing to learn.
Firefox suffers the same problem ...  Bug 661126 - Manage Add-ons/Options on Firefox/Thunderbird

(In reply to comment #4)
> Alternately, just get rid of that button because really, how many ways do we
> need to be able to get at the add-ons tab?

Except that Thunderbird got this model from firefox. And I don't find any bug that indicates firefox intends to remove it. (but that's not to say it wouldn't be a good idea)
 https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&list_id=544397&short_desc=options%20&field0-0-0=short_desc&short_desc_type=allwordssubstr&type0-0-0=anywordssubstr&value0-0-0=addon%20add-on&resolution=---&resolution=WONTFIX&product=Core&product=Firefox

Comment 7

8 years ago
When getting Add-ons Manager via [Tools > Options > General > Manage Add-ons], what I see is a new window within the same instance of TBird.  There is no new button on my Windows XP taskbar.  If I minimize it, it goes to the TBird status bar, not to the Windows XP taskbar.

I see this as a problem.  From the menu bar, selecting [Tools > Options > General > Manage Add-ons] hides the existing window to the extent a user might think it was closed.  There is no indication that the user now has two windows.  The Add-ons Manager still appears in a tab; but if I close that tab, I have the new window and not the original one.  I don't even see the Options window, which remains a child of the original window.  

There are two ways to resolve this:  

1.  [Tools > Options > General > Manage Add-ons] should operated exactly the same as [Tools > Add-ons] does now, launching a new tab in the current Thunderbird window.  

2.  Either way of reaching the Add-ons Manager should launch a new window that is ONLY the Add-ons Manager -- no tab, no account pane -- the way Thunderbird 3.1.11 worked.  When the Add-ons Manager is dismissed, the Thunderbird window from which Add-ons Manager was launched is seen.  

In any case, the two ways that a user can launch the Add-ons Manager should give the same result.  Not doing this is confusing to the user.
Dupe of bug 565686?

Comment 9

8 years ago
Re comment #8:  

This is a duplicate of bug #565686 ONLY if the problem described here is an artifact of that other bug.  However, I suspect this bug is an artifact of how Thunderbird implemented its use of the Add-ons Manager and is thus a distinct bug.  

My suspicion is based on the fact that I do not get this problem when using [Tools > Add-ons] to launch the Add-ons Manager.  The problem appears only when using [Tools > Options > General > Manage Add-ons].
(In reply to comment #9)
> This is a duplicate of bug #565686 ONLY if the problem described here is an
> artifact of that other bug.  However, I suspect this bug is an artifact of
> how Thunderbird implemented its use of the Add-ons Manager and is thus a
> distinct bug.  

If you read that bug you'll note that it's exactly the same as this one, only for Firefox. That said, it's not a dupe because Thunderbird and Firefox have different code paths to do the same thing, and I doubt that toolkit devs are going to come fix Thunderbird issues.
(In reply to comment #10)
> If you read that bug you'll note that it's exactly the same as this one,
> only for Firefox. 

Actually, bug 565686 is a toolkit bug.
(In reply to comment #11)
> (In reply to comment #10)
> > If you read that bug you'll note that it's exactly the same as this one,
> > only for Firefox. 
> 
> Actually, bug 565686 is a toolkit bug.

I'm pretty sure it's miscategorized, since the issue has to do with the Options dialog being modal on Windows, which is a Firefox bug, not a Toolkit bug. We can wait and see what happens with that bug, but based on the comments, it seems very likely that they'll be fixing it in Firefox-only code, which means Thunderbird won't benefit from the changes (but we can just follow in their footsteps).

Comment 13

7 years ago
Hello, I'm part of the official Italian Firefox support team, and one user reported this problem on our support forum.

The problem seems always verified with Thunderbird - I'm using Mozilla/5.0 (X11; Linux i686; rv:6.0.2) Gecko/20110902 Thunderbird/6.0.2, but also in Mac and Windows - and moreover it seems to happen even in Firefox. 

So this bug should be confirmed and addressed differently.
Thanks.
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
As patch for bug 513164 landed on both Firefox and Thunderbird, maybe this bug need to be closed, doesn't it?
(In reply to Javi Rueda from comment #14)
> As patch for bug 513164 landed on both Firefox and Thunderbird, maybe this
> bug need to be closed, doesn't it?

Indeed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.