Bug 666944 (NikBull)

Seamonkey 2.1 has multiple table editing issues in normal view - had to rollback to 2.0.6

RESOLVED DUPLICATE of bug 664095

Status

SeaMonkey
Composer
RESOLVED DUPLICATE of bug 664095
7 years ago
7 years ago

People

(Reporter: Nik Bull, Unassigned)

Tracking

SeaMonkey 2.1 Branch
seamonkey2.4
Bug Flags:
in-testsuite -

SeaMonkey Tracking Flags

(seamonkey2.1 wontfix, seamonkey2.2 wontfix, seamonkey2.3 wontfix, seamonkey2.4 fixed)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.100 Safari/534.30
Build Identifier: 2.1

ALL ERRORS IN NORMAL VIEW:  When clicking on an image within a cell a duplicate of the image appears next to it, temporarily wrecking the layout making it impossible to work with.  When editing tables the arrows to add & remove rows & columns no longer appears, yet the function is still available through the drop-menu.  When highlighting cells & right clicking the Table Cell Options is greyed out, yet again this is still possible through the drop-menu.  There can be no purpose in removing these functions if they are still in the drop-menu & it would be impossible to edit tables without them.  A problem with 2.06 that I forgot to check before rolling back - when you select a table the eight re-size tabs appear at the top of the page instead of on the table making re-sizing very difficult. I realise tables are going out of fashion but as an amateur I use them a lot.

Reproducible: Always

Steps to Reproduce:
ALL IN NORMAL VIEW
1.create a table
2.insert images & text
3.try clicking on image
4.try re-sizing the table 
5.try highlighting a row, right click, then table cell properties
6.try selecting a row or column then add or remove with the non-existent arrows 

Actual Results:  
See details entry

Expected Results:  
See details entry

this forced me to roll back to 2.06 & if I find it unusable then many other people will too.
(Reporter)

Updated

7 years ago
Version: unspecified → SeaMonkey 2.1 Branch
(Reporter)

Updated

7 years ago
Alias: NikBull
Summary: Seamonkey 2.1 has multiple issues - had to rollback to 2.0.6 → Seamonkey 2.1 has multiple table editing issues in normal view - had to rollback to 2.0.6
You mean you see this in the Composer, don't you (i.e. for instance after a "step zero" which would be "Window → Composer")?

Oh, and BTW, if you nicknamed your first bug by your own name, how are you going to nickname your next bug? Usually aliases are assigned by developers to bugs which are hard to fix, have many blockers and/or dependents, and need to be easily found by many people; and as a rule, a more descriptive alias is used (more descriptive _of the bug_, I mean) than the name of the reporter.
tony: "(New to Bugzilla)" is a feature from a new bugzilla version, there is also a similar "first patch" :-)
(Reporter)

Comment 3

7 years ago
Sorry guys, I don't understand either of your comments.  I'm really only an amateur user & this seemed the best place to flag the problems I was having.  This problem is in the composer, I tend to do most work in the 'Normal' tab view then add any tricky html stuff in the 'Source' view afterwards.  These problems in the 'normal' view have made it unusable.  

I didn't realise the nickname was for the bug I thought it was for the user.  At least I can find it, the search feature on this site isn't too great.
In reply to comment #3:

Comment #2 was a reaction to my comment #1, it isn't a problem if you don't understand it. It is even a little beside the point.

The first paragraph of my comment #1, however, was a question to you, which you haven't yet answered, so let me rephrase it differently:

You are talking about "the Normal view", "the Normal tab view", and my question is: the Normal view of what? The most used windows in SeaMonkey are the Browser window and the Mailer window, but they don't have a specific "Normal view". Maybe you are talking about something in the Composer window, with which I personally am little acquainted because I never use it. If that is the case, then this bug belongs in the "Composer" Component rather that the "General" Component. I can move it there, but first I want to be sure that that's what you're talking about.
(Reporter)

Comment 5

7 years ago
Yes this is on the composer.
Component: General → Composer
QA Contact: general → composer

Comment 6

7 years ago
Could you try doing this in a mail compose window too and see if it happens there?
(Reporter)

Comment 7

7 years ago
I only use the composer & have never used any of the other features. I have rolled back to 2.0.6 as the composer is so much better. 

There's another problem with the newer versions, when you cut & paste items with a link the newer composers lose the link whereas in 2.0.6 the link is retained.  I'm not sure whether that feature was removed on purpose but I much prefer the link to be retained.

Think I'm gonna have to stick with 2.0.6 as the composer element seems to be either wrecked or forgotten on the later versions.

Updated

7 years ago
Duplicate of this bug: 670494

Updated

7 years ago
Duplicate of this bug: 670123

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All

Updated

7 years ago
Duplicate of this bug: 674906

Comment 11

7 years ago
As far as I can see all the issues here were caused by a core Gecko bug that was fixed in bug 664095 (and will be available in SM2.4). If you do find any further issues could you log a separate bug for each one. Thanks.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
status-seamonkey2.1: --- → wontfix
status-seamonkey2.2: --- → wontfix
status-seamonkey2.3: --- → wontfix
status-seamonkey2.4: --- → fixed
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.4

Updated

7 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 664095
You need to log in before you can comment on or make changes to this bug.