Use Malgun Gothic instead of Gulim in Windows

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
8 years ago
Last year

People

(Reporter: joone.hur, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Reporter

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: 

Firefox has used Gulim font by default to render Korean, but many Korean web sites don't use Gulim anymore because Gulim is old fashioned font.

I suggest that we should set Malgun Gothic for the default font of Firefox instead of Gulim in Windows Vista/7, which is the default system font in Windows Vista/7.

I think Malgun Gothic is so beautiful font to represent the beauty of Korean font. Many Korean people also prefer to use it.


Reproducible: Always

Steps to Reproduce:
1. Open http://twitter.com/?lang=ko
2. Do you think the Korean font is beatiful?
3.

Actual Results:  
Korean is rendered by Gulim font

Expected Results:  
I hope to see Korean rendered by Malgun Gothic.

Articles about the problems of Gulim Font (written in Korean)
http://euirae.egloos.com/2945632
http://www.donga.com/fbin/output?n=200904180201
http://www.wikitree.co.kr/main/news_view.php?id=32747
http://jumpkarma-textcube.blogspot.com/2009/01/%ED%95%9C%EA%B8%80%ED%8F%B0%ED%8A%B8-%EA%B5%B4%EB%A6%BC%EC%B2%B4%EA%B0%80-%EC%9D%BC%EB%B3%B8%EC%84%9C%EC%B2%B4.html

Comment 1

8 years ago
Joone: I think this is a good idea but before we make any decision, is there a way we can ask the Mozilla Korea community members their opinion?

Maybe do a poll or survey with screenshots of both fonts to gather feedback?

We certainly want to provide the best font for Korean users but we also want to make sure that we are making the right change. Getting feedback from users will be important to push such a change.
How about WinXP? We cannot switch default font per OS version. And how about the compatibility with non-font specified pages? I think that we shouldn't change the default fonts.

Comment 3

8 years ago
Well if Win7 is much higher than WinXP in Korea, then we should consider the change.

Is there any statistics on Windows OS version in Korea?
"higher" isn't enough reason. Even if we do it in the future, we should do it after we drop the WinXP support.
And what's the default font of IE? We shouldn't use different fonts for default fonts from IE.
FYI. According to the recent report by Internet Trends, the ratio of Window XP is 50% in Korea. This estimation is similar with our company's stat. (the #2 largest Internet portal.)
Reporter

Comment 7

8 years ago
You can find the difference between Gulim and Malgun Gothic font.
According to comment 6, we cannot ignore WinXP.

-> INVA
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
Reporter

Comment 9

8 years ago
(In reply to comment #8)
> According to comment 6, we cannot ignore WinXP.
> 
> -> INVA

Most WinXP users already installed Malgun Gothic font because MS Office 2007 or higher version installs Malgun Gothic by default. If there is no Malgun Gothic in the user's WinXP, Gulim still can be used for the default font of Firefox.

It seems not hard to change the default font of Firefox according to the OS version.
Reporter

Comment 10

8 years ago
Even IE uses Malgun Gothir for its new tab page(about:tabs) in Windows7, but Firefox still uses Gulim for about:home page.
(In reply to comment #10)
> Created attachment 542103 [details]
> IE8 on Win7 uses Malgun Gothic for the internal pages
> 
> Even IE uses Malgun Gothir for its new tab page(about:tabs) in Windows7, but
> Firefox still uses Gulim for about:home page.

IE8's default font is still Gulim in Window 7. You can see MalgunGothic in about:tabs of IE8 because CSS is defined in that page. As you know, web sites choose fonts in their CSS setting. I'm not sure that default font is important to users. 

If you want to switch default font on mozilla.com or about:home etc, we can file another bug in mozilla.com.
Reporter

Comment 12

8 years ago
In the case that web sites don't specify the default font, we need to choose Malgun Gothic instead of Gulim.  I believe that it would make the web more beautiful on Windows platform. 

We should consider why Korean people still change the default font in their browser when they install Windows. Firefox should move ahead of IE.
(In reply to comment #12)
> In the case that web sites don't specify the default font, we need to choose
> Malgun Gothic instead of Gulim.  I believe that it would make the web more
> beautiful on Windows platform. 

Even if so, it cannot be a reason to change our default font. Our default font settings are very important for the compatibility of non-font-specified pages' rendering between browsers.

> We should consider why Korean people still change the default font in their
> browser when they install Windows. Firefox should move ahead of IE.

No, Microsoft believes that the compatibility is very important. And I agree with them.

If most Korean people thought same as you think, i.e., the Hangul characters should be displayed nicer on Windows, most Korean web designers would specify Malgun Gothic for font-family and Firefox users who can change options themselves would change their default font settings.
(In reply to comment #12)
> In the case that web sites don't specify the default font, we need to choose
> Malgun Gothic instead of Gulim.  I believe that it would make the web more
> beautiful on Windows platform. 

Have you considered the interaction with font smoothing settings in XP? Which font is preferable for users who have not enabled ClearType, but only grayscale smoothing - or no font smoothing at all?
(In reply to comment #12)
> In the case that web sites don't specify the default font, we need to choose
> Malgun Gothic instead of Gulim.  I believe that it would make the web more
> beautiful on Windows platform. 
I quickly surveyed setting of default font of Korean top 20 websites according to http://koreanclick.com/information/freedata_rankings.php

I found as following results of body font-family setting:
1. Naver.com: "굴림",Gulim,"돋움",Dotum,AppleGothic,Sans-serif
2. Daum.net: "새굴림","굴림",gulim,sans-serif;
3. Nate.com: "돋움",Dotum,Arial,sans-serif
4. Cyworld.com: "돋움",Dotum,Arial,sans-serif
5. Tistory.com: dotum,Verdana
6. Chosun.com: "굴림","Gulim","돋움","Dotum","AppleGothic","Sans-serif"
7. joinsMSN.com: "굴림",Gulim,AppleGothic,Arial,Helvetica,Clean,Sans-serif;
8. mk.co.kr: 돋움,Dotum,AppleGothic,sans-serif
9. hankyung.com: "굴림",Gulim,"돋움",Dotum,Verdana,Arial,AppleGothic,sans-serif
10. gmarket.co.kr: "돋움",Dotum,Tahoma,Arial

There is no web sites setting up malgun gothic for windows visita/7 users. I means that most of Korean web designers believe gulim is more readable than malgun gothic, cleartype. 

p.s. I don't have any opinion for this issue because choosing font is personal preference.
Reporter

Comment 16

8 years ago
We should think why Microsoft changed the default Korean system font to Malgun Gothic when they released Windows Vista and even if we install the latest MS Office on WinXP, MS office uses Malgun Gothic.

In the future, the time would come when the browsers would have to take Malgun Gothic or whatever as the default web font on Windows platform. Therefore, I just suggest that Firefox would move fist.

Thanks for your opinions.

Comment 17

8 years ago
(In reply of comment #2)

Yes it's not easy switching default font per OS, but if we use browser CSS, it's not a big deal to make use Gulim instead of Malgun Gothic when Malgun Gothic is not available.

As Channy wrote in comment #15, yes so many(almost) Korean portal sites uses Gulim as a default font but that's because Gulim also has bitmap font inside which is optimal for a small size characters (As I remember, for 9~12px) not because Gulim is a good font.

Korean designer uses image instead text on big size text (as written above) rendered text using Gulim is not good looking.

So I suggest as Joone, to change default Korean font to Malgun Gothic. As you know if we set font setting with CSS as '* { font-family: "맑은 고딕", "Malgun Gothic", "굴림", Gulim, ...; } then when there's no Malgun Gothic, then Gulim will be used so there will not be a problem if there not installed Malgun Gothic.
Reporter

Comment 18

3 years ago
5 years passed since I suggested to change Gulim font with Malgun Gothic.
I think we can now change the default UI font.
Reporter

Updated

3 years ago
Summary: Use Malgun Gothic instead of Gulim in Windows Vista/7 → Use Malgun Gothic instead of Gulim in Windows
Reporter

Updated

2 years ago
Depends on: 1407869
Depends on: 1431570
You need to log in before you can comment on or make changes to this bug.