Use Malgun Gothic as default on Korean on Nightly

RESOLVED FIXED in Firefox 58

Status

()

enhancement
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: m_kato, Assigned: m_kato)

Tracking

(Blocks 1 bug)

Trunk
mozilla58
Unspecified
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox58 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

2 years ago
Bug 667364 is closed as invalid, but Windows 7+ default is Malgun Gothic, and Gulim is removed from non-Korean Windows as defualt.

So we should use Malgun Gothic instead of Gulim.  (At first, we changes it on Nightly only for feedback)
Assignee

Comment 1

2 years ago
Hi, Hyeonseok.   I would like to change default font for Korean since Malgun Gothic is default font of Windows.  How do you think?
Flags: needinfo?(hyeonseok)

Comment 2

2 years ago
The time has come! I think it should be a Malgun Gothic. I will ask to the community about the change after being applied to Firefox Nightly.

Updated

2 years ago
Flags: needinfo?(hyeonseok)
Assignee

Comment 4

2 years ago
Windows Vista or later changes Korean default font to Malgun Gothic.  Windows 10 removes Gulim font on non-Korean Windows, and Gulim becomes an additional font for Korean language pack.  So we should change Firefox's default font to Malgun Gothic.

Also, this change is for Nightly only for feedback.  If this changes is no big issue, I will change it on release channel.
Attachment #8919669 - Flags: review?(jfkthame)
Attachment #8919669 - Flags: review?(jfkthame) → review+

Updated

2 years ago
Blocks: 667364

Comment 5

2 years ago
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d10766b6ea60
Use Malgun Gothic as default on Korean on Nightly r=jfkthame
https://hg.mozilla.org/mozilla-central/rev/d10766b6ea60
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Duplicate of this bug: 1430595
Assignee

Updated

a year ago
Blocks: 1431570
You need to log in before you can comment on or make changes to this bug.