Closed Bug 667456 Opened 11 years ago Closed 2 years ago

[meta] [10.7] Update Firefox Theme for Mac OS X 10.7 Lion

Categories

(Firefox :: Theme, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: Dominic.Spitaler, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: meta)

Attachments

(1 file)

The release of OS X Lion is nearing and running Firefox on it works well, but it’s default theme hasn’t been updated yet to incorporate all the visual loveliness introduced in this OS update. 

So this bug is for tracking all the theme changes that are necessary to feel native again. Above you’ll find a mockup, showing what I think is necessary to be done.
Depends on: 667476
Depends on: 667480
No longer depends on: 667480
Summary: Update Firefox Theme for Mac OS X 10.7 Lion → [10.7] Update Firefox Theme for Mac OS X 10.7 Lion
Depends on: 667480
Keywords: meta
Status: UNCONFIRMED → NEW
Ever confirmed: true
Awesome, thanks for doing this!

(I haven't done any work on this yet because I don't have access to a Lion preview and because I'm short on time currently anyways.)
(In reply to comment #0)
> Above you’ll find a mockup, showing what I think is necessary
> to be done.

You nice mockup also shows the fullscreen arrows in the right upper edge, which is necessary for a 10.7 look, but doesn't mention it. Is this Bug 639705 or does Bug 639705 only implement the support and the UI thing needs to be done in another bug?
(In reply to comment #2)
Bug 639705 will also add the fullscreen arrows. They're provided automatically.
Don't we want to keep the round Back button on Lion? It's a distinctive part of the UI branding that distinguishes Firefox from Safari at a glance.
The mockup shows small-icons mode.
Depends on: 677613
The mockups are shown with the bookmarks-bar disabled. Is there any change wanted on it for Lion? Smoother/lighter folder icons? Or no changes at all, perhaps?
Looks amazing!
Looking good, but take a look at the split buttons in Lion. The divider no longer spans the height of the button, but instead stops several pixels short on either end (screenshot: http://cl.ly/0J1c3P3Z1U0N200i1V2r).
Jackson: That's how we implemented split buttons on Lion. The only exception that has a connecting separator is the keyhole-style back/forward button.
Depends on: 681425
Depends on: 689012
Depends on: 766106
Bug 690910 and Bug 766106 (and maybe Bug 688678) are probably obsolete with Australis, can you please WONTFIX them?
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Summary: [10.7] Update Firefox Theme for Mac OS X 10.7 Lion → [meta] [10.7] Update Firefox Theme for Mac OS X 10.7 Lion
You need to log in before you can comment on or make changes to this bug.