Implement .postMessage for multiple content processes

RESOLVED DUPLICATE of bug 1204775

Status

()

RESOLVED DUPLICATE of bug 1204775
7 years ago
3 months ago

People

(Reporter: benjamin, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
.postMessage will need a broadcast mechanic to work across multiple content processes

Updated

7 years ago
Duplicate of this bug: 667488
postMessage targets a particular window, no?  And it's a window you have a reference to.  So it's generally in the same process as you already (modulo the bit about setting openers to null), or am I misunderstanding the setup?
This is about window.postMessage and not sharedWorker.postMessage?
Since the latter one could need cross-process messaging, I think.
Yeah, I think the only postMessage() method that needs e10s love is the one on shared workers, which we don't implement yet.
Blocks: 1207306
Flags: needinfo?(gkrizsanits)
(In reply to Johnny Stenback  (:jst, jst@mozilla.com) from comment #4)
> Yeah, I think the only postMessage() method that needs e10s love is the one
> on shared workers, which we don't implement yet.

I think for shared workers first we need to figure out how to share them between multiple content processes. Any other approach would probably be a spec violation and a hack. I think making sure that worker.port.postMessage does what it supposed to do should be part of that work. Ben, is someone working on that / is there a bug filed for that?
Flags: needinfo?(gkrizsanits) → needinfo?(bkelly)
Not directly, but a lot of the infrastructure we need for service worker will make doing this for SharedWorker easier.  Marking the appropriate bugs as dependencies.
Depends on: 1231213, 1231216, 123171
Flags: needinfo?(bkelly)
No longer depends on: 123171
worker.port.postMessage for SharedWorker is already multi-e10s compatible.
Internally SharedWorker ports are MessagePort.
If this bug is just about SharedWorker.port.postMessage, it's already fixed by bug 1204775.
Flags: needinfo?(gkrizsanits)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1204775
Flags: needinfo?(gkrizsanits)
You need to log in before you can comment on or make changes to this bug.