Closed Bug 66771 Opened 20 years ago Closed 15 years ago

No method for filtering all email from account to specific mailbox

Categories

(MailNews Core :: Filters, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: gjerde, Assigned: Bienvenu)

References

Details

(Keywords: fixed1.8.1)

Attachments

(3 files, 1 obsolete file)

Ie, Sending all email from a specific account to a folder.
Seth Spitzer suggested that currently you can filter on just @, but there really
should be a more specific filter for this purpose.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
reassigning to naving
Assignee: gayatrib → naving
You mean all mail _for_ an account, right? I don't think we need a special
"always" criteria - you can just leave the filter as it is by default: Subject
contains "" (empty string). Or does that not work? I suggest WONTFIXing this.

Or did I misunderstand?
OS: Linux → All
Hardware: PC → All
mass re-assign.
Assignee: naving → sspitzer
*** Bug 208531 has been marked as a duplicate of this bug. ***
re: comment 2: no, [Subject contains ""] does not work.
I've seen this issue requested a few times in the newsgroups, too.
Product: MailNews → Core
*** Bug 262185 has been marked as a duplicate of this bug. ***
I confirm/vote. I think this might be important in combination with the upcoming
Autoreply, forward and Bounce filter actions.
(https://bugzilla.mozilla.org/show_bug.cgi?id=11034)
This request is a bit late, sorry for that.
Flags: blocking-aviary1.1?
Assignee: sspitzer → nobody
Flags: blocking-aviary1.1? → blocking-aviary1.1-
QA Contact: laurel
Attached patch proposed fix (obsolete) — Splinter Review
I think this will also be useful for things like creating virtual folders that are the union of several folders, w/o any search criteria. This is a work in progress - it just occurred to me that it's all wrong, in the sense that I need to change search terms to allow for an ALL criteria, instead of making it a property on the filter.
Assignee: nobody → bienvenu
Status: NEW → ASSIGNED
Attached patch proposed fixSplinter Review
this adds a match all item for the filter editor, and the virtual folder search terms (but not for views or standard search, where it's not so meaningful).
Attachment #223385 - Attachment is obsolete: true
Attachment #223796 - Flags: superreview?(mscott)
Comment on attachment 223796 [details] [diff] [review]
proposed fix

I think there are some dump statements in the patch we can get rid of.

This should be really useful!
Attachment #223796 - Flags: superreview?(mscott) → superreview+
fixed on trunk. I've also checked in the equivalent seamonkey changes so that seamonkey won't be broken.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
fixed on 1.8 branch
Keywords: fixed1.8.1
1) in 1.8_Branch the searchTermOverlay.dtd patch isn't checked in (forgotten)

2) the filter editor is broken:

2.1 Everytimes you select "Match all messages" and switch back to "Match all/any of the following">, a new rules line will be listed. This rules line seems to be empty and nothing can be selected in the dropdowns.

2.2 Clicking "-" to delete the empty rules line deletes ANOTHER (the above) rules line!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
1) is fixed. I'll try to figure out 2) today
Attachment #224208 - Flags: superreview?(sspitzer)
David, your fix for searchTermsOverlay.js seems to be working. Thanks
Comment on attachment 224208 [details] [diff] [review]
fix for empty rows getting added switching from match all

sr=sspitzer (acting super reviewer while mscott is on vacation)
Attachment #224208 - Flags: superreview?(sspitzer) → superreview+
searchTermOverlay.js patch checked into both trunk and branch. re-resolving.
Status: REOPENED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → FIXED
Sorry David, but I've to reopen this bug again...

In Thunderbird open "Edit > Find > Search Addresses". The dialog includes the new "Match all messages" entity/option. If this option would make sense in this dialog, we would need a second/different entity "Match all addresses". But I believe the option "Match all ..." doesn't make any sense in the search addresses dialog. Nobody needs to find all addresses...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Alexander, can you open a new, different bug for that regression? Thx.
Status: REOPENED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → FIXED
Created bug 340489
No longer blocks: 340489
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
Duplicate of this bug: 311777
You need to log in before you can comment on or make changes to this bug.