Last Comment Bug 668017 - Context menus on objects are lost with content selection
: Context menus on objects are lost with content selection
Status: VERIFIED FIXED
[inbound]
: regression, verified-aurora
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: P2 normal (vote)
: Firefox 7
Assigned To: Wesley Johnston (:wesj)
:
Mentors:
: 668465 (view as bug list)
Depends on:
Blocks: 661388 667071
  Show dependency treegraph
 
Reported: 2011-06-28 13:45 PDT by Aaron Train [:aaronmt]
Modified: 2011-08-04 12:32 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (1.09 KB, patch)
2011-06-28 17:01 PDT, Wesley Johnston (:wesj)
mbrubeck: review+
Details | Diff | Review

Description Aaron Train [:aaronmt] 2011-06-28 13:45:59 PDT
Mozilla/5.0 (Android; Linux armv7l; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 Fennec/7.0a1
Devices: Nexus S, Nexus One
OS: 2.3.4

Currently when you tap and hold to open a context menu on objects such as <video> and <audio> they do not appear as the long tap on the object is mistaken for a selection.

Try the demo URLs and attempt to open their context menus:

1. http://terrillthompson.com/tests/html5-audio.html
2. http://snapshot.opera.com/resources/BigBuckBunny.html
Comment 1 Aaron Train [:aaronmt] 2011-06-28 13:52:21 PDT
This also exhibits the side affect of being able to back out of the preferences window if you attempt to check for errors or such (bug 667517).
Comment 2 Wesley Johnston (:wesj) 2011-06-28 17:01:52 PDT
Created attachment 542672 [details] [diff] [review]
Patch

Need to test/think about this a bit more, but I think context menus should probably always win over text selection. Looking into what's going on with the prefs pane...
Comment 3 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-06-29 14:59:49 PDT
This also occurs with about:home and if you long tap on one of the links from "Your tabs from last time"  What ends up happening is that the Nightly logo icon gets highlighted as a selection.
Comment 4 Marco Bonardo [::mak] 2011-06-30 06:05:28 PDT
http://hg.mozilla.org/mozilla-central/rev/ee430647729b
Comment 5 Aaron Train [:aaronmt] 2011-06-30 06:19:53 PDT
*** Bug 668465 has been marked as a duplicate of this bug. ***
Comment 6 Aaron Train [:aaronmt] 2011-07-11 08:08:15 PDT
Verified on Nightly:

Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110711 Firefox/8.0a1 

Verified on Aurora:

Mozilla/5.0 (Android; Linux armv7l; rv:7.0a2) Gecko/20110711 Firefox/7.0a2 Fennec/7.0a2

Note You need to log in before you can comment on or make changes to this bug.