Make it easier for non-Mozilla devs to get and use the JavaScript Debug Shell

RESOLVED FIXED

Status

Release Engineering
General
P5
enhancement
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: gkw, Assigned: lsblakk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [release][automation])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
+++ This bug was initially created as a clone of Bug #543463 +++

Now that we have an opt js shell being built, why not have a debug version appearing in the -debug/ folders as well?
(Reporter)

Comment 1

7 years ago
The main benefit is that this will help regression testing for js assertions.
Ah. Then this is just fallout from the way bug 400083 is implemented.
Assignee: general → nobody
No longer blocks: 555287, 555288, 652719, 663108, 663796
Component: JavaScript Engine → Release Engineering
Depends on: 400083
No longer depends on: 667295
Product: Core → mozilla.org
QA Contact: general → release
Version: Trunk → other

Updated

7 years ago
Priority: -- → P5
Whiteboard: [release][automation]
(Assignee)

Comment 5

6 years ago
Created attachment 615816 [details] [diff] [review]
also copy jsshell files to the nightly debug archive (tested)

just because i hate regexes...have adjusted this to also pick up the jsshell files per platform.
Assignee: nobody → lsblakk
Status: NEW → ASSIGNED
Attachment #615816 - Flags: review?(aki)

Updated

6 years ago
Attachment #615816 - Flags: review?(aki) → review+
(Assignee)

Comment 6

6 years ago
Comment on attachment 615816 [details] [diff] [review]
also copy jsshell files to the nightly debug archive (tested)

landed: http://hg.mozilla.org/build/tools/rev/96bbe6d5b09f

updated the hg-build-tools clone on ffxbld@stage so that the next run of this script will copy over the necessary files.

please reopen if this doesn't occur for some reason and I'll look into it.
Attachment #615816 - Flags: checked-in+
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.