WSEnable.exe needs to have its manifest set to requireAdministrator

RESOLVED FIXED in Thunderbird 8.0

Status

Thunderbird
OS Integration
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: sid0, Assigned: sid0)

Tracking

({regression})

unspecified
Thunderbird 8.0
regression

Thunderbird Tracking Flags

(thunderbird6 fixed, thunderbird7 fixed)

Details

Attachments

(1 attachment)

Created attachment 544064 [details] [diff] [review]
fix

I noticed this while setting it up on a new computer -- this was broken by bug 567497.
Attachment #544064 - Flags: review?(dbienvenu)

Updated

7 years ago
Attachment #544064 - Flags: review?(dbienvenu) → review+

Comment 1

7 years ago
Sid and I think that this is broken in 3.1.11 and 5.0, so it's something support and qa should know about.

The manifestation of the bug is that when the default mail app prompt comes up, and the user checks the "enable windows search" checkbox, we don't remember that setting.

I had a separate issue w/ and w/o this patch that toggling that check box from the options UI didn't work. I think that's not related to this issue, but I don't know for sure. With this patch, the startup prompt does work.
(Assignee)

Updated

7 years ago
Keywords: regression
(Assignee)

Comment 2

7 years ago
https://hg.mozilla.org/comm-central/rev/cc06bf5d9186
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 8.0
(Assignee)

Comment 3

7 years ago
Comment on attachment 544064 [details] [diff] [review]
fix

Could we get this into aurora and beta? This is a regression fix with practically zero risk.
Attachment #544064 - Flags: approval-mozilla-beta?
Attachment #544064 - Flags: approval-mozilla-aurora?
Comment on attachment 544064 [details] [diff] [review]
fix

Approved as not part of the build.
Attachment #544064 - Flags: approval-mozilla-beta?
Attachment #544064 - Flags: approval-mozilla-beta+
Attachment #544064 - Flags: approval-mozilla-aurora?
Attachment #544064 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 5

7 years ago
Comment on attachment 544064 [details] [diff] [review]
fix

Oops, my bad! I should have asked for approval-comm-aurora and comm-beta. Never mind.
Attachment #544064 - Flags: approval-mozilla-beta+
Attachment #544064 - Flags: approval-mozilla-aurora+
Attachment #544064 - Flags: approval-comm-beta?
Attachment #544064 - Flags: approval-comm-aurora?
Attachment #544064 - Flags: approval-comm-beta?
Attachment #544064 - Flags: approval-comm-beta+
Attachment #544064 - Flags: approval-comm-aurora?
Attachment #544064 - Flags: approval-comm-aurora+
(Assignee)

Comment 6

6 years ago
https://hg.mozilla.org/releases/comm-aurora/rev/92e34294d51f
https://hg.mozilla.org/releases/comm-beta/rev/379b80ecfc0b
status-thunderbird6: --- → fixed
status-thunderbird7: --- → fixed
(Assignee)

Updated

6 years ago
Duplicate of this bug: 677353
You need to log in before you can comment on or make changes to this bug.