Last Comment Bug 670036 - Quicktime Plugin: WAV files play once, then never again
: Quicktime Plugin: WAV files play once, then never again
Status: VERIFIED FIXED
[qa!]
: verified-aurora, verified-beta
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: mozilla9
Assigned To: Steven Michaud [:smichaud] (Retired)
:
Mentors:
: 707526 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-07 16:05 PDT by Lance Olsen
Modified: 2011-12-05 07:09 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
fixed


Attachments
screen shot of my firebug console after trying to reload wav file (76.44 KB, image/png)
2011-07-07 16:05 PDT, Lance Olsen
no flags Details

Description Lance Olsen 2011-07-07 16:05:57 PDT
Created attachment 544646 [details]
screen shot of my firebug console after trying to reload wav file

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_7) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.100 Safari/534.30

Steps to reproduce:

I tried to play a wav file, for example: http://www.dailywav.com/0711/terribleWisdom.wav


Actual results:

The file plays the first time using the quicktime plugin (v 7.6.6). When I reload, there is no sound and no player. Firebug indicates that the browser has cached the file locally.


Expected results:

The browser should have played the cached version.
Comment 1 Lance Olsen 2011-07-16 11:36:58 PDT
Just updated to 5.0.1 and this still happens. Note that the User Agent above is incorrect (thats just what I was using when I submitted the bug).

Is there anyone working on this?
Comment 2 Lance Olsen 2011-07-26 12:19:00 PDT
Could someone help me understand why my bug report has gotten no replies? Are other people not able to reproduce it? Is this a known issue?

BTW, my actual User Agent is:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Comment 3 Richard Newman [:rnewman] 2011-10-03 13:18:17 PDT
I just got a user report of this same issue:

---
- Log in the Forums Site and go to your User CP and then Edit Options.
- Scroll down until you find some links saying Sound1 Sound2 etc. If I click, say on Sound1, then Sound 3, they both play OK. But if I click on Sound1 again, it doesn't play. I get a small window in which the sound is played normally, and the progress bar shows the sound is being reloaded, but it is not played a second time.
---

Up-to-date Quicktime, running Firefox 7 AFAIK.

I get similar behavior when I try to reproduce in Aurora:

* First time, sound opens in a new tab and plays fine.
* Second time, I get a popup saying that Quicktime needs to install software.
* Third time, I get nothing at all. I don't get a progress bar.

Attempting to reproduce in Nightly, loading the sound file directly (http://forum.m1911.org/sounds/Sound1.wav) does *nothing at all*; Web Console shows the file is downloaded with a 200 status, but nothing plays. stdout prints:

WARNING: null plugin instance during PaintPlugin: file /Users/rnewman/moz/hg/services-central/layout/generic/nsObjectFrame.cpp, line 1752
WARNING: null plugin instance during PaintPlugin: file /Users/rnewman/moz/hg/services-central/layout/generic/nsObjectFrame.cpp, line 1752
WARNING: null plugin instance during PaintPlugin: file /Users/rnewman/moz/hg/services-central/layout/generic/nsObjectFrame.cpp, line 1752
For audio/x-wav found plugin QuickTime Plugin.plugin
WARNING: null plugin instance during PaintPlugin: file /Users/rnewman/moz/hg/services-central/layout/generic/nsObjectFrame.cpp, line 1752
WARNING: null plugin instance during PaintPlugin: file /Users/rnewman/moz/hg/services-central/layout/generic/nsObjectFrame.cpp, line 1752

I have

  QuickTime Plug-in 7.6.6

installed.
Comment 4 Steven Michaud [:smichaud] (Retired) 2011-10-03 13:36:26 PDT
I've bumped into this bug (I think) while trying to fix bug 687610
(see bug 687610 comment	#46 and	bug 687610 comment #50).

But what I've seen doesn't match exactly what's reported here, so
Lance and Richard, please do some tests for me.

1) Does this bug also happen in 32-bit mode?

2) Does this bug still happen if you first clear the network cache?
Comment 5 Richard Newman [:rnewman] 2011-10-03 13:54:59 PDT
User reported versions:

---
- Mac OS-X Lion 10.7.1
- Firefox 7.0.1
- QuickTime player 10.1 (501)
- QuickTime plug-in 7.7.1
---
Comment 6 Lance Olsen 2011-10-03 14:27:44 PDT
Steven, thanks for looking into this.

I rebooted in 32-bit mode, and this still happens.

Clearing the network cache fixes this. Also doing a shift-reload will fix it.

I am currently running
Mac OS X 10.6.8
Firefox 7.0.1
QuickTime Player 10.0 (128)
QuickTime Plugin 7.6.6
Comment 7 Steven Michaud [:smichaud] (Retired) 2011-10-03 14:47:30 PDT
> I rebooted in 32-bit mode, and this still happens.

What do you mean by this?

What I meant for you to do is the following:

1) Quit FF.
2) Right-click on your FF distro and choose Get Info.
3) Check the box labeled "Open in 32-bit mode".
4) Double-click on your FF distro to run it.
...
Comment 8 Lance Olsen 2011-10-03 14:53:06 PDT
Ah, yes I rebooted my whole machine in 32-bit mode.

Following your instructions to start Firefox in 32-bit mode fixes this.
Comment 9 Steven Michaud [:smichaud] (Retired) 2011-10-03 15:06:05 PDT
Thanks, Lance and Richard, for the info.

> User reported versions:
>
> ---
> - Mac OS-X Lion 10.7.1         <---
> - Firefox 7.0.1
> - QuickTime player 10.1 (501)
> - QuickTime plug-in 7.7.1
> ---

I don't expect this bug to happen on OS X 10.7.X, so I'm puzzled by this.
Comment 10 Steven Michaud [:smichaud] (Retired) 2011-10-07 07:33:30 PDT
This bug should be fixed by my patch for bug 687610.

Here's a tryserver build made from that patch:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/smichaud@pobox.com-fa3385a54298/try-macosx/fennec-10.0a1.en-US.mac.dmg

Please try it out, and let us know your results.

> I don't expect this bug to happen on OS X 10.7.X, so I'm puzzled by this.

I'm now able to reproduce this bug on OS X 10.7.X.
Comment 11 Lance Olsen 2011-11-18 10:55:34 PST
Steven,
I just saw this post, and your link is broken now. Can you repost it?

Lance

(In reply to Steven Michaud from comment #10)
> This bug should be fixed by my patch for bug 687610.
> 
> Here's a tryserver build made from that patch:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/smichaud@pobox.com-
> fa3385a54298/try-macosx/fennec-10.0a1.en-US.mac.dmg
> 
> Please try it out, and let us know your results.
> 
> > I don't expect this bug to happen on OS X 10.7.X, so I'm puzzled by this.
> 
> I'm now able to reproduce this bug on OS X 10.7.X.
Comment 12 Steven Michaud [:smichaud] (Retired) 2011-11-18 11:04:50 PST
You don't need that link.  My patch for bug 687610 is now in current mozilla-central, aurora and beta nightlies (at ftp://ftp.mozilla.org/pub/firefox/nightly/).

And this bug should now be fixed (I forgot to mark it fixed earlier).
Comment 13 Steven Michaud [:smichaud] (Retired) 2011-12-04 14:55:34 PST
*** Bug 707526 has been marked as a duplicate of this bug. ***
Comment 14 Vlad [QA] 2011-12-05 07:09:22 PST
The issue is fixed on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0) Gecko/20100101 Firefox/9.0 beta 4
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a2) Gecko/20111204 Firefox/10.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a1) Gecko/20111205 Firefox/11.0a1

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0) Gecko/20100101 Firefox/9.0 beta 4
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0a2) Gecko/20111204 Firefox/10.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0a1) Gecko/20111205 Firefox/11.0a1

I have reloaded the .wav from the description for several time and it plays every time.
Considering this, setting resolution to VERIFIED FIXED.

Note You need to log in before you can comment on or make changes to this bug.