The default bug view has changed. See this FAQ.

Opening account manager (account settings) from compose window fails

RESOLVED FIXED in Thunderbird 12.0

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: AlexIhrig, Assigned: squib)

Tracking

({regression})

Trunk
Thunderbird 12.0
x86_64
Windows 7
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Opening the account manager from compose window -> Tools menu fails without an error in error console.

Tested with Thunderbird 5.0 and todays 8.0-comm-central build in safe-mode.
WFM on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:7.0a2) Gecko/20110713 Thunderbird/7.0a2.

Alex can you find the regression window ?
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 2

6 years ago
Hmm,

maybe only a problem with my 'old' profile. Testing with a new, clean profile WFM. Testing with my 'old' profile in safe-mode doesn't work.
Alex - does deleteing localstore.rdf in your old profile helps ?
Duplicate of this bug: 676477
regression range http://hg.mozilla.org/comm-central/pushloghtml?startdate=2011-03-07+03%3A00&enddate=2011-03-08+06%3A00
works 20110307
fails 20110308
puts the mark on Bug 549045

reproduces in safe mode with 2011-09-19 build
Blocks: 549045
Keywords: regressionwindow-wanted
Based on the comments here and the duplicate thread, we're going to need to get some idea of a test profile that exhibits the problem (e.g. I can't reproduce)
Keywords: qawanted, testcase-wanted
I've just used a pretty clean test profile in safe mode and one imap account.
1. open TB
2. open compose
3. tools | account settings

results: no account settings, nothing in error console
at startup: error console has
 Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0

I'll try to send you a profile

Comment 8

5 years ago
I can see this too, on TB8, linux, on a used profile. On TB11, relativelly clean profile it work fine.

Updated

5 years ago
Summary: Opening account manager from compose window fails → Opening account manager (account settings) from compose window fails
(Assignee)

Comment 9

5 years ago
Taking this, since I inadvertently fixed it as part of another bug.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
(In reply to Jim Porter (:squib) from comment #9)
> Taking this, since I inadvertently fixed it as part of another bug.

If I read Bug 526998 Comment 13 correctly, the other bug is bug 526998, which is ready to land.
Depends on: 526998
(Assignee)

Comment 11

5 years ago
Fixed by bug 526998.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Keywords: qawanted, testcase-wanted
Target Milestone: --- → Thunderbird 12.0
(Assignee)

Updated

5 years ago
Duplicate of this bug: 672491
You need to log in before you can comment on or make changes to this bug.